Bug 173315 - selections often include extra whitespace at the end of lines
Summary: selections often include extra whitespace at the end of lines
Status: RESOLVED DUPLICATE of bug 188528
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 2.1
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 181988 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-22 18:22 UTC by Orion Poplawski
Modified: 2009-04-29 17:24 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Orion Poplawski 2008-10-22 18:22:04 UTC
Version:           2.1 (using KDE 4.1.2)
OS:                Linux
Installed from:    Fedora RPMs

Often when selecting output on the konsole screen, I get extra whitespace at the end instead of a newline where expected:

"find /opt/local/rsi/idl70/ -newer /opt/local/rsi/idl70/idl70.ldd                                 "

I use 91 character wide terminals.  Don't know if that makes a difference.
Comment 1 Martin van Es 2009-02-04 10:36:45 UTC
I can confirm this behavior in 4.2.0 (konsole 2.2) and note that this is as a regression from KDE 3. I tested in 3.5.10 (konsole 1.6.6) and there's no extra whitespace when copying the output of the exact same command (ls -sla in homedir).
Comment 2 Matthew Woehlke 2009-02-07 02:35:58 UTC
Duplicate of #181988. I'll close that one as this is older, but see the comments there. In particular, it seems this only happens to lines in the scrollback buffer.
Comment 3 Matthew Woehlke 2009-02-07 02:36:04 UTC
*** Bug 181988 has been marked as a duplicate of this bug. ***
Comment 4 Oliver Henshaw 2009-04-27 17:32:37 UTC
This can be trivially reproduced by copying empty lines from the current page of konsole and comparing them to empty lines copied from the scrollback buffer.
Comment 5 Kurt Hindenburg 2009-04-29 17:24:17 UTC
This has been fixed for lines not in the history;  188528 is about history lines.

*** This bug has been marked as a duplicate of bug 188528 ***