Bug 172997 - #5 QMutex::lock (this=0x2529fe2f221efe75) at thread/qmutex.cpp:153
Summary: #5 QMutex::lock (this=0x2529fe2f221efe75) at thread/qmutex.cpp:153
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 173013 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-17 00:15 UTC by Dan
Modified: 2008-10-18 11:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan 2008-10-17 00:15:19 UTC
Version:           svn (using Devel)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Compiled sources

Application: Kopete (kopete), signal SIGSEGV
Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 140632939697920 (LWP 12786)]
[New Thread 1098967376 (LWP 12799)]
[New Thread 1090574672 (LWP 12798)]
[KCrash handler]
#5  QMutex::lock (this=0x2529fe2f221efe75) at thread/qmutex.cpp:153
#6  0x00007fe7a607402e in QCoreApplication::postEvent (receiver=0x24a9d60, 
    event=0x24e0b90, priority=0) at kernel/qcoreapplication.cpp:977
#7  0x00007fe794eefbc8 in Client::close (this=0x1a88d80)
    at /usr/local/src/svn/kdenetwork/kopete/protocols/oscar/liboscar/client.cpp:272
#8  0x00007fe79521b83d in OscarAccount::logOff (this=0x17ed140, 
    reason=Kopete::Account::ConnectionReset)
    at /usr/local/src/svn/kdenetwork/kopete/protocols/oscar/oscaraccount.cpp:186
#9  0x00007fe79521bae9 in OscarAccount::slotSocketError (this=0x17ed140, 
    errCode=<value optimized out>, errString=@0x7fffb06e03e0)
    at /usr/local/src/svn/kdenetwork/kopete/protocols/oscar/oscaraccount.cpp:910
#10 0x00007fe79522135f in OscarAccount::qt_metacall (this=0x17ed140, 
    _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, 
    _a=0x7fffb06e0160)
    at /usr/local/src/svn/kdenetwork/b/kopete/protocols/oscar/oscaraccount.moc:144
#11 0x00007fe7954ac9d5 in ICQAccount::qt_metacall (this=0x2529fe2f221efe75, 
    _c=38669200, _id=0, _a=0x0)
    at /usr/local/src/svn/kdenetwork/b/kopete/protocols/oscar/icq/icqaccount.moc:138
#12 0x00007fe7a608830c in QMetaObject::activate (sender=0x1a88d80, 
    from_signal_index=<value optimized out>, to_signal_index=19, argv=0x0)
    at kernel/qobject.cpp:3028
#13 0x00007fe794eec996 in Client::socketError (this=0x2529fe2f221efe75, _t1=1, 
    _t2=<value optimized out>)
    at /usr/local/src/svn/kdenetwork/b/kopete/protocols/oscar/liboscar/client.moc:344
#14 0x00007fe794eee78c in Client::determineDisconnection (this=0x1a88d80, 
    code=1, string=@0x7fffb06e03e0)
    at /usr/local/src/svn/kdenetwork/kopete/protocols/oscar/liboscar/client.cpp:1661
#15 0x00007fe794ef7984 in Client::qt_metacall (this=0x1a88d80, 
    _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, 
    _a=0x7fffb06e03b0)
    at /usr/local/src/svn/kdenetwork/b/kopete/protocols/oscar/liboscar/client.moc:232
#16 0x00007fe7a608830c in QMetaObject::activate (sender=0x19a3d50, 
    from_signal_index=<value optimized out>, to_signal_index=7, argv=0x0)
    at kernel/qobject.cpp:3028
#17 0x00007fe794f1d806 in Connection::socketError (this=0x2529fe2f221efe75, 
    _t1=1, _t2=<value optimized out>)
    at /usr/local/src/svn/kdenetwork/b/kopete/protocols/oscar/liboscar/connection.moc:114
#18 0x00007fe794f1e3a8 in Connection::streamSocketError (this=0x19a3d50, 
    code=1)
    at /usr/local/src/svn/kdenetwork/kopete/protocols/oscar/liboscar/connection.cpp:267
#19 0x00007fe794f1e7b6 in Connection::qt_metacall (this=0x19a3d50, 
    _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, 
    _a=0x7fffb06e0520)
    at /usr/local/src/svn/kdenetwork/b/kopete/protocols/oscar/liboscar/connection.moc:85
#20 0x00007fe7a608830c in QMetaObject::activate (sender=0x1426750, 
    from_signal_index=<value optimized out>, to_signal_index=6, argv=0x0)
    at kernel/qobject.cpp:3028
#21 0x00007fe794f09ce1 in Stream::error (this=0x2529fe2f221efe75, _t1=1)
    at /usr/local/src/svn/kdenetwork/b/kopete/protocols/oscar/liboscar/stream.moc:93
#22 0x00007fe794f088ba in ClientStream::socketError (this=0x1426750, 
    socketError=QAbstractSocket::RemoteHostClosedError)
    at /usr/local/src/svn/kdenetwork/kopete/protocols/oscar/liboscar/oscarclientstream.cpp:299
#23 0x00007fe794f08a1e in ClientStream::qt_metacall (this=0x1426750, 
    _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, 
    _a=0x7fffb06e06b0)
    at /usr/local/src/svn/kdenetwork/b/kopete/protocols/oscar/liboscar/oscarclientstream.moc:87
#24 0x00007fe7a608830c in QMetaObject::activate (sender=0x14af430, 
    from_signal_index=<value optimized out>, to_signal_index=12, argv=0x0)
    at kernel/qobject.cpp:3028
#25 0x00007fe7a3d5b561 in QAbstractSocket::error (this=0x2529fe2f221efe75, 
    _t1=QAbstractSocket::RemoteHostClosedError)
    at .moc/release-shared/moc_qabstractsocket.cpp:146
#26 0x00007fe7a3d5ec34 in QAbstractSocketPrivate::readFromSocket (
    this=0x2e579f0) at socket/qabstractsocket.cpp:990
#27 0x00007fe7a3d5eda7 in QAbstractSocketPrivate::canReadNotification (
    this=0x2e579f0) at socket/qabstractsocket.cpp:549
#28 0x00007fe7a3d50261 in QReadNotifier::event (this=<value optimized out>, 
    e=0x24e0b90) at socket/qnativesocketengine.cpp:974
#29 0x00007fe7a71f3acd in QApplicationPrivate::notify_helper (this=0xf4d160, 
    receiver=0x2c68c10, e=0x7fffb06e0bc0) at kernel/qapplication.cpp:3809
#30 0x00007fe7a71fb6aa in QApplication::notify (this=0x7fffb06e19b0, 
    receiver=0x2c68c10, e=0x7fffb06e0bc0) at kernel/qapplication.cpp:3774
#31 0x00007fe7a658089b in KApplication::notify (this=0x7fffb06e19b0, 
    receiver=0x2c68c10, event=0x7fffb06e0bc0)
    at /usr/local/src/svn/kdelibs/kdeui/kernel/kapplication.cpp:307
#32 0x00007fe7a607435e in QCoreApplication::notifyInternal (
    this=0x7fffb06e19b0, receiver=0x2c68c10, event=0x7fffb06e0bc0)
    at kernel/qcoreapplication.cpp:593
#33 0x00007fe7a609c059 in socketNotifierSourceDispatch (source=0xf4f290)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#34 0x00007fe7a0161951 in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.0
#35 0x00007fe7a016502d in g_main_context_iterate ()
   from /usr/local/lib/libglib-2.0.so.0
#36 0x00007fe7a01651eb in g_main_context_iteration ()
   from /usr/local/lib/libglib-2.0.so.0
#37 0x00007fe7a609bdef in QEventDispatcherGlib::processEvents (this=0xf49cd0, 
    flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:325
#38 0x00007fe7a72828ff in QGuiEventDispatcherGlib::processEvents (
    this=0x2529fe2f221efe75, flags=<value optimized out>)
    at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007fe7a6072cc2 in QEventLoop::processEvents (
    this=<value optimized out>, flags={i = -1334964768})
    at kernel/qeventloop.cpp:149
#40 0x00007fe7a6072e4d in QEventLoop::exec (this=0x7fffb06e0e20, flags=
      {i = -1334964672}) at kernel/qeventloop.cpp:200
#41 0x00007fe7a764ff35 in QDialog::exec (this=0x16a2f00)
    at dialogs/qdialog.cpp:453
#42 0x00007fe7a64eb8fa in KDialogQueue::Private::slotShowQueuedDialog (
    this=0x14ad1c0)
    at /usr/local/src/svn/kdelibs/kdeui/dialogs/kdialog.cpp:1051
#43 0x00007fe7a64eb9fd in KDialogQueue::qt_metacall (this=0x1344b70, 
    _c=QMetaObject::InvokeMetaMethod, _id=252, _a=<value optimized out>)
    at /usr/local/src/svn/kdelibs/b/kdeui/kdialogqueue_p.moc:65
#44 0x00007fe7a608830c in QMetaObject::activate (sender=0x28e0d10, 
    from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0)
    at kernel/qobject.cpp:3028
#45 0x00007fe7a608e41f in QSingleShotTimer::timerEvent (this=0x28e0d10)
    at kernel/qtimer.cpp:300
#46 0x00007fe7a6082d73 in QObject::event (this=0x28e0d10, e=0x24e0b90)
    at kernel/qobject.cpp:1117
#47 0x00007fe7a71f3acd in QApplicationPrivate::notify_helper (this=0xf4d160, 
    receiver=0x28e0d10, e=0x7fffb06e1670) at kernel/qapplication.cpp:3809
#48 0x00007fe7a71fb6aa in QApplication::notify (this=0x7fffb06e19b0, 
    receiver=0x28e0d10, e=0x7fffb06e1670) at kernel/qapplication.cpp:3774
#49 0x00007fe7a658089b in KApplication::notify (this=0x7fffb06e19b0, 
    receiver=0x28e0d10, event=0x7fffb06e1670)
    at /usr/local/src/svn/kdelibs/kdeui/kernel/kapplication.cpp:307
#50 0x00007fe7a607435e in QCoreApplication::notifyInternal (
    this=0x7fffb06e19b0, receiver=0x28e0d10, event=0x7fffb06e1670)
    at kernel/qcoreapplication.cpp:593
#51 0x00007fe7a609f51e in QTimerInfoList::activateTimers (this=0xf503d0)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 0x00007fe7a609be7d in timerSourceDispatch (source=<value optimized out>)
    at kernel/qeventdispatcher_glib.cpp:166
#53 0x00007fe7a0161951 in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.0
#54 0x00007fe7a016502d in g_main_context_iterate ()
   from /usr/local/lib/libglib-2.0.so.0
#55 0x00007fe7a01651eb in g_main_context_iteration ()
   from /usr/local/lib/libglib-2.0.so.0
#56 0x00007fe7a609bdef in QEventDispatcherGlib::processEvents (this=0xf49cd0, 
    flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:325
#57 0x00007fe7a72828ff in QGuiEventDispatcherGlib::processEvents (
    this=0x2529fe2f221efe75, flags=<value optimized out>)
    at kernel/qguieventdispatcher_glib.cpp:204
#58 0x00007fe7a6072cc2 in QEventLoop::processEvents (
    this=<value optimized out>, flags={i = -1334961952})
    at kernel/qeventloop.cpp:149
#59 0x00007fe7a6072e4d in QEventLoop::exec (this=0x7fffb06e1920, flags=
      {i = -1334961872}) at kernel/qeventloop.cpp:200
#60 0x00007fe7a607528d in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:851
#61 0x000000000044873c in main (argc=1, argv=0x7fffb06e2778)
    at /usr/local/src/svn/kdenetwork/kopete/kopete/main.cpp:102
#0  0x00007fe7a0f031a1 in ?? () from /lib64/libc.so.6
Comment 1 Roman Jarosz 2008-10-17 09:37:27 UTC
*** Bug 173013 has been marked as a duplicate of this bug. ***
Comment 2 Roman Jarosz 2008-10-17 10:01:20 UTC
SVN commit 872433 by rjarosz:

Fix crash caused by my commit 871882, sorry!
The StageOne/Two tasks are already deleted when connection is closed.
Delete StageTwoTask right after the task has finished, so we don't leave it in memory till we close connection.

BUG: 172997
CCBUG: 160359



 M  +55 -62    client.cpp  
 M  +0 -5      client.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=872433
Comment 3 Roman Jarosz 2008-10-18 11:16:03 UTC
SVN commit 872809 by rjarosz:

Backport commits 871882 and 872433
Fix crash on login.

BUG: 172997



 M  +61 -54    client.cpp  
 M  +0 -5      client.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=872809