Bug 172858 - Okular plugin for other browsers
Summary: Okular plugin for other browsers
Status: RESOLVED UPSTREAM
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Unspecified
: VLO wishlist with 77 votes (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-15 13:37 UTC by Mirko Ferrari
Modified: 2011-05-08 04:39 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Ferrari 2008-10-15 13:37:12 UTC
Version:            (using KDE 4.1.2)
Installed from:    Ubuntu Packages

Okular is a great document viewer, but for people who don't use Konqueror as default browser, there is no chance of viewing pdf documents directly from the browser other than installing another software (like acrobat reder).

I'd like to have an okular plugin usable also in Firefox, without the need of installing extra pdf viewers.
Comment 1 Pino Toscano 2008-10-15 20:28:06 UTC
Not sure how this is doable (nor easy).
Comment 2 Tobias Koenig 2008-10-16 19:55:20 UTC
Hej,

I've written a plugin for KDE3 some time ago, which allowed you to use
KParts as plugins inside Netscape/Mozilla/Firefox.
The code was based on the NetscapePlugin support that was provided by
Qt3. Unfortunately it is not in Qt4, so no chance to port it over.

The old code is in trunk/playground/utils/dragonegg

Ciao,
Tobias
Comment 3 Martin Klapetek 2008-11-12 11:55:54 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Giulio Guzzinati 2008-11-29 15:48:20 UTC
Isn't it possible to do this with mozplugger without disturbing the KDE team?

I use konqueror on my laptop so I have not tried this, but i did setup firefox on my dad's desktop pc  (running ubuntu) to display PDFs though evince

mozplugger:
http://mozplugger.mozdev.org/

a guide to use evince:
http://ubuntuforums.org/showthread.php?t=25685

what mozplugger does is precisely put the whole window of the application (minus the decoration at the borders, obviously) inside of you firefox tab.
Comment 5 Mirko Ferrari 2008-11-29 16:56:11 UTC
The whole point of this whish is to avoid the use of another pfd viewer. And to me using Evince or Acrobat Reader doesn't make any difference.

This request is to provide a native solution that comes bundled with KDE, not a workaround that some more experienced users could enable.
So if the developers say it is possible I'll wait, otherwhy I'll simply install Acrobat Reader in favour of Okular, since I don't like having two or more programs for the same function.
Comment 6 Pino Toscano 2008-11-29 17:06:24 UTC
@Mirko Ferrari:
note that Giulio Guzzinati is not saying you have to use evince or acroread with mozplugger, but that mozplugger is a generic solution for embedding any application (okular included) as browser plugin.
Did you try mozplugger instead of tagging it as "advanced solution"?
Comment 7 Martin Klapetek 2008-11-29 17:13:26 UTC
I'd like to see some other solution that mozplugger, because I have installed both gnome and kde and there's (default?) an evince mozplugger plugin in Fedora and it works terrible. In fact it doesn't really work me most of the time, the whole firefox window gets messed up and I can't read the pdf in that plugin anyway. I'm on a 64bit and maybe I'm just missing some configuration or something, don't know...
Comment 8 Giulio Guzzinati 2008-11-29 17:22:55 UTC
@Martin Klapetek i think the problem of being able to make mozplugger work with both of the desktops might be solved packaging two different configurations in packages that are separate from the base mozplugger package. This however does not solve the problem when you have both desktops installed. But having a plugin does not solve this either, because firefox is one and the same in both DEs, and so are his configuration.

If you tell me mozplugger sucks, however, it's another matter.
Comment 9 Mirko Ferrari 2008-11-29 17:35:41 UTC
@Pino Toscano:
I don't want any hybrid solution. I won't use mozplugger.
The point is "are Okular developers willing to integrate Okular in other browsers or not?"
If you don't want to develope a solution, or the team has other priorities, just tell us. It's very easy, because since I opened this request you haven't showed any willingness to tackle this request, while you should, because the most of KDE users don't use Konqueror as the main web browser.
Comment 10 Pino Toscano 2008-11-29 18:27:33 UTC
@Mirko Ferrari:
If you don't want to use a solution that potentially is already there, then it becomes your problem.
Regarding your "you haven't showed any willingness to tackle this request":
a) comment #1, #2 and #6 are coming from Okular developers (and if there was no willingness at all, there would had been no replies)
b) mozplugger is not an hybrid solution, but a generic solution
c) nobody is saying "go use mozplugger, this request is unuseful", otherwise it would have been written *already*, and this bug conseguentially closed
d) If you are not using KDE software, you cannot expect the very same level of integration and support than using KDE software. While I agree it can be a nice thing to have, it is *not* a priority
e) as I wrote in comment #1, this is NOT easily doable.
f) as last thing: writing such comments on your side makes me willing to just ignore this bug report. Please respect us, thanks, nobody is throwing you away.
Comment 11 Albert Astals Cid 2008-11-29 18:36:04 UTC
Ask Firefox developers if they are willing to release a library with a stable API for plugin developers.

When they have achieved it come back and we'll think about it, deal?

For your information KDE plugin API hasn't changed since 2001, Firefox has broken their API in each release since 2004 and there is NO library to develop Firefox plugins.

Besides throwing threats of not using the software doesn't make us sleep any worse, we aren't paid for developing okular and i can tell you we have enough problems already to have to deal with users that think their feature request is the only and most important one.
Comment 12 Mirko Ferrari 2008-11-29 19:06:47 UTC
This is going too far.
I'm not here for threatening anyone, it all stared from a simple request, by a user, not a developer.

It is better to close this bug since it's not easily doable, it's not a priority and there are no mozilla stable plugin API.

One thing I don't like on KDE developers side is that they always look pissed if someone ask them to improve something.
For example 2 or 3 weeks ago I went to #kde-dev irc channel asking if someone could fix some compiling issues on a plasmoid in trunk and the answer was: "Fix it youself". Should all KDE devs answer like this because they work for free?

That said I won't comment further on this bug report, do what you think it's best for your users.
Comment 13 Pino Toscano 2008-11-29 19:20:54 UTC
See, you're overexagerating now.

Nobody said your simple request was not valid, as otherwise it would have been already closed.
The discussion was calm and simple, until you came up with "no, i won't ever use anything else than exactly what I request", telling also that "you haven't
showed any willingness to tackle this request, while you should".
You say that "KDE developers side is that they always look pissed
if someone ask them to improve something.", but really what happened here as exactly the opposite. You cannot complain somebody did bite you, when you started biting us. This is not helpful to us, and to all the other commenters that brought calm and costructive comments to this bug report.
Comment 14 Daniel Barna 2009-01-07 12:54:27 UTC
Hi,
To make a comment on this issue: I also like okular very much (at least I liked kpdf: it was way faster than acroread, and had some other useful features - acroread might have come up with the same features by now, I don't know)

I would be happy using okular through mozplugger (it is anyway a general solution to use any programs within firefox), but it has some problems
(kde4-okular-4.1.3-4.7 from SuSE 11.1, and mozplugger-1.11.0 installed myself). 
It seems that I can not interact via the keyboard with okular, if it is running within firefox+mozplugger. Shortcuts do not work, and even if I click Edit/Find in the menu, I can not type anything into the search box. 

I don't know if this is a mozplugger or okular issue.

I also very strongly support the usability of okular within firefox, be it a direct okular plugin, or through mozplugger, I don't mind.

Cheers
Comment 15 Orion Poplawski 2009-04-28 22:38:17 UTC
okular/mozplugger/keyboard issue appears to be a Qt issue:

http://www.qtsoftware.com/developer/task-tracker/index_html?method=entry&id=249189

https://www.mozdev.org/bugs/show_bug.cgi?id=19196
Comment 16 Roderick Johnstone 2010-04-30 16:37:56 UTC
BTW the qt tracker mentioned in #15 was closed and migrated to: http://bugreports.qt.nokia.com/browse/QTBUG-3814
Comment 17 Jeremy Sanders 2010-05-19 18:06:10 UTC
I have a basic version of a firefox/opera okular plugin here:
 http://github.com/jeremysanders/okularplugin

It seems to mostly work for PDF, PS & DVI. It could support more files.

You need the rc file to be somewhere on the kde resource path to get the correct menus.

Sometimes the print dialog doesn't open for some reason.
Comment 18 Lukas Jirkovsky 2010-05-21 12:14:20 UTC
Wow! That's great! It works like a charm.

I made a PKGBUILD for ArchLinux users: http://aur.archlinux.org/packages.php?ID=37336
Comment 19 Pino Toscano 2010-12-09 12:55:55 UTC
Or better use a generic plugin for any KDE component (not just Okular):
http://kde-apps.org/content/show.php/KParts+Plugin?content=125066

I guess we can close this wish now, as there is a generic solution covering also Okular.