Bug 172432 - Desktop Grid: Hold window in place when moving to next/previous desktop
Summary: Desktop Grid: Hold window in place when moving to next/previous desktop
Status: RESOLVED DUPLICATE of bug 213847
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: Gentoo Packages Unspecified
: LO normal with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-09 07:22 UTC by Matt Whitlock
Modified: 2009-12-06 19:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Whitlock 2008-10-09 07:22:51 UTC
Version:            (using KDE 4.1.2)
Installed from:    Gentoo Packages

I use Super + mouse wheel over the client area of a window to move it to next/previous desktop.  With the Desktop Grid effect active, the window I am "taking with me" flies off the screen and then flies onto the screen from the other side as I arrive on the next/previous desktop.  It ought to stay in place while the rest of the windows slide (except any windows set to be on all desktops, of course).
Comment 1 Lubos Lunak 2009-01-01 23:07:47 UTC
DesktopGrid needs to also take into effect Worspace::movingClient somehow.
Comment 2 Martin Flöser 2009-12-06 19:45:55 UTC

*** This bug has been marked as a duplicate of bug 213847 ***