Bug 172371 - Google finance recent quotes doesn't work
Summary: Google finance recent quotes doesn't work
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-08 01:16 UTC by Andres Garcia
Modified: 2008-10-24 02:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Garcia 2008-10-08 01:16:55 UTC
Version:           4.1.2 (KDE 4.1.2) (using 4.1.2 (KDE 4.1.2), Mandriva Linux release 2009.0 (Official) for i586)
Compiler:          gcc
OS:                Linux (i686) release 2.6.27-desktop-0.rc8.2mnb

If you go the google finance page:

http://finance.google.com

at the right there is a column named 'Recent quotes', when you first enter the page it should should a few quotes from companies that are in the news, as you visit diferent companies, like:

http://finance.google.com/finance?q=goog

you get those quotes when you go back to the main page.

This used to work in 3.5 but no longer, the quotes are shown at all.

I am using kde 4.1.2 in a Mandriva 2009 release candidate.
Comment 1 Maksim Orlovich 2008-10-08 01:35:24 UTC
The fix would be:
--- ecma/kjs_window.cpp (revision 868136)
+++ ecma/kjs_window.cpp (working copy)
@@ -2553,7 +2556,7 @@
        return jsString("");
       return jsString( UString(url.path().isEmpty() ? QString("/") : url.path()) );
     case Port:
-      return jsString( UString(url.port() ? QString::number((int)url.port()) : QLatin1String("")) );
+      return jsString( UString(url.port() > 0 ? QString::number((int)url.port()) : QLatin1String("")) );
     case Protocol:
       return jsString( UString(url.protocol()+':') );
     case Search:


... Two changes due to KUrl behavior changes in about a week? Odd how that works sometimes.
Comment 2 Maksim Orlovich 2008-10-24 02:25:27 UTC
SVN commit 875314 by orlovich:

Don't return -1 for location.port when no port is set (regression due to change in KUrl semantics).
Fixes recent quotes on google finance page.
BUG:172371


 M  +1 -1      kjs_window.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=875314
Comment 3 Maksim Orlovich 2008-10-24 02:27:32 UTC
SVN commit 875315 by orlovich:

automatically merged revision 875314:
Don't return -1 for location.port when no port is set (regression due to change in KUrl semantics).
Fixes recent quotes on google finance page.
BUG:172371

 M  +1 -1      kjs_window.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=875315