Bug 172225 - Konqueror crashes when two new windows are closed (one after the other)
Summary: Konqueror crashes when two new windows are closed (one after the other)
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-05 19:42 UTC by Vivien Mallet
Modified: 2008-10-05 19:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vivien Mallet 2008-10-05 19:42:37 UTC
Version:            (using KDE 4.1.2)
OS:                Linux
Installed from:    Ubuntu Packages

Launch Konqueror twice, from krunner, so as to get to new windows. Then close them with ctrl+Q, in any order. You will get a crash.

You may find other variants that lead to the same crash. Like launching one Konqueror and getting the second window with ctrl+N.

Below are the backtraces:
Application: Konqueror (konqueror), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb608c940 (LWP 11967)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7f75410 in __kernel_vsyscall ()
#7  0xb7d58085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb7d59a01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb7d5110e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb4243122 in KHTMLGlobal::finalCheck ()
   from /usr/lib/kde4/lib/libkhtml.so.5
#11 0xb467a1ec in ?? () from /usr/lib/kde4/lib/kde4/libkhtmlpart.so
#12 0xb74b2e4f in QObjectCleanupHandler::clear () from /usr/lib/libQtCore.so.4
#13 0xb74b2ec0 in QObjectCleanupHandler::~QObjectCleanupHandler ()
   from /usr/lib/libQtCore.so.4
#14 0xb772ba4d in ?? () from /usr/lib/kde4/lib/libkdecore.so.5
#15 0xb7619deb in ?? () from /usr/lib/kde4/lib/libkdecore.so.5
#16 0xb7d5b084 in exit () from /lib/tls/i686/cmov/libc.so.6
#17 0xb7d43458 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#18 0x080484f1 in _start ()
#0  0xb7f75410 in __kernel_vsyscall ()
Comment 1 Maksim Orlovich 2008-10-05 19:57:23 UTC

*** This bug has been marked as a duplicate of bug 151453 ***