Bug 172188 - Clicking on "cancel" instead of "close chat" closes chat anyway
Summary: Clicking on "cancel" instead of "close chat" closes chat anyway
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 186822 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-05 12:17 UTC by Gerrit Visscher
Modified: 2009-03-23 01:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
A patch fixing this bug (401 bytes, patch)
2009-01-23 14:11 UTC, Tomas Trnka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerrit Visscher 2008-10-05 12:17:51 UTC
Version:           0.60.2 (using 4.1.2 (KDE 4.1.2), Gentoo)
Compiler:          x86_64-pc-linux-gnu-gcc
OS:                Linux (x86_64) release 2.6.26-gentoo-r1

When a chat partner wrote something a few seconds ago and you want to close the window, Kopete pops up a dialog and asks if you really want to do so. But clicking "cancel" closes the chat anyway (so does "close chat").
Expected behavior: Kopete should not close the chat window (okay, that was obvious).
Comment 1 Davide Ferrari 2008-10-20 17:58:12 UTC
I can confirm this bug.
Comment 2 Matt Rogers 2008-11-18 05:01:37 UTC
how can i reproduce this?
Comment 3 Davide Ferrari 2008-11-18 09:34:22 UTC
Try to close a chat window right after someone sent you a message. Then kopete will display a confirmation dialog... both options will close the dialog
Comment 4 Tomas Trnka 2009-01-23 14:11:52 UTC
Created attachment 30530 [details]
A patch fixing this bug

The bug was in KopeteChatWindow::closeEvent - the QCloseEvent comes marked as Accepted by default, so accept() is actually a no-op, but it's necessary to call ignore() when the user doesn't want to close the window.
Comment 5 Roman Jarosz 2009-01-23 14:42:55 UTC
SVN commit 915669 by rjarosz:

Fix bug 172188: Clicking on "cancel" instead of "close chat" closes chat anyway.
Patch by Tomáš Trnka. Thanks!

BUG: 172188
CCMAIL: TomTrnka@seznam.cz



 M  +3 -0      kopetechatwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915669
Comment 6 Roman Jarosz 2009-01-23 14:44:40 UTC
SVN commit 915670 by rjarosz:

Backport commit 915669.
Fix bug 172188: Clicking on "cancel" instead of "close chat" closes chat anyway.
Patch by Tomáš Trnka. Thanks!

CCBUG: 172188



 M  +3 -0      kopetechatwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915670
Comment 7 Davide Ferrari 2009-01-23 15:43:30 UTC
Thank you Tomáš and Roman :)
Comment 8 Matthias Fuchs 2009-03-23 01:43:57 UTC
*** Bug 186822 has been marked as a duplicate of this bug. ***