Bug 171544 - Invisible terminal - Manual split terminal don't show up
Summary: Invisible terminal - Manual split terminal don't show up
Status: RESOLVED FIXED
Alias: None
Product: yakuake
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 5 votes (vote)
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords:
: 175182 181896 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-23 17:38 UTC by Paweł Prażak
Modified: 2009-03-09 16:51 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screen shot of yakuake with invisible terminal and border (120.11 KB, image/png)
2009-01-18 05:11 UTC, Tom Helner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Prażak 2008-09-23 17:38:34 UTC
Version:           2.9.4-5.2 (using 4.1.67  KDE 4.1.67  KDE 4.2 >  20080918    release 1.2 , KDE:KDE4:UNSTABLE:Desktop / OPENSUSE_11.0)
Compiler:          gcc
OS:                Linux  x86_64  release 2.6.25.16-0.1-default

When i hit ctrl+alt+l or +t, or use context menu, terminal splits but don't show up, but when you type 'exit' in invisible terminal it closes, so it's runnig, it's just invisible.
Comment 1 Eike Hein 2008-09-23 17:44:48 UTC
I'm afraid I'm unable to reproduce this problem on any of my systems, nor have there been similar reports in the past, and the code related to terminal splits has not changed in any interesting way for the past couple of Yakuake versions (actually, not at all afair). 

This may be a graphics driver- or X-related issue of some kind.
Comment 2 Paweł Prażak 2008-09-25 11:47:40 UTC
I managed to solve this problem and you were right - it was graphics related. Sorry for false alarm ;) Great work with Yakuake, I love this app.
Comment 3 Eike Hein 2008-11-15 12:17:46 UTC
*** Bug 175182 has been marked as a duplicate of this bug. ***
Comment 4 Richard Johnson 2008-12-28 23:09:43 UTC
Kojot, could you please explain how you fixed this issue and how it was a graphics related issue? I just got a bug report in Ubuntu concerning this, as it only seems to occur for me when trying Yakuake in GNOME. Any extra info will be greatly appreciated. Thanks!
Comment 5 Paweł Prażak 2008-12-29 00:40:25 UTC
As far as I remember it was kwin / compiz or Qt related issue and lots of packages was from UNSTABLE repo.
I'm sure it was something wrong with my installation.

Now I use Yakuake 2.9.3 (KDE 4.1.3 "release 68.1", Qt: 4.4.3) on openSUSE 11.1 and it works great. (kwin compositing on)

I've checked on friend's Ubuntu 8.10 box (GNOME) and it seems to work well (both: compiz on and off), version: Yakuake 2.9.3 (KDE 4.1.3, Qt: 4.4.3)

Hope this helps a bit.
Comment 6 Pavol Rusnak 2009-01-14 16:53:48 UTC
I can reproduce on kde4-yakuake-2.9.4 with KDE 4.1.87 on openSUSE 11.1, regardles of Desktop effects, using Nvidia GFX card. Split in Konsole works OK.
Comment 7 Paweł Prażak 2009-01-14 21:21:42 UTC
I have the same issue since upgade to KDE 4.1.87 (regression?)
I have Nvidia gfx, and
Qt: 4.4.3
KDE: 4.1.87 (KDE 4.1.87 (KDE 4.2 >= 20090101)) "release 75.2"
Plasma Workspace: 0.3

It happens with both desktop effects on and off.
How can I help you with debugging or provide with extra info?
Comment 8 Renan Inácio 2009-01-15 10:09:35 UTC
I have exactly the same problem.
nvidia driver: 177.82
yakuake: 2.9.3
Qt: 4.4.3
KDE: 4.1.96 (KDE 4.1.96 (KDE 4.2 RC1))
using kubuntu experimental repository
also happened in 4.1.8x, which was Beta 2

If instead of splitting a tab, I set a hotkey to create a splitted one, it works. Splitting any terminal on an already-split-on-creation tab doesn't work.
Comment 9 Victor B. Gonzalez 2009-01-15 13:50:48 UTC
yeah, I just upgraded from Kubuntus 8.10 KDE 4.1.3 stable to KDE 4.2 RC1 and my Yakuake broke when it comes to splits. The upgrade went smooth and I have no idea what happened but everything else seems fine. 
Comment 10 Eike Hein 2009-01-15 13:59:39 UTC
Unfortunately I still can't reproduce this problem (also on KDE 4.1.87) on my own box, but I'm going to install a Kubuntu system along with their experimental KDE 4.2 packages in a virtual machine and check it out.
Comment 11 Victor B. Gonzalez 2009-01-15 14:01:55 UTC
Thank you Eike!

It's that attitude that makes Yakuake great! It's much appreciated!
Comment 12 Eike Hein 2009-01-15 15:01:51 UTC
Adding Robert Knight (Konsole maintainer) to the CC list on this bug, as while a workaround might be found in Yakuake, the underlying change/cause is likely going to be found in Konsole.
Comment 13 Eike Hein 2009-01-15 15:20:33 UTC
I've now been able to reproduce the problem. Right now it seems that the KPart instanciated for the split doesn't create the terminal emulation widget for some reason. The split does contain a Konsole::ViewSplitter widget (which is the "top-level" widget of a Konsole KPart), but it's empty. I have no idea why right now, but this does appear to go wrong inside the Konsole KPart somewhere.

Robert, any input would be appreciated if you can reproduce this on your system.
Comment 14 Tom Helner 2009-01-18 05:11:13 UTC
Created attachment 30372 [details]
screen shot of yakuake with invisible terminal and border
Comment 15 Tom Helner 2009-01-18 05:16:05 UTC
I have seen the same behavior in yakuake 2.9.3 in KDE beta 2 - RC1 on kubuntu 8.10. I also have a fat border of the same color as the "invisible terminal". I am wondering if these issues are related.
Comment 16 Eike Hein 2009-01-19 13:01:22 UTC
The "fat border" is also due to a change in Konsole during the 4.2 development cycle. I have informed Robert of this back in July, but so far haven't heard anything concrete back.
Comment 17 Robert Knight 2009-01-23 14:55:35 UTC
Hi folks,

Sorry I haven't replied yet.  Nothing immediately comes to mind about anything which might have changed between KDE 4.1 and 4.2 in the embedded Konsole which might cause this.  I'll try to check out recent versions of Yakuake over the weekend and have a look.
Comment 18 Eike Hein 2009-01-26 12:57:17 UTC
*** Bug 181896 has been marked as a duplicate of this bug. ***
Comment 19 Frederik Schwarzer 2009-01-26 15:56:28 UTC
I just want to add that this also applies to my Debian Box for the last few months. (So not Kubuntu-only) I haven't said anything yet because of the beginning of this report heading towards a graphics card issue and my intel driver comes from the experimental repository...
Comment 20 Kornel Szabo 2009-01-31 19:12:23 UTC
Hi everybody. The konsolepart also vanishes in ArchLinux :(
Comment 21 Ana Guerrero 2009-02-01 01:32:35 UTC
Hi,

I also have been able to reproduce this bug after I got a bug report about it in Debian:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=513554
Comment 22 Rutger 2009-02-03 04:38:37 UTC
I am experiencing the same problem running OpenSuse 11.1 with KDE 4.2. It worked in 4.1x.
Comment 23 Paulo Dias 2009-02-03 16:01:38 UTC
Same problem, any attempt to open a split results in a black window over the new splited window. menu and shortcut produces the same behaviour.

kubuntu 8.10, kde 4.2 final from ppa. radeon 6.10.0.

it worked before 4.2 and below.
Comment 24 Jakub Zakrzewski 2009-02-12 12:58:40 UTC
I confirm this problem exists on both my computers with KDE4 and Yakuake 2.9.3.
I updated from 2.9.3 and to 2.9.4 and problem still exists. One of my computers uses Radeon X550 and another one Intel graphic card.

I found:
"Yakuake 2.9.4 has a small bug that makes the splitter handles appear in the user-configured window background color (fallout from the background painting changes in that release). They're still there, but if your terminal background happens to be black, and the window background, too, they're effectively invisible. This is fixed in SVN, and the fix will be included in the next release."
on http://www.kde-apps.org/content/show.php?content=29153
Comment 25 Eike Hein 2009-02-13 13:09:48 UTC
The splitter handles are unrelated to this problem. As is the Yakuake version; the split code has not changed. The change is in KDE 4.2 vs. KDE 4.1.
Comment 26 Paulo Dias 2009-02-18 17:33:00 UTC
(In reply to comment #25)
> The splitter handles are unrelated to this problem. As is the Yakuake version;
> the split code has not changed. The change is in KDE 4.2 vs. KDE 4.1.

Hi Eike, did you had the time to fix this annoying bug?

best regards
Comment 27 Robert Knight 2009-02-18 17:53:53 UTC
> Hi Eike, did you had the time to fix this annoying bug?

No, its a problem in Konsole and he is waiting on me to fix it.
Comment 28 Paulo Dias 2009-03-03 16:38:38 UTC
(In reply to comment #27)
> > Hi Eike, did you had the time to fix this annoying bug?
> 
> No, its a problem in Konsole and he is waiting on me to fix it.

Hi Robert, so we'll need to wait for kde 4.3 for this bug to be fixed? Will the changes to Konsole fix the bug in Yakuake "automagically"?

Best regards and keep up the good work :)
Comment 29 Paulo Dias 2009-03-05 18:09:41 UTC
Just updated to kde 4.2.1, the yakuake bug still remains, didn't the konsole fix entered into the release in time? or is it more complicated then just backporting it to the 4.2 stable release bug fix and needs to be adressed in 4.3?

best regards
Comment 30 Eike Hein 2009-03-05 20:32:11 UTC
The Konsole bug has not been fixed, thus there was nothing to backport to 4.2.1.
Comment 31 Eike Hein 2009-03-05 20:35:10 UTC
Some news: The Konsole commit that breaks Yakuake's splits is revision 860035, http://websvn.kde.org/?view=rev&revision=860035
Comment 32 Eike Hein 2009-03-05 20:35:54 UTC
Addendum: The same Konsole revision is repsonsible for introducing the ugly rim around terminals in Yakuake.
Comment 33 Eike Hein 2009-03-05 21:09:43 UTC
Alright.

I've just committed r935623 to fix the layout regression from r860035 that caused the aforementioned ugly rim. 

Strangely enough, this has also fixed the problem with the terminal not showing up in the Yakuake dynamic split case (it's interesting to note that the Yakuake split session presets, like the Quad one, always worked fine). It almost appears as if the margins were taking up 100% of the space in some cases; maybe it's a QLayout bug.

Bottom line, as of Konsole revision 935623, both annoying Yakuake problems are fixed. Dynamic splits are back to working order.

Robert, please seriously consider backporting this to the 4.2 branch for 4.2.2.
Comment 34 Thomas Bächler 2009-03-05 21:37:21 UTC
Confirmed. I just applied the patch to the kde 4.2.1 source tarball and my terminals split again. Thanks for the efforts.
Comment 35 Victor B. Gonzalez 2009-03-06 02:54:08 UTC
Trying to build the konsole source "goes to hell in a hand-basket fast". How do you build this revision checked out of SVN?
Comment 36 Eike Hein 2009-03-06 03:32:04 UTC
You can't build the "konsole" directory individually; at least not without rewriting its CMakeLists.txt. Or do a shallow checkout of apps/ (svn co -n), then 'svn up konsole' in it, and finally modify the apps/ CMakeLists.txt to only consider the "konsole" subdirectory. Then build apps/.
Comment 37 Victor B. Gonzalez 2009-03-06 04:55:07 UTC
Eike, you're my hero. Very easy when you decrypt the build magic. I can confirm your work has indeed fixed the ugly thick border and broken splits on the latest Kubuntu 9.04 Jaunty (as of March 5th). Beautiful work. Thank you very much!
Comment 38 Robert Knight 2009-03-06 11:21:42 UTC
Hi Eike,

Thanks for sorting this out - I'm sorry I haven't sorted it myself.  Provided you can be sufficiently sure there are no regressions in Konsole then yes, we can backport the patch for 4.2.2
Comment 39 Thomas Bächler 2009-03-06 13:28:55 UTC
Eike/Robert, I don't use konsole myself, but I have kde 4.2.1 built with this patch included. If you tell me which tests to perform, I'd be happy to rule out any potential regressions this might cause.

In a quick test konsole starts and shows terminals, so it's not completely broken. Anything else that needs to be tested?
Comment 40 Robert Knight 2009-03-06 13:31:47 UTC
Hi Thomas,

The change which broke Yakuake was introduced by Aaron Seigo to put the incremental search bar (Ctrl+Shift+F) inside the terminal area instead of underneath the tabs.  Please check that still shows correctly and also that Konsole's split-view feature works (View -> Split View -> ...)
Comment 41 Eike Hein 2009-03-06 13:35:50 UTC
What my patch does is set the margin for the extra layout added by r860035 to 0, just like the parent (and pre-r860035 the only) layout has. 

Since Konsole's search bar is inside this layout, the only adverse side-effect it might have had is on the margins around this search bar, but they look fine to me (looks just as in Konqueror, Konversation, etc).
Comment 42 Victor B. Gonzalez 2009-03-06 13:51:30 UTC
I just tested vertical/horizontal splits in konsole on Kubuntu 9.04 Jaunty (as of March 6th) and they work as they have before. There is no difference here. The search bar looks just as it does in Konqueror and Okular. The search bar shows up in the particular split you currently have focused and looks good. The search bar works *but* only finds hits of the current session, not the history. Anything else, I'll be happy to provide more information.
Comment 43 Thomas Bächler 2009-03-06 14:25:46 UTC
Search bar is inside and looks fine. Splitting horizontally also looks fine.

Splitting vertically becomes ugly as soon as the search bar is displayed: It forces the current split window to be wide enough to hold the whole search bar, which makes the other split window very small - I guess this problem was there before:

Without searchbar: http://dev.archlinux.org/~thomas/konsole1.jpg
With searchbar: http://dev.archlinux.org/~thomas/konsole2.jpg
Comment 44 Eike Hein 2009-03-06 14:28:34 UTC
Yes, my patch would not affect that.
Comment 45 Eike Hein 2009-03-09 16:51:18 UTC
SVN commit 937339 by hein:

Backport r935623. Fixes a layout regression affecting apps
using the KPart, sometimes causing the terminal not to show
up as well as generally adding an ugly margin around the
terminal.
BUG:171544


 M  +2 -0      ViewContainer.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=937339