Bug 171395 - KEditFileType reproducible crashes with signal 11 (SIGSEGV) when editing associations
Summary: KEditFileType reproducible crashes with signal 11 (SIGSEGV) when editing asso...
Status: RESOLVED FIXED
Alias: None
Product: unknown
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 170350 171704 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-21 12:58 UTC by Panagiotis Papadopoulos
Modified: 2008-09-29 01:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Panagiotis Papadopoulos 2008-09-21 12:58:29 UTC
Version:            (using KDE 4.1.1)
OS:                Linux
Installed from:    Unlisted Binary Package

Yesterday I noticed, that if you remove all associations from a file with keditfiletype and try to add another one no matter which, keditfiletype crashes with a signal 11 SIGSEGV.

I asked a friend to try this on his machine, and he gets the same crash
Comment 1 Pino Toscano 2008-09-21 13:18:21 UTC
Hello,

could you please attach a backtrace of the crash? You can find more instruction in:
http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports

Thanks!
Comment 2 Urs Wolfer 2008-09-21 13:26:47 UTC
SVN commit 863178 by uwolfer:

Fix crash if you delete all associations and then add a new one.
BUG:171395

 M  +1 -1      kservicelistwidget.cpp
Comment 3 Panagiotis Papadopoulos 2008-09-21 14:20:02 UTC
Is it now fixed?
Wow that was fast^^
Comment 4 Urs Wolfer 2008-09-21 14:26:15 UTC
Yes, this crash is fixed (in trunk and 4.1 stable branch).
Comment 5 Jonathan Thomas 2008-09-27 20:04:59 UTC
*** Bug 170350 has been marked as a duplicate of this bug. ***
Comment 6 FiNeX 2008-09-29 01:06:43 UTC
*** Bug 171704 has been marked as a duplicate of this bug. ***