Bug 171256 - [PATCH] some images broken when in html, work fine outside.
Summary: [PATCH] some images broken when in html, work fine outside.
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Andreas Hartmetz
URL:
Keywords:
: 177345 178312 186358 188435 189110 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-18 08:10 UTC by Thomas
Modified: 2009-07-08 19:37 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas 2008-09-18 08:10:33 UTC
Version:            (using Devel)
Compiler:          debian gcc 4.3.1 
OS:                Linux
Installed from:    Compiled sources

Heres a screenshot of konqueror, and a bunch of broken images (mainly pngs):
http://strangesoft.net/konquerorpngbug.png

It used to work fine a week or three ago. definitely works in firefox (any version) or kde 3 (any version that I ever used).

The strange thing, that bald dude's avatar is png as well as the ones that are broken, I just loaded it manually, and it started to appear properly.. But trying it with others doesn't always work.
Comment 1 Thomas 2008-10-31 21:10:26 UTC
I recently just learned that It happens to break when konqueror redirects itself to http://sitename:80  even though none of the links have the port as part of the href. Once I remove the :80 from the url bar, and hit enter, the page reloads WITH working images.
Comment 2 Maksim Orlovich 2008-10-31 21:16:18 UTC
Possibly related: bug 173950
Comment 3 Andreas Hartmetz 2008-10-31 21:36:13 UTC
assign
Comment 4 kgw 2008-11-30 02:10:44 UTC
I get similar results all over the place. www.naturescapes.net, www.birdphotographers.net, www.fotocommunity.de, I can continue the list of broken rendered sites for quite some time - every now and then all images are shown, but often I have to hit reload to get all to show. My konqueror ist a SVN build as of today (2008-11-29).
Comment 5 Tommi Tervo 2008-12-10 09:44:46 UTC
*** Bug 177345 has been marked as a duplicate of this bug. ***
Comment 6 Tommi Tervo 2008-12-21 12:26:36 UTC
*** Bug 178312 has been marked as a duplicate of this bug. ***
Comment 7 Tommi Tervo 2009-03-04 16:45:41 UTC
David was nice again and provided patch which seems to work fine:
http://www.davidfaure.fr/kde/kio_http_nodefaultport.diff
Comment 8 Thomas 2009-03-04 16:58:27 UTC
(In reply to comment #7)
> David was nice again and provided patch which seems to work fine:
> http://www.davidfaure.fr/kde/kio_http_nodefaultport.diff

I'm wondering how this fixes it? The port I've had the problems with is port 80. Which is the default as far as I know. But konqueror keeps being told by kio to forward to sitename:80, even if sitename itself is port 80.
Comment 9 Jakub Stachowski 2009-03-14 12:36:04 UTC
*** Bug 186358 has been marked as a duplicate of this bug. ***
Comment 10 Tommi Tervo 2009-03-30 08:25:34 UTC
*** Bug 188435 has been marked as a duplicate of this bug. ***
Comment 11 Artem S. Tashkinov 2009-03-30 11:34:34 UTC
Bug 188435 has more details on this issue.

In short some redirects in Konqueror are broken.
Comment 12 Tommi Tervo 2009-04-08 11:25:25 UTC
*** Bug 189110 has been marked as a duplicate of this bug. ***
Comment 13 Tommi Tervo 2009-04-08 11:28:18 UTC
This is fixed in trunk, not (yet) backported to 4_2_branch.
Comment 14 Artem S. Tashkinov 2009-04-08 15:00:04 UTC
What a relief!
Comment 15 Andreas Hartmetz 2009-04-08 16:22:21 UTC
This doesn't seem to be fixed at least on www.birdphotographers.net.
I haven't applied the default-port patch to 4.2 because it looked slightly risky. OTOH, I didn't exactly apply David's patch but a heavily modified version. It should do the same thing though. If somebody can confirm that things work with David's patch but not with the patch in trunk I'll have another look. Otherwise I'll assume that something else is broken because that seems more likely.
Comment 16 Marcus Harrison 2009-06-18 16:27:07 UTC
I think bug #153602 is a duplicate of this bug.
Comment 17 Artem S. Tashkinov 2009-06-18 18:12:41 UTC
(In reply to comment #16)
> I think bug #153602 is a duplicate of this bug.

I think not, cause if you go from any microsoft.com page to another one and just hit "back" in konqueror the page will be shown correctly.
Comment 18 Andreas Hartmetz 2009-07-08 19:37:47 UTC
SVN commit 993441 by ahartmetz:

- Proper handling of the situation that the server might not supply a way to
  determine the end of response body on a keep-alive connection - we need to
  prevent keep-alive then.
- Some more simplification of the "do we need to disconnect from the current
  server for that new URL" logic. This includes removing the fugly
  m_isFirstRequest hack.
- Completely rewritten cache, with short methods, some separation of concerns
  and whatnot. Also binary storage of metadata that will be updated often
  for better performance and smaller size. Only one file per resource instead
  of two.
- Create cache files in the HTTP ioslaves, however serialize stat *updates* by
  doing them through the (now always running) cache cleaner process.
- New cache file naming scheme. I asked Chris Mason (of btrfs) on IRC about
  generic Linux filesystems and directories with a few thousand entries. All
  mainstream filesystems can handle that, so we'll just hash the URL and not
  use subdirectories.
- Add --file-info option to the cache cleaner. Very helpful for debugging.
- Follow the RFC more closely wrt caching, among other things by using the Age
  header as a last resort to determine the original serve date of a resource.
- Regression-ish: no compression - I'd rather not compress HTML and CSS than
  try to compress everything including images. Compression also seems to have
  interacted badly with updating file stats on disk.
  It will be possible to re-add compression, there is a reserved byte in the
  cache file header for that. If at all, only for text types please.
- Move cache related header parsing into a helper method to shrink the
  huge readResponseHeader() method. We also skip processing that stuff if we
  are not going to need it.
- Generally more data members were removed than added in http.h. Yay!

BUG: 171256, 193181

 M  +935 -904  http.cpp  
 M  +62 -66    http.h  
 M  +426 -200  http_cache_cleaner.cpp  
 M  +8 -19     parsinghelpers.cpp  
 M  +1 -1      parsinghelpers.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=993441