Bug 171139 - Changing "Run On" only in Autostart module doesn't get applied in some cases
Summary: Changing "Run On" only in Autostart module doesn't get applied in some cases
Status: RESOLVED DUPLICATE of bug 228795
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_autostart (show other bugs)
Version: 4.1
Platform: Compiled Sources Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Laurent Montel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-16 08:24 UTC by Michael Liddle
Modified: 2012-11-10 06:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Liddle 2008-09-16 08:24:22 UTC
Version:            (using Devel)
Installed from:    Compiled sources

This is a bit of an odd and confusing one, so I'll try to explain it carefully...

I have two scripts I want to have "Autostart"

One is an actual script file (I call this "actual script"), and the other is a _link_ to a (completely different) script file (I'll call this "linked script").

I want the actual script to run on "Startup" and the linked script to run on "Pre-KDE Startup" (i.e. be sourced into the shell that startkde is run in).

Trouble is I set them up the wrong way around (i.e. the Run On setting for each was backwards). So I tried to swap them, but I can't get my changes applied.

With the actual script I was able to make it Run On "Startup," but then I couldn't move it back (not that I wanted too, but I thought I'd try for this bug report). 

With the linked script on the other hand I was not able to get it to change at all (in either direction).

So seems like something isn't quite working right...

I _was_ able to swap them both manually (i.e. `mv Autostart/script.sh env/`), and those changed were reflected in the Autostart module.
Comment 1 Jekyll Wu 2012-11-10 06:11:09 UTC
I think this report shares the same cause as bug 228795.  Feel free to reopen if you find the fix for bug 228795 does not fix this issue.

*** This bug has been marked as a duplicate of bug 228795 ***