Bug 170881 - Commenting paragraphs in static wrap mode does not work properly.
Summary: Commenting paragraphs in static wrap mode does not work properly.
Status: RESOLVED DUPLICATE of bug 105373
Alias: None
Product: kate
Classification: Unclassified
Component: part (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-11 21:59 UTC by David Huard
Modified: 2010-07-04 23:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Huard 2008-09-11 21:59:51 UTC
Version:           2.0.1 (using KDE 3.5.9)
OS:                Linux
Installed from:    Fedora RPMs

Steps to reproduce the problem:

0. Select a paragraph. 
1. Join lines of a paragraph in the mode "static wrap" --- CTRL-J
2. Comment the lines of the paragraph --- CTRL-D

The result is that % characters are put at the beginning of each line, which triggers a rewrap that pushes the last words of a line at the beginning of the next line, so that the % characters end up in the middle of the lines. To get this to work, the algorithm should add the % character on the first line, wrap, then add % on the second line, wrap, etc. 

This is my first rant on kile after years of use. 
Thanks for this great tool.
Comment 1 Thomas Braun 2008-09-13 16:16:35 UTC
Hi,

can you check if you get the same behaviour in kate?

Thanks,
Thomas

PS:
For the "rant" you have choosen the best place namely the Bug Tracking System :)
Comment 2 David Huard 2008-09-15 15:39:44 UTC
(In reply to comment #1)
> Hi,
> 
> can you check if you get the same behaviour in kate?
> 

kate ?? Sorry, I'm on gnome so I am not so aware of the KDE toolbox. I installed kdelibs and kdebase (fedora9) and managed to have kwrite running. Is this the same thing ? In any case, I opened a LaTeX file in kwrite, but didn't find the "Comment lines" command, so I can't really answer your query. 

> Thanks,
> Thomas
> 
> PS:
> For the "rant" you have choosen the best place namely the Bug Tracking System
> :)
> 

Comment 3 Thomas Braun 2008-09-20 16:17:32 UTC
Hi,

have you tried to install the package kate?

At least it is named like that on debian.
Comment 4 David Huard 2008-09-22 14:45:04 UTC
That's the first thing I tried, but there is no such package in fedora9. 

 ...

Found it, it's hidden in ``kdesdk``.

 ...

Kate has the same behavior as kile: Disable dynamic word wrap, enable static word wrap, join the lines of a paragraph, comment them and you've got the same mess. 








Comment 5 Dominik Haumann 2010-07-04 23:23:31 UTC

*** This bug has been marked as a duplicate of bug 105373 ***