Bug 170817 - Stop gnome and kde 4 autostart mess
Summary: Stop gnome and kde 4 autostart mess
Status: RESOLVED WORKSFORME
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_autostart (show other bugs)
Version: 4.1
Platform: unspecified Unspecified
: NOR normal with 67 votes (vote)
Target Milestone: ---
Assignee: Laurent Montel
URL:
Keywords:
: 252663 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-10 20:41 UTC by Eduardo Durany Fernández
Modified: 2019-10-04 16:03 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Durany Fernández 2008-09-10 20:41:21 UTC
Version:            (using KDE 4.1.1)
Installed from:    Unspecified

Stop gnome and kde 4 autostart mess

Case one:
Steps to reproduce:

1) Mark an entry in gnome-session to not autostart
2) Login in kde4

Expected behavior:
Kde4 does not autostart that app

Current behavior:
Kde4 autostarts the app

Case two:
Steps to reproduce:

1) Mark an entry in kde to not autostart
2) Login in gnome

Expected behavior:
Gnome shows the app in gnome-session and does not autostart it

Current behavior:
Gnome does not show the app in gnome-session

I would like to list every autostart entries in gnome and kde. Mark them to autostart only in gnome, only in kde or in both.

Same bug in gnome:
http://bugzilla.gnome.org/show_bug.cgi?id=551700

Related bugs:
http://bugzilla.gnome.org/show_bug.cgi?id=548339
https://bugs.kde.org/show_bug.cgi?id=163582
Comment 1 Adam Williamson 2008-09-10 23:41:29 UTC
Additional comments: KDE has a 'private' autostart directory, ~/.kde/Autostart . GNOME does not.

The OnlyShowIn keyword can be used; in the context of autostart it will make the app only start in a particular DE. OnlyShowIn=KDE will make it only autostart in KDE, OnlyShowIn=GNOME will make it only autostart in GNOME.

So all the bits are there for both KDE and GNOME to behave sensibly by default and to present a simple interface to configure this.

IMHO, by default, when you set an app to autostart in either KDE or GNOME, it should be set to *only* autostart in that environment. I think that's the behavior most users expect.

Extra links to reports of this issue:

http://forum.mandriva.com/viewtopic.php?p=548286
https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/255342
Comment 2 Eduardo Durany Fernández 2008-09-11 17:40:25 UTC
When Gnome disables an autostart entry, it adds the flag "X-GNOME-Autostart-enabled=false". Kde does not understand this flag.

When Kde disables an autostart entry, it adds the flag "Hidden=true". The problem is that Gnome uses this flag to mark autostart entries deleted. From gnome-sessions source:

/* Two possible cases:
* a) We want to remove a system wide startup desktop file.
*    We can't do that, so we will create a user desktop file
*    with the hidden flag set.
* b) We want to remove a startup desktop file that is both
*    system and user. So we have to mark it as hidden.
*/

I think Gnome and Kde hackers need to reach agreement here.
Comment 3 Adam Williamson 2008-09-11 17:45:18 UTC
If what I wrote above is true - "OnlyShowIn=KDE will make it only autostart in KDE, OnlyShowIn=GNOME will make it only autostart in GNOME" - then the obvious solution is to use the OnlyShowIn key, which is a standard one, not an extension like X-GNOME-Autostart-enabled.
Comment 4 Eduardo Durany Fernández 2008-09-11 18:42:43 UTC
Yes, but if you put "OnlyShowIn=kde" gnome will not list that entry.
I would like to list every autostart entries in Gnome and Kde and to enable, disable or delete them. But maybe people would like another thing.

I think "Hidden" should be used only to deleted entries so we need another flag such as "Autostart-enable" to enable/disable them.

A similar problem occurs with menu entries. With Gnome i can enable or disable menu entries without delete them. I think Gnome uses "NoDisplay" flag to do this. Kde can not do this (http://bugs.kde.org/show_bug.cgi?id=93689).

What about an "Enable" flag to resolve both cases?
Comment 5 Per 2008-09-12 01:49:38 UTC
I'm using OnlyShowIn=GNOME atm in Mandriva to solve this problem. It seems to be working perfectly. 

I support using the OnlyShowIn key, like Adam suggests. I don't need to have KDE autostart entries listed in Gnome. I'm not really sure I want to either.

Any solution is fine with me though. As long as it's simple.
Comment 6 Eduardo Durany Fernández 2008-09-12 02:15:02 UTC
Well, after some research...

GNOME (gnome-session):

Show:
It shows autostart entries in /etc/xdg/autostart and in $HOME/.config/autostart.
It does not show entries with "Hidden=true", "NotShowIn=gnome" or "OnlyShowIn=kde".

Enable/Disable (user):
It sets "X-GNOME-Autostart-enabled" flag true or false.

Enable/Disable (system):
It creates a user desktop file with "X-GNOME-Autostart-enabled" flag.

Delete (user):
It deletes the desktop file.

Delete (system):
It creates a user desktop file with "Hidden=true".


KDE (systemsettings):

Show:
It only shows autostart entries in $HOME/.config/autostart.
It shows entries with "Hidden=true" or "OnlyShowIn=gnome" (but it does not exec them).

Enable/Disable (user):
It sets "Hidden" flag true or false.

Delete (user):
It deletes the desktop file.


I like gnome-sessions behavior, but obviously "X-GNOME-Autostart-enabled" flag should be standardized.
This is a very annoying bug and i am sure every people would like to see similar behavior in both programs. I can't do much more with this. Thanks for reading.
Comment 7 Adam Williamson 2008-09-12 02:21:36 UTC
Great info, Eduardo. I'll duplicate it in the GNOME bug, if you don't mind.
Comment 8 Christoph Feck 2010-09-28 17:32:06 UTC
*** Bug 252663 has been marked as a duplicate of this bug. ***
Comment 9 Andrew Crouthamel 2018-11-05 03:12:28 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 10 Andrew Crouthamel 2018-11-17 05:06:15 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!