Bug 170681 - AmaroK crashes when searching the shoutcast directory
Summary: AmaroK crashes when searching the shoutcast directory
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Internet Services (show other bugs)
Version: 2.0-beta
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-08 14:30 UTC by Emilio
Modified: 2009-01-18 11:26 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emilio 2008-09-08 14:30:24 UTC
Version:           2.0 beta (using KDE 4.1.1)
OS:                Linux
Installed from:    Mandriva RPMs

When searching something in the shoucast directory amarok crashes.

How to reproduce:

1- Click on the Internet tab
2- Click the Shoutcast directory
3- Search something and click in the + button to see the search results. Then amarok crashes.

In my computer it is always reproducible. I am using Mandriva One 2009 rc1. (LiveCD)

If I run it from a console that's the output since I type the word "rock" till it crashes:

amarok:    "r"                                                                  
amarok:    "ro"                                                                 
amarok:    "roc"                                                                
amarok:    "rock"                                                               
amarok:    appending ' "" : "rock" '                                            
amarok: BEGIN: virtual QueryMaker* ShoutcastServiceQueryMaker::addFilter(qint64, const QString&, bool, bool)                                                    
amarok:      Filter:  "rock"                                                    
amarok: END__: virtual QueryMaker* ShoutcastServiceQueryMaker::addFilter(qint64, const QString&, bool, bool) - Took 0.00021s                                    
amarok: BEGIN: virtual QueryMaker* ShoutcastServiceQueryMaker::addFilter(qint64, const QString&, bool, bool)                                                    
amarok: END__: virtual QueryMaker* ShoutcastServiceQueryMaker::addFilter(qint64, const QString&, bool, bool) - Took 0.00011s                                    
amarok: BEGIN: virtual void ShoutcastServiceQueryMaker::run()                   
amarok: BEGIN: void ShoutcastServiceQueryMaker::fetchStations()                 
amarok:        fetching tracks with filter:  "rock"  url:  "http://www.shoutcast.com/sbin/newxml.phtml?genre=&s=rock"
amarok: END__: void ShoutcastServiceQueryMaker::fetchStations() - Took 0.00078s
amarok: END__: virtual void ShoutcastServiceQueryMaker::run() - Took 0.001s
amarok: END__: virtual void CollectionTreeView::mousePressEvent(QMouseEvent*) -Took 0.0043s
ControlElement: 46
ControlElement: 25
Element: 33
ControlElement: 46
ControlElement: 25
Element: 33
ControlElement: 46
ControlElement: 46
ControlElement: 46
ControlElement: 46
ControlElement: 46
ControlElement: 46
ControlElement: 46
ControlElement: 46
ControlElement: 46
ControlElement: 46
ControlElement: 46
ControlElement: 46
amarok: BEGIN: void ShoutcastServiceQueryMaker::stationDownloadComplete(KJob*)
amarok:    add track:  ".977 The Hitz Channel"
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 0.00019s
amarok: BEGIN: ShoutcastTrack::ShoutcastTrack(const QString&, const KUrl&)
amarok: END__: ShoutcastTrack::ShoutcastTrack(const QString&, const KUrl&) - Took 0.00011s
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = amarok path = <unknown> pid = 6770
sock_file=/home/guest/.kde4/socket-localhost/kdeinit4__0
Comment 1 Emilio 2008-09-08 21:37:19 UTC
The gdb returns the following

Aplicación: Amarok (amarok), señal SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb44ed6d0 (LWP 6559)]
[New Thread 0xafb42b90 (LWP 6580)]
[New Thread 0xb0343b90 (LWP 6578)]
[New Thread 0xb0b44b90 (LWP 6577)]
[New Thread 0xb2b12b90 (LWP 6576)]
[New Thread 0xb1e40b90 (LWP 6574)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7c42e0a in ?? () from /usr/lib/libamaroklib.so.1
#7  0xb0b75e57 in ?? () from /usr/lib/kde4/amarok_service_shoutcast.so
#8  0xb0b788fd in ?? () from /usr/lib/kde4/amarok_service_shoutcast.so
#9  0xb74cdced in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#10 0xb74ceaf5 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#11 0xb7677375 in KJob::result () from /usr/lib/libkdecore.so.5
#12 0xb76778f2 in KJob::emitResult () from /usr/lib/libkdecore.so.5
#13 0xb5e8375f in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.5
#14 0xb5e8ab53 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.5
#15 0xb5e8b9a4 in KIO::TransferJob::qt_metacall () from /usr/lib/libkio.so.5
#16 0xb5e8bd42 in KIO::StoredTransferJob::qt_metacall ()
   from /usr/lib/libkio.so.5
#17 0xb74cdced in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#18 0xb74ceaf5 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#19 0xb5f535d5 in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.5
#20 0xb5f5753b in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#21 0xb5f53da0 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#22 0xb5f43346 in KIO::Slave::gotInput () from /usr/lib/libkio.so.5
#23 0xb5f45e90 in KIO::Slave::qt_metacall () from /usr/lib/libkio.so.5
#24 0xb74cdced in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#25 0xb74ceaf5 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#26 0xb5e48195 in KIO::Connection::readyRead () from /usr/lib/libkio.so.5
#27 0xb5e4a38d in ?? () from /usr/lib/libkio.so.5
#28 0xb5e4a51b in KIO::Connection::qt_metacall () from /usr/lib/libkio.so.5
#29 0xb74c6bba in QMetaCallEvent::placeMetaCall ()
   from /usr/lib/libQtCore.so.4
#30 0xb74c87f2 in QObject::event () from /usr/lib/libQtCore.so.4
#31 0xb6b702cc in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#32 0xb6b78535 in QApplication::notify () from /usr/lib/libQtGui.so.4
#33 0xb79b9601 in KApplication::notify () from /usr/lib/libkdeui.so.5
#34 0xb74b8863 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#35 0xb74b9525 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#36 0xb74b970c in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#37 0xb74e48dd in ?? () from /usr/lib/libQtCore.so.4
#38 0xb4d2279a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#39 0xb4d25eb8 in ?? () from /usr/lib/libglib-2.0.so.0
#40 0xb4d26078 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#41 0xb74e44fa in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#42 0xb6c0ca2a in ?? () from /usr/lib/libQtGui.so.4
#43 0xb74b6ef3 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#44 0xb74b70b1 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#45 0xb74b97e2 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#46 0xb6b70134 in QApplication::exec () from /usr/lib/libQtGui.so.4
#47 0x0804c05c in _start ()
Comment 2 Lydia Pintscher 2008-09-10 20:39:43 UTC
Is this still a problem in current SVN?
Comment 3 Mark Kretschmann 2008-09-16 18:19:06 UTC
I was able to reproduce the crash with latest SVN. Backtrace: 


Thread 1 (Thread 0x7fb9cc8527c0 (LWP 20469)):
[KCrash Handler]
#5  0x00007fb9da7c7912 in QList<KSharedPtr<Meta::Track> >::detach (this=0x40) at /usr/include/qt4/QtCore/qlist.h:121
#6  0x00007fb9da7c794b in QList<KSharedPtr<Meta::Track> >::append (this=0x40, t=@0x7fffe3c92ae0) at /usr/include/qt4/QtCore/qlist.h:422
#7  0x00007fb9da84c0cb in Meta::ServiceGenre::addTrack (this=0x0, track=@0x7fffe3c92ae0) at /home/mark/kde/src/amarok/src/browsers/servicebrowser/ServiceMetaBase.cpp:892
#8  0x00007fb9bcd733d0 in ShoutcastServiceQueryMaker::stationDownloadComplete (this=0x4b8d4e0, job=0x53d7a70)
    at /home/mark/kde/src/amarok/src/browsers/servicebrowser/shoutcast/ShoutcastServiceQueryMaker.cpp:386
#9  0x00007fb9bcd74a8d in ShoutcastServiceQueryMaker::qt_metacall (this=0x4b8d4e0, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0x7fffe3c92df0)
    at /home/mark/kde/build/amarok/src/browsers/servicebrowser/shoutcast/ShoutcastServiceQueryMaker.moc:74
#10 0x00007fb9db5278b6 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#11 0x00007fb9dae103af in KJob::result (this=0x53d7a70, _t1=0x53d7a70) at /home/mark/kde/build/kdelibs/kdecore/kjob.moc:186
#12 0x00007fb9dae10880 in KJob::emitResult (this=0x53d7a70) at /home/mark/kde/src/kdelibs/kdecore/jobs/kjob.cpp:290
#13 0x00007fb9d6d282cf in KIO::SimpleJob::slotFinished (this=0x53d7a70) at /home/mark/kde/src/kdelibs/kio/kio/job.cpp:489
#14 0x00007fb9d6d2869b in KIO::TransferJob::slotFinished (this=0x53d7a70) at /home/mark/kde/src/kdelibs/kio/kio/job.cpp:958
#15 0x00007fb9d6d2ee98 in KIO::TransferJob::qt_metacall (this=0x53d7a70, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x7fffe3c931f0) at /home/mark/kde/build/kdelibs/kio/jobclasses.moc:336
#16 0x00007fb9d6d2f238 in KIO::StoredTransferJob::qt_metacall (this=0x53d7a70, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0x7fffe3c931f0) at /home/mark/kde/build/kdelibs/kio/jobclasses.moc:438
#17 0x00007fb9db5278b6 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#18 0x00007fb9d6dc5db4 in KIO::SlaveInterface::finished (this=0x11afd20) at /home/mark/kde/build/kdelibs/kio/slaveinterface.moc:163
#19 0x00007fb9d6dc784e in KIO::SlaveInterface::dispatch (this=0x11afd20, _cmd=104, rawdata=@0x7fffe3c93440) at /home/mark/kde/src/kdelibs/kio/kio/slaveinterface.cpp:176
#20 0x00007fb9d6dc7728 in KIO::SlaveInterface::dispatch (this=0x11afd20) at /home/mark/kde/src/kdelibs/kio/kio/slaveinterface.cpp:91
#21 0x00007fb9d6dbb203 in KIO::Slave::gotInput (this=0x11afd20) at /home/mark/kde/src/kdelibs/kio/kio/slave.cpp:319
#22 0x00007fb9d6dbc407 in KIO::Slave::qt_metacall (this=0x11afd20, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0x7fffe3c935b0) at /home/mark/kde/build/kdelibs/kio/slave.moc:75
#23 0x00007fb9db5278b6 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#24 0x00007fb9d6cfaea2 in KIO::Connection::readyRead (this=0x11b0030) at /home/mark/kde/build/kdelibs/kio/connection.moc:84
#25 0x00007fb9d6cfbcae in KIO::ConnectionPrivate::dequeue (this=0x818ae0) at /home/mark/kde/src/kdelibs/kio/kio/connection.cpp:82
#26 0x00007fb9d6cfcb2e in KIO::Connection::qt_metacall (this=0x11b0030, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x53e9c90) at /home/mark/kde/build/kdelibs/kio/connection.moc:72
#27 0x00007fb9db522497 in QObject::event () from /usr/lib/libQtCore.so.4
#28 0x00007fb9d8be3acf in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#29 0x00007fb9d8be5c85 in QApplication::notify () from /usr/lib/libQtGui.so.4
#30 0x00007fb9d979b52e in KApplication::notify (this=0x7fffe3c93f90, receiver=0x11b0030, event=0x5375210) at /home/mark/kde/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#31 0x00007fb9db5136b9 in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#32 0x00007fb9db5149db in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib/libQtCore.so.4
#33 0x00007fb9db53c6e3 in ?? () from /usr/lib/libQtCore.so.4
#34 0x00007fb9d7f253d4 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#35 0x00007fb9d7f286e5 in ?? () from /usr/lib/libglib-2.0.so.0
#36 0x00007fb9d7f28bcb in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#37 0x00007fb9db53c9df in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#38 0x00007fb9d8c6d20f in ?? () from /usr/lib/libQtGui.so.4
#39 0x00007fb9db512b35 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#40 0x00007fb9db512c8b in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#41 0x00007fb9db514cd9 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#42 0x0000000000403618 in main (argc=3, argv=0x7fffe3c95118) at /home/mark/kde/src/amarok/src/main.cpp:127

Comment 4 Nikolaj Hald Nielsen 2008-10-12 11:14:26 UTC
I was not able to reproduce this with latest trunk. I made small safety check though. Svn commit 870274 adds a small sanity check that should prevent the crash that Mark got.
Comment 5 gmud 2009-01-18 10:58:41 UTC
What version was trunk at time of testing?

I can still reproduce with version 1.92.2 (KDE 4.1.2, ubuntu packages):

Anwendung: Amarok (amarok), Signal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0xb497e6c0 (LWP 7214)]
[New Thread 0xac003b90 (LWP 7226)]
[New Thread 0xac804b90 (LWP 7225)]
[New Thread 0xad9feb90 (LWP 7224)]
[New Thread 0xae1ffb90 (LWP 7223)]
[New Thread 0xafee1b90 (LWP 7222)]
[New Thread 0xb0c45b90 (LWP 7220)]
[New Thread 0xb1446b90 (LWP 7219)]
[New Thread 0xb1c68b90 (LWP 7218)]
[New Thread 0xb24e0b90 (LWP 7215)]
[KCrash handler]
#6  0xb7cee652 in QList<KSharedPtr<Meta::Track> >::detach (this=0x24)
    at /usr/include/qt4/QtCore/qlist.h:121
#7  0xb7cee6a2 in QList<KSharedPtr<Meta::Track> >::append (this=0x24, 
    t=@0xbffb050c) at /usr/include/qt4/QtCore/qlist.h:422
#8  0xae5b4e35 in ShoutcastServiceQueryMaker::stationDownloadComplete (
    this=0x9cf5cf8, job=0x887d4c0)
    at /build/buildd/amarok-kde4-1.92.2/src/browsers/servicebrowser/shoutcast/ShoutcastServiceQueryMaker.cpp:384
#9  0xae5b686a in ShoutcastServiceQueryMaker::qt_metacall (this=0x9cf5cf8, 
    _c=QMetaObject::InvokeMetaMethod, _id=-1, _a=0xbffb067c)
    at /build/buildd/amarok-kde4-1.92.2/obj-i486-linux-gnu/src/browsers/servicebrowser/shoutcast/ShoutcastServiceQueryMaker.moc:74
#10 0xb764cf79 in QMetaObject::activate (sender=0x887d4c0, 
    from_signal_index=7, to_signal_index=7, argv=0xbffb067c)
    at kernel/qobject.cpp:3016
#11 0xb764d642 in QMetaObject::activate (sender=0x887d4c0, m=0xb7922868, 
    local_signal_index=3, argv=0xbffb067c) at kernel/qobject.cpp:3086
#12 0xb7828673 in KJob::result (this=0x887d4c0, _t1=0x887d4c0)
    at /build/buildd/kde4libs-4.1.2/obj-i486-linux-gnu/kdecore/kjob.moc:186
#13 0xb7828b92 in KJob::emitResult (this=0x887d4c0)
    at /build/buildd/kde4libs-4.1.2/kdecore/jobs/kjob.cpp:290
#14 0xb61cbcdf in KIO::SimpleJob::slotFinished (this=0x887d4c0)
    at /build/buildd/kde4libs-4.1.2/kio/kio/job.cpp:498
#15 0xb61cc320 in KIO::TransferJob::slotFinished (this=0x887d4c0)
    at /build/buildd/kde4libs-4.1.2/kio/kio/job.cpp:967
#16 0xb61d2b18 in KIO::TransferJob::qt_metacall (this=0x887d4c0, 
    _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbffb0908)
    at /build/buildd/kde4libs-4.1.2/obj-i486-linux-gnu/kio/jobclasses.moc:336
#17 0xb61d2dea in KIO::StoredTransferJob::qt_metacall (this=0x887d4c0, 
    _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbffb0908)
    at /build/buildd/kde4libs-4.1.2/obj-i486-linux-gnu/kio/jobclasses.moc:438
#18 0xb764cf79 in QMetaObject::activate (sender=0x9c957d8, 
    from_signal_index=8, to_signal_index=8, argv=0x0)
    at kernel/qobject.cpp:3016
#19 0xb764d642 in QMetaObject::activate (sender=0x9c957d8, m=0xb6334c04, 
    local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3086
#20 0xb626eac7 in KIO::SlaveInterface::finished (this=0x9c957d8)
    at /build/buildd/kde4libs-4.1.2/obj-i486-linux-gnu/kio/slaveinterface.moc:161
#21 0xb6270cab in KIO::SlaveInterface::dispatch (this=0x9c957d8, _cmd=104, 
    rawdata=@0xbffb0aa4)
    at /build/buildd/kde4libs-4.1.2/kio/kio/slaveinterface.cpp:175
#22 0xb62710ed in KIO::SlaveInterface::dispatch (this=0x9c957d8)
    at /build/buildd/kde4libs-4.1.2/kio/kio/slaveinterface.cpp:90
#23 0xb6263c67 in KIO::Slave::gotInput (this=0x9c957d8)
    at /build/buildd/kde4libs-4.1.2/kio/kio/slave.cpp:322
#24 0xb626503d in KIO::Slave::qt_metacall (this=0x9c957d8, 
    _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbffb0bb8)
    at /build/buildd/kde4libs-4.1.2/obj-i486-linux-gnu/kio/slave.moc:75
#25 0xb764cf79 in QMetaObject::activate (sender=0x9c7e198, 
    from_signal_index=4, to_signal_index=4, argv=0x0)
    at kernel/qobject.cpp:3016
#26 0xb764d642 in QMetaObject::activate (sender=0x9c7e198, m=0xb6331860, 
    local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3086
#27 0xb619e917 in KIO::Connection::readyRead (this=0x9c7e198)
    at /build/buildd/kde4libs-4.1.2/obj-i486-linux-gnu/kio/connection.moc:84
#28 0xb619f788 in KIO::ConnectionPrivate::dequeue (this=0x9cf0470)
    at /build/buildd/kde4libs-4.1.2/kio/kio/connection.cpp:82
#29 0xb61a05ce in KIO::Connection::qt_metacall (this=0x9c7e198, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x9cabaf0)
    at /build/buildd/kde4libs-4.1.2/obj-i486-linux-gnu/kio/connection.moc:72
#30 0xb76468ab in QMetaCallEvent::placeMetaCall (this=0x8a01780, 
    object=0x9c7e198) at kernel/qobject.cpp:535
#31 0xb7647c31 in QObject::event (this=0x9c7e198, e=0x8a01780)
    at kernel/qobject.cpp:1140
#32 0xb6cfef9c in QApplicationPrivate::notify_helper (this=0x8071630, 
    receiver=0x9c7e198, e=0x8a01780) at kernel/qapplication.cpp:3800
#33 0xb6d03bf9 in QApplication::notify (this=0xbffb13bc, receiver=0x9c7e198, 
    e=0x8a01780) at kernel/qapplication.cpp:3392
#34 0xb7adf483 in KApplication::notify (this=0xbffb13bc, receiver=0x9c7e198, 
    event=0x8a01780)
    at /build/buildd/kde4libs-4.1.2/kdeui/kernel/kapplication.cpp:311
#35 0xb76380b9 in QCoreApplication::notifyInternal (this=0xbffb13bc, 
    receiver=0x9c7e198, event=0x8a01780) at kernel/qcoreapplication.cpp:591
#36 0xb7639469 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, 
    event_type=0, data=0x8052130)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#37 0xb763968d in QCoreApplication::sendPostedEvents (receiver=0x0, 
    event_type=0) at kernel/qcoreapplication.cpp:1095
#38 0xb766362f in postEventSourceDispatch (s=0x8073910)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#39 0xb4fe5cc6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0xb4fe9083 in ?? () from /usr/lib/libglib-2.0.so.0
#41 0xb4fe963e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#42 0xb76639f8 in QEventDispatcherGlib::processEvents (this=0x8070c10, 
    flags=@0xbffb12b8) at kernel/qeventdispatcher_glib.cpp:325
#43 0xb6d92a25 in QGuiEventDispatcherGlib::processEvents (this=0x8070c10, 
    flags=@0xbffb12e8) at kernel/qguieventdispatcher_glib.cpp:204
#44 0xb763733d in QEventLoop::processEvents (this=0xbffb1360, 
    flags=@0xbffb1324) at kernel/qeventloop.cpp:149
#45 0xb76374cd in QEventLoop::exec (this=0xbffb1360, flags=@0xbffb1368)
    at kernel/qeventloop.cpp:200
#46 0xb763974d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:849
#47 0xb6cfe897 in QApplication::exec () at kernel/qapplication.cpp:3330
#48 0x0804b3ca in main (argc=1, argv=0xbffb18a4)
    at /build/buildd/amarok-kde4-1.92.2/src/main.cpp:127
#0  0xb7f07410 in __kernel_vsyscall ()
Comment 6 Emilio 2009-01-18 11:26:39 UTC
The version you are using (1.92.2) is a beta version affected by this problem. In amarok 2.0 or newer this problem doesn't happen anymore so try to update amarok.