Bug 17067 - kmail crash larger attachments
Summary: kmail crash larger attachments
Status: RESOLVED DUPLICATE of bug 59069
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Other
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2000-12-14 12:33 UTC by Hermann Rochholz
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hermann Rochholz 2000-12-14 12:25:51 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: kmail
Version: Hermann Rochholz/Sternstr. 5/ 82205 Gilching/ Germany
Severity: crash
Installed from: tar.gz

System:
OSF 4.0g (True unix)
KDE 2.01

When receiving large attachments (>~ 10MB)
kmail hangs up. 

(submitted via bugs.kde.org)
Comment 1 M. Schuckert 2001-06-15 10:07:10 UTC
Hello

think you did good work with Kmail.
Because where is the problem if append large attachments:

kmail crashes on copy-process for the attachment.

My System: 
Generic installed RedHat 7.1 (RPM)
Kernel 2.4.2-2
gcc 2.96
ldd 2.2.2
kde 2.1.1 (parallel to Gnome) without special modifications
Kmail 1.2
working under normal user account

it was an ca. 100 MB attachment (1 File) and also 
with a kernel 2.4.5 - tar.gz -File (26 MB)
copy-process has ended mous make only "jumps" on
moving it and KDE is stalled (also keyboard inputs)
top shows that nearly all swap space ist consumed!
crashmanager reportet message about Signal #6.

/tmp ist 200 MB (28 MB occupied)
/var has 800 MB reserve
swap space:  130 MB on sda 130 MB on sdb

----- a little suggestion:
probably is it better to make set a pointer to the attachment file(s)
and give user a warning on sending mail if file is changed/deleted
in the  meantime (copy process on sending mail)  so it is not
nessesary to occopy disk place all the time in the sent folder??
(only an idea)

regards

M. Schuckert
Germany (near Magdeburg)
private and bussiness Linux/KDE User

-- 

Get your free email from www.linuxmail.org 


Powered by Outblaze
Comment 2 Ingo Kl 2001-06-15 22:09:09 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Friday 15. June 2001 12:07 M. Schuckert wrote:
> think you did good work with Kmail.
> Because where is the problem if append large attachments:
>
> kmail crashes on copy-process for the attachment.

[snip]

> it was an ca. 100 MB attachment (1 File) and also
> with a kernel 2.4.5 - tar.gz -File (26 MB)
> copy-process has ended mous make only "jumps" on
> moving it and KDE is stalled (also keyboard inputs)
> top shows that nearly all swap space ist consumed!
> crashmanager reportet message about Signal #6.
>
> /tmp ist 200 MB (28 MB occupied)
> /var has 800 MB reserve
> swap space:  130 MB on sda 130 MB on sdb

Please note that according to a recent test KMail needs up to 12 times 
the size of the attachment as system memory. Unless you don't have more 
than 1.2 GB virtual memory KMail can't handle a 100 MB attachment.

BTW I consider sending such a big file as attachment stupid because a 
binary file which is sent as attachment has to be encoded in Base64 
which will increase the file size to about 133% of the original file 
size. It would be much better to put this file on a web server or a ftp 
server or to exchange this file via irc or icq or whatever. E-Mail was 
never meant to be used as transport medium for binary data especially 
not in such big quantities.
The kernel 2.4.5 tar.gz file can be found on numerous web and ftp 
servers. So why on earth would someone send this file as attachment 
(except for mail bombing)?

FYI regardless of my opinion some of the developers are working on a 
reduction of the memory consumption.

Regards
Ingo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.4 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE7KoeFGnR+RTDgudgRAhmwAJ4kdqJ4gxWZAYpCKmUv3rjANNOBjACfQsUC
1jZTo5cDx01BzBWInpHnGQ8=
=mYLm
-----END PGP SIGNATURE-----
Comment 3 Hermann Rochholz 2001-06-15 22:38:39 UTC
Ingo Klöcker wrote:

> BTW I consider sending such a big file as attachment stupid because a
> binary file which is sent as attachment has to be encoded in Base64
> which will increase the file size to about 133% of the original file
> size. It would be much better to put this file on a web server or a ftp
> server or to exchange this file via irc or icq or whatever. E-Mail was
> never meant to be used as transport medium for binary data especially
> not in such big quantities.

Yes you're right. But consider the stupidity of PC users.
In "Outlook" you can hide file size. And my mailer has to
be able to handle every file sent
from this (questionable) program.

Hermann
--
Hermann Rochholz
Sternstrasse 5
82205 Gilching
Tel./Fax.: 08105/275999
mailto:Hermann.Rochholz@gmx.de
Comment 4 Wolfgang Spindler 2001-06-17 04:26:24 UTC
Dear folks at KDE

I think you're not really right. Today email is a transport for large file 
data as well. For instance my wife works as a photographer. For her is has 
been everyday business to send her shots to her publishers by email. Most of 
the times she offers more than one JPEG motive and it is handy for her and 
her pubilishers to send/recieve related photos in one transaction.

Please consider this. My wife has to fall back on Microsoft if you can't 
solve this problem.

Regards

Wolfgang Spindler
Comment 5 Don Sanders 2001-06-17 09:28:42 UTC
As Ingo stated some developers are working on this problem.

Don.

On Sunday 17 June 2001 06:26 Wolfgang Spindler wrote:

> Dear folks at KDE
>
> I think you're not really right. Today email is a
> transport for large file data as well. For instance my
> wife works as a photographer. For her is has been
> everyday business to send her shots to her publishers by
> email. Most of the times she offers more than one JPEG
> motive and it is handy for her and her pubilishers to
> send/recieve related photos in one transaction.
>
> Please consider this. My wife has to fall back on
> Microsoft if you can't solve this problem.
>
> Regards
>
> Wolfgang Spindler
Comment 6 Rodney Quaye 2001-10-23 20:58:21 UTC
Version:           2.1.1 (using KDE 2.2.0 )
Installed from:    Mandrake RPMs
Compiler:          GCC version 2.96
OS:                Linux
OS/Compiler notes: Linux 2.4.3-20mdk i686

I tried to attach a large ZIP file (9 Megs) to an E-mail message I was sending. Yes! E-mail was never meant for that but bare with me. After several minutes waiting for KMail to send the file it returned back with an SMTP message saying the body of the message was too large. I decided to log off. I was using the GNOME desktop at the time. After clicking the log off icon the GNOME start bar stop responding. All the applications still worked but it would not log me off. So eventually I had to CTRL-ALT-F? to another console screen and reboot the machine. The reason I suspect this was to do with KMail was that I logged back on and tried sending two E-mails about 5 Meg each. After I sent the E-mails I tried to log off again while KMail was still open. Again the GNOME start bar did not respond. All the applications were still responding though. But as soon as I shutdown KMail I managed to log off as usual. I suspect that KMail was somehow preventing GNOME from logging me out. Perhaps GNOME waits for all the applications to shutdown by themselves before logging you out and KMail was slow because of the big attachments I had added to it? Anyway it looks to the unintiated that the desktop has crashed when it has not.

Another thing should not the process for sending the E-mail run as a seperate process so that the Window re-draw and controls can
still be active in typical X windows fashion? You could then prompt the user when they close KMail that by the way mail is being sent do they want to stop sending yes or no. If they say 'yes' then kill the other process and shutdown KMail.

Rod.

(Submitted via bugs.kde.org)
Comment 7 Dan Arnon 2001-11-01 20:12:12 UTC
I am a new Linux user. I installed Suse Linux 7.2 recently. Since I work a 
lot with Windows users I had to send large .doc files to them by mail. The 
first time I did it (through the Mozilla mailer - the attachment was about 3M 
in size) the system completely froze I couldn't even kill KDE. I had to turn 
the computer off and back on. Thinking that the problem was with Mozilla I 
changed the way I send mail by running sendmail as a daemon and then using 
Kmail as my mail reader configured to send mail locally to sendmail. The 
problem persisted -  I had to turn the computer off and on all the time. Each 
time I was getting unpredictable corruptions in various places. After some 
desparate experimentation I discovered that the problem was mostly 
associated with sending files encoded in the base64 encoding. That makes 
sense because this encoding inflates the files by a 4:3 factor. However my 
system would still crash on a 2M email sent with base64 encoding but be 
perfectly happy with an 8-bit 5M email.

While bugs exist everywhere I've become a bit skeptical of the claim that 
Linux never "freezes" - I have Windows ME at home and for all its faults it 
never freezes on me.

Danny
Comment 8 Carsten Burghardt 2002-01-12 14:47:11 UTC
Does this also happen with the current (2.2.2) or the development version (=
kde=20
3.0 beta1)?
--=20
Carsten Burghardt
email: cb@magic-shop.de
WWW: http://www.magic-shop.de
PGP: http://www.magic-shop.de/Carsten_Burghardt.asc
Comment 9 Chris Howells 2003-05-28 21:31:09 UTC
*** Bug 59069 has been marked as a duplicate of this bug. ***
Comment 10 Stephan Kulow 2003-09-20 19:20:52 UTC
as the other bug report is non-wishlist, I mark it the other way around as duplicates :) 

*** This bug has been marked as a duplicate of 59069 ***