Bug 170213 - Dolphin can not access files named with special characters in a samba share
Summary: Dolphin can not access files named with special characters in a samba share
Status: RESOLVED DUPLICATE of bug 158639
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: kioslave (show other bugs)
Version: 4.0
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-01 21:44 UTC by Victor Suarez
Modified: 2008-12-20 12:05 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Suarez 2008-09-01 21:44:56 UTC
Version:            (using KDE 4.1.1)
OS:                Linux
Installed from:    Ubuntu Packages

When I try to access to a samba/cifs share, I can not read, copy, move, delete, etc. files with non-English characters in their names. Always give the same error message: "The file xxx does not exist". This type of files are shown with the "binary" icon and an overlaying key lock.

Dolphin does not show this problem with sftp or with local access. 

Next some annoying things:
- Dolphin3 on KDE 4.1.1 works without trouble (create, delete, copy, move, edit, etc.).
- If I create a file/folder named "niño" with Dolphin3, Dolphin4 show the file/folder's name Ok, incorrect icon, and cannot access it (gives me the error message).
- If I create a file/folder named "niño" with Dolphin4, it gives me the same error message. Then file/folder is created, still inaccessible, incorrect icon and named "ni[?]o" ([?] is white question mark inside of black diamond). Dolphin3 show the correct icon, "ni[?]o" file name, but I can rename it, delete, edit, etc.

Regards
V[?]ctor (Víctor on Dolphin3 ;)
Comment 1 jorortega 2008-09-02 03:18:44 UTC
Not just with ñ, accented characters in spanish, just happens with files that have any characters in other languages like japanese. Reporting here just to put my +1 since i changed file manager and all is working again here, but dolplhin/konkeror/KDE 4.1.1 is still buggy in this aspect. (and not usable by anyone that uses these characters combinated with a-z letters and numbers)

J.
Comment 2 Marco Menardi 2008-09-15 00:10:44 UTC
I'had a GNU/Linux box with samba and unix charset = ISO8859-15 encoding. I recently transferred all those files in GNU/Linux filesystem UTF8 with rsync.
Now when Dolphin encounters those files (normal access, not through samba, they are local files) with accents and special characters in the name, shows a white "?" on black background. If I try to rename those files, happens as the bug reporter states ("The file xxx does not exist").
In addition, opening the old host directory with smb:// makes Dolphin block with the error "The process for the smb://192.168.1.3 protocol died unexpectedly"
Comment 3 Victor Suarez 2008-10-03 20:19:44 UTC
Bug is still present in the new KDE 4.1.2.
Comment 4 Václav Novák 2008-11-04 12:44:48 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Victor Suarez 2008-11-23 17:15:36 UTC
Weird, but with the same version of KDE (4.1.2), Kubuntu 8.10 does not suffer this problem. So this could be a distribution problem and not Dolphin problem.
Comment 6 Yözen Hernández 2008-12-06 04:50:08 UTC
Not sure if this is related, but I experience this issue with folders with the character 1/2 (½) which shows up as a ? in a black diamond (�) in dolphin, konqueror, and konsole.

I am using KDE 4.1.3 in Kubuntu Intrepid. I have seen this bug I believe since 4.0 but thought it was fixed. I had no problems in KDE 3.
Comment 7 FiNeX 2008-12-20 12:05:05 UTC

*** This bug has been marked as a duplicate of bug 158639 ***