Bug 170199 - kate main window is not resizable on OS X
Summary: kate main window is not resizable on OS X
Status: RESOLVED DUPLICATE of bug 168809
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: MacPorts Packages macOS
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 174722 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-01 17:07 UTC by illogic-al
Modified: 2009-09-16 01:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description illogic-al 2008-09-01 17:07:49 UTC
Version:            (using KDE 4.1.1)
Compiler:          gcc version 4.2.1 (Apple Inc. build 5564) 
Installed from:    Compiled From Sources

Title says it all. The resize handle in the bottom left of the window (standard os x location for the native widget style) doesn't appear. Also doesn't show up if KDE's widget style oxygen is used (IIRC).
Comment 1 illogic-al 2008-09-01 17:10:05 UTC
bah. qt bug. forgot that. 
Comment 2 illogic-al 2008-09-30 02:16:31 UTC
Actually this is probably a KDE bug. Normal Qt programs don't have this problem.
Re-assign to whatever part of KDE it should belong to. 
Comment 3 Mark Kretschmann 2008-09-30 10:08:45 UTC
Ok, reassigning.
Comment 4 illogic-al 2008-11-10 00:46:55 UTC
*** Bug 174722 has been marked as a duplicate of this bug. ***
Comment 5 Leo Franchi 2008-11-19 13:37:27 UTC
SVN commit 886503 by lfranchi:

add resize handle on os x.... amarok is resizable!!

BUG: 170199

 M  +4 -0      MainWindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=886503
Comment 6 illogic-al 2009-02-10 02:36:05 UTC
Kate's got this problem too. Can a kate dev provide a patch for a possible fix. I be testin' yo.
Comment 7 Dominik Haumann 2009-05-20 10:10:24 UTC
There are two solutions for this.
1. Put a QSizeGrip into the sidebar at the bottom. This only works if the sidebar is visible.
2. Put a QSizeGrip into the statusbar, but the sidebar at the bottom is below, so the placement will be strange.

Solution 1 also has the flaw that if there are tabs in the right sidebar, that the size grip is then also not in the bottom right corner.

What solution is preferred? all of them suck ;)
Comment 8 Jan Gosmann 2009-09-15 19:45:37 UTC
This is bug is duplicate, see: #168809

I think most important is to make the window resizable. I do not care that much where the QSizeGrip sits. I think I would put it into the statusbar. Maybe it is possible to change the layout of the mainwindow a little bit to get the QSizeGrip always in the lower right corner? What is about swapping the position of the statusbar and the sidebar?
Comment 9 illogic-al 2009-09-16 01:17:23 UTC

*** This bug has been marked as a duplicate of bug 168809 ***