Bug 169748 - kate - pressing twice the defined shortcut for "focus terminal" does not focus back to document
Summary: kate - pressing twice the defined shortcut for "focus terminal" does not focu...
Status: RESOLVED DUPLICATE of bug 157523
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-24 23:31 UTC by Nikos Papas
Modified: 2009-11-17 15:05 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Papas 2008-08-24 23:31:38 UTC
Version:            (using KDE 4.1.0)
OS:                Linux
Installed from:    Ubuntu Packages

I have assigned a keyboard shortcut to the "focus terminal" command in kate. When I open a new document and input the shortcut I get the terminal with the cursor focused on it (I can type etc).

When I press the shortcut again the cursor does not go back to the document. However, if I go to Tools->Defocus Terminal it works fine. Note that the "Defocus Terminal" shows the same defined shortcut as the "Focus Terminal". 

Thanks for your time.
Comment 1 Nikos Papas 2008-10-26 10:37:49 UTC
The same problem happens in KDE 4.1.2
Comment 2 Nikos Papas 2008-11-14 10:36:10 UTC
Also in KDE 4.1.3
Comment 3 Dario Andres 2008-12-21 04:03:17 UTC
I can confirm here using:

Qt: 4.4.3
KDE: 4.1.85 (KDE 4.1.85 (KDE 4.2 Beta2))
kdelibs svn rev. 899135 / kdebase svn rev. 899135
on ArchLinux x86_64 - Kernel 2.6.27.8

I suppose that when you first Focus the terminal, the terminal part "receive" the key combination (and Kate can't catch the key shortcut to close go to the main view)
Comment 4 Nikos Papas 2008-12-21 10:45:39 UTC
Yeah, I have also installed KDE 4.1.85 by Kubuntu packages and still have the same problem.
Comment 5 Nikos Papas 2009-01-28 00:16:08 UTC
The problem still persists on KDE 4.2.
Comment 6 Nikos Papas 2009-05-30 00:06:58 UTC
Still in KDE 4.2.3
Comment 7 Nikos Papas 2009-06-03 19:26:11 UTC
Hi again.

I just installed KDE 4.2.4 and the problem is still here.
Comment 8 Nikos Papas 2009-06-04 14:55:22 UTC
An update: I discovered by accident that once I am focused on the terminal I can switch back to the document by pressing Shift+Tab. Maybe this can be useful to resolve this bug. Thanks
Comment 9 harry bennett 2009-07-06 02:57:31 UTC
I have the behavior of comment #8,... useful,... but counter-intuitive.
Comment 10 Nikos Papas 2009-08-08 23:19:41 UTC
The same happens in KDE 4.3.
Comment 11 Rafał Rzepecki 2009-11-17 15:05:51 UTC

*** This bug has been marked as a duplicate of bug 157523 ***