Bug 169642 - Konqueror crashes frequently at haaretz.com
Summary: Konqueror crashes frequently at haaretz.com
Status: RESOLVED DUPLICATE of bug 169447
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.1.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-23 08:29 UTC by eli
Modified: 2008-08-29 17:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eli 2008-08-23 08:29:15 UTC
Version:            (using KDE 4.1.0)
OS:                Linux
Installed from:    Fedora RPMs

When I visit http://www.haaretz.com Konqueror crashes freqently. Not always, but frequently.
Comment 1 A. Spehr 2008-08-23 08:46:14 UTC
Indeed. 4.1.62

Thread 1 (Thread 0xb5dab700 (LWP 5537)):
[KCrash Handler]
#6  0xb4029dcb in QVector<khtml::RenderLayer*>::at (this=0x0, i=0) at /home/ax4/kde/src/qt-copy/include/QtCore/../../src/corelib/tools/qvector.h:323
#7  0xb4027ff0 in khtml::RenderLayer::updateWidgetMasks (this=0x9d59fe8, rootLayer=0x9d59a18) at /home/ax4/kde/src/KDE/kdelibs/khtml/rendering/render_layer.cpp:404
#8  0xb40282c4 in khtml::RenderLayer::updateWidgetMasks (this=0x9d59f00, rootLayer=0x9d59a18) at /home/ax4/kde/src/KDE/kdelibs/khtml/rendering/render_layer.cpp:424
#9  0xb40282c4 in khtml::RenderLayer::updateWidgetMasks (this=0x9d59be8, rootLayer=0x9d59a18) at /home/ax4/kde/src/KDE/kdelibs/khtml/rendering/render_layer.cpp:424
#10 0xb40282c4 in khtml::RenderLayer::updateWidgetMasks (this=0x9d59b00, rootLayer=0x9d59a18) at /home/ax4/kde/src/KDE/kdelibs/khtml/rendering/render_layer.cpp:424
#11 0xb40282c4 in khtml::RenderLayer::updateWidgetMasks (this=0x9d59a18, rootLayer=0x9d59a18) at /home/ax4/kde/src/KDE/kdelibs/khtml/rendering/render_layer.cpp:424
#12 0xb405fbd6 in khtml::RenderCanvas::layout (this=0x9d59940) at /home/ax4/kde/src/KDE/kdelibs/khtml/rendering/render_canvas.cpp:199
#13 0xb3e82776 in KHTMLView::layout (this=0xa0ed678) at /home/ax4/kde/src/KDE/kdelibs/khtml/khtmlview.cpp:971
#14 0xb3e82c80 in KHTMLView::timerEvent (this=0xa0ed678, e=0xbfe578f4) at /home/ax4/kde/src/KDE/kdelibs/khtml/khtmlview.cpp:4029
#15 0xb74ffdaa in QObject::event (this=0xa0ed678, e=0xbfe578f4) at kernel/qobject.cpp:1105
#16 0xb6a6bd33 in QWidget::event (this=0xa0ed678, event=0xbfe578f4) at kernel/qwidget.cpp:7310
#17 0xb6dd9636 in QFrame::event (this=0xa0ed678, e=0xbfe578f4) at widgets/qframe.cpp:657
#18 0xb6e72902 in QAbstractScrollArea::event (this=0xa0ed678, e=0xbfe578f4) at widgets/qabstractscrollarea.cpp:897
#19 0xb6e79121 in QScrollArea::event (this=0xa0ed678, e=0xbfe578f4) at widgets/qscrollarea.cpp:297
#20 0xb3e80311 in KHTMLView::event (this=0xa0ed678, e=0xbfe578f4) at /home/ax4/kde/src/KDE/kdelibs/khtml/khtmlview.cpp:526
#21 0xb6a0cd95 in QApplicationPrivate::notify_helper (this=0x9a49610, receiver=0xa0ed678, e=0xbfe578f4) at kernel/qapplication.cpp:3772
#22 0xb6a0e9d2 in QApplication::notify (this=0xbfe57c38, receiver=0xa0ed678, e=0xbfe578f4) at kernel/qapplication.cpp:3739
#23 0xb79f4af7 in KApplication::notify (this=0xbfe57c38, receiver=0xa0ed678, event=0xbfe578f4) at /home/ax4/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#24 0xb74ecf67 in QCoreApplication::notifyInternal (this=0xbfe57c38, receiver=0xa0ed678, event=0xbfe578f4) at kernel/qcoreapplication.cpp:583
#25 0xb74f0c6d in QCoreApplication::sendEvent (receiver=0xa0ed678, event=0xbfe578f4) at ../../include/QtCore/qcoreapplication.h:215
#26 0xb751f0af in QTimerInfoList::activateTimers (this=0x9a4c514) at kernel/qeventdispatcher_unix.cpp:563
#27 0xb751c89c in timerSourceDispatch (source=0x9a4c4e0) at kernel/qeventdispatcher_glib.cpp:166
#28 0xb605f2e1 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#29 0xb6062973 in ?? () from /usr/lib/libglib-2.0.so.0
#30 0x09a4b858 in ?? ()
#31 0x00000000 in ?? ()

Comment 2 Frank Reininghaus 2008-08-29 17:33:20 UTC
This looks very much like a duplicate of a bug reported earlier (which has a reduced testcase). The backtraces look very similar, and also the haaretz.com page contains the CSS attributes which caused the crash in the other bug ("position: absolute" and a negative z-index in the CSS file http://www.haaretz.com/hasen/scripts/newstyle.css linked to in the haaretz.com start page).

*** This bug has been marked as a duplicate of bug 169447 ***