Bug 169411 - kde4.1 knode problem with iso 8859-15
Summary: kde4.1 knode problem with iso 8859-15
Status: RESOLVED FIXED
Alias: None
Product: knode
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-18 23:49 UTC by Martin Schlander
Modified: 2009-03-09 22:36 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Add hyphen to ISO encodings in KCharset (3.67 KB, patch)
2008-12-05 20:50 UTC, Olivier Trichet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schlander 2008-08-18 23:49:54 UTC
Version:            (using KDE 4.1.0)
OS:                Linux
Installed from:    SuSE RPMs

I've configured knode to post using ISO 8859-15. 

In the headers of posts sent by me there's this:
Content-Type: text/plain; charset="ISO 8859-15"

Apparently this causes charset problems for others, seems it should be "iso-8859-15" (note the extra dash). However KNode displays my posts fine though, so I didn't notice until others started complaining about me :-).

Manually changing the config file seems to work as a work-around, I've entered this:

[POSTNEWS]
8BitEncoding=true
Charset=iso-8859-15

The configuration originally written by KNode, which caused the problem, was:

[POSTNEWS]
8BitEncoding=true
Charset=ISO 8859-15
Comment 1 Martin Schlander 2008-08-18 23:53:29 UTC
Btw., I'm pretty sure the same problem goes for many of the other encodings. I only actually tested with ISO 8859-1 though, which has the same problem.
Comment 2 Thomas Bigot 2008-11-25 16:20:46 UTC
I confirm, I have the same problem using:
$ kontact --version
Qt: 4.4.3
KDE: 4.1.80 (KDE 4.1.80 (KDE 4.2 Beta1))
Kontact: 1.3

And the workaround works fine.
Comment 3 Thomas Bigot 2008-11-25 16:24:10 UTC
More useful, the version of knode, if needed:

$ knode --version
Qt: 4.4.3
KDE: 4.1.80 (KDE 4.1.80 (KDE 4.2 Beta1))
KNode: 0.99.01
Comment 4 Olivier Trichet 2008-11-26 10:12:23 UTC
Volker,
this issue is worked around in KMail by the method KMMsgBase::fixEncoding().
Would it be possible to share it with KNode somehow ?
Comment 5 Thomas McGuire 2008-11-26 12:37:19 UTC
I'd prefer if someone would fix KCharsets instead, but it has scary lookup tables so I didn't dare to change anything there.
Comment 6 Olivier Trichet 2008-12-05 20:50:56 UTC
Created attachment 29071 [details]
Add hyphen to ISO encodings in KCharset

This patch add hyphen to all ISO-encoding declared in KCharset.

Is it really the place where we want to make the change ? All KDE application will be 
affected and therefore a user defined charset will not be found in the lists returned by the KCharset after this. (ok it's no big deal).

(note : the not so scary lookup tables does not appears in the diff because they do not change, not because I did not take care. :-))
Comment 7 Olivier Trichet 2008-12-09 20:39:34 UTC
SVN commit 895000 by otrichet:

Use a workaround from kmail to address bug 169411: knode sends post with charset "iso xxxx-x" instead of proper "iso-xxxx-x".
For the kde 4.1 branche only

CCBUG: 169411


 M  +15 -1     kncomposer.cpp  
 M  +6 -1      kncomposer.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=895000
Comment 8 Davide Ferrari 2009-01-05 12:13:11 UTC
Is this fixed in KDE4.2 as well? I'm using beta2 and the problem is present here as well
Comment 9 Volker Krause 2009-01-16 18:00:37 UTC
SVN commit 912072 by vkrause:

Forwardport SVN commit 895000 by otrichet from 4.1 branch:

Use a workaround from kmail to address bug 169411: knode sends post with
charset "iso xxxx-x" instead of proper "iso-xxxx-x".
For the kde 4.1 branche only

CCBUG: 169411


Is the underlying problem fixed in trunk or should I merge this
workaround there as well?

CCMAIL: nive@nivalis.org
CCMAIL: mcguire@kde.org


 M  +15 -1     kncomposer.cpp  
 M  +6 -1      kncomposer.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=912072
Comment 10 Volker Krause 2009-01-24 13:55:41 UTC
SVN commit 916050 by vkrause:

Forwardport SVN commit 895000 by otrichet from 4.1 branch:

Use a workaround from kmail to address bug 169411: knode sends post with
charset "iso xxxx-x" instead of proper "iso-xxxx-x".
For the kde 4.1 branche only

CCBUG: 169411


 M  +15 -1     kncomposer.cpp  
 M  +6 -1      kncomposer.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=916050
Comment 11 Olivier Trichet 2009-03-09 22:36:29 UTC
Closing this bugs, the ugly workaround is seen as ok...

http://lists.kde.org/?l=kde-pim&m=123481713832253&w=2