Bug 169214 - Lens auto correction tool should try to determine correct lens from metadata
Summary: Lens auto correction tool should try to determine correct lens from metadata
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-LensCorrection (show other bugs)
Version: 0.10.0
Platform: unspecified Linux
: NOR wishlist with 5 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-16 02:56 UTC by Gandalf Lechner
Modified: 2022-01-18 16:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gandalf Lechner 2008-08-16 02:56:29 UTC
Version:           0.10.0-beta3 (rev.: 847555) (using 4.1.00 (KDE 4.1.0), Kubuntu packages)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.24-17-generic

The lens auto correction tool is pretty cool: As far as I can tell it tries to determine the make and model of the camera from the metadata of the picture under consideration to extract the correct crop factor from the lensfun database (My camera is not yet in the database, therefore I'm not sure). However, it does not seem to try to also determine the lens used for taking the picture, although this information is stored in the metadata as well.

Maybe the data stored in the picture are not sufficient to uniquely determine the lens (there seems to be only the focal length range in the metadata, and no particular lens name), but at least they could be used to narrow down the list of possible lenses to few possibilities. Only these few lenses should be shown in the drop down list of the lens auto correction tool if "use metadata" is checked. In many cases, this would make further input from the user unnecessary.
Comment 1 Andi Clemens 2009-03-10 11:52:18 UTC
I think this is a duplicate of bug 184156. Since the discussion is longer in there, I will close this one.

*** This bug has been marked as a duplicate of bug 184156 ***
Comment 2 caulier.gilles 2022-01-18 16:45:35 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=184156