Bug 168806 - Crash when closing Konqueror
Summary: Crash when closing Konqueror
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 166541 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-09 14:26 UTC by Andy Elvey
Modified: 2009-08-02 20:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Error trace for Konqueror crash (3.84 KB, text/plain)
2008-08-09 14:28 UTC, Andy Elvey
Details
A detailed trace of the Konqueror crash. (3.03 KB, text/plain)
2008-08-10 03:50 UTC, Andy Elvey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Elvey 2008-08-09 14:26:48 UTC
Version:           4.1.00 (using KDE 4.1.0)
Installed from:    Ubuntu Packages
OS:                Linux

This crash is easily reproducible. 

 Whenever I close Konqueror 4.1.00 (either by clicking on "x" at top-right of screen, or by choosing "File, Quit" - Konqueror crashes and I get this error message - 

"A Fatal Error Occurred
The application Konqueror (konqueror) crashed and caused the signal 6 (SIGABRT)."  

 This happens every time, no matter which website I go to. 

 As soon as I've saved this report, I'll try to attach a trace of the errors. That may help. 
- Andy
Comment 1 Andy Elvey 2008-08-09 14:28:09 UTC
Created attachment 26750 [details]
Error trace for Konqueror crash
Comment 2 Christophe Giboudeaux 2008-08-09 18:22:27 UTC
Your backtrace is useless.

Please read the following page and provide a useful backtrace for this crash : http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 3 Andy Elvey 2008-08-10 03:50:15 UTC
Created attachment 26763 [details]
A detailed trace of the Konqueror crash. 

Detailed trace of the Konqueror crash. Apologies for the useless trace included
before.
Comment 4 Dominik Tritscher 2008-08-11 20:52:32 UTC
Thanks for the trace.
Copy&Paste for ease of searching similar crashes:
(gdb) backtrace
#0  0xb7ef8410 in __kernel_vsyscall ()
#1  0xb7ce8085 in raise () from /lib/tls/i686/cmov/libc.so.6
#2  0xb7ce9a01 in abort () from /lib/tls/i686/cmov/libc.so.6
#3  0xb7ce110e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#4  0xb43cbf33 in khtml::Cache::clear ()
    at /build/buildd/kde4libs-4.1.0/khtml/misc/loader.cpp:1598
#5  0xb424e00a in ~KHTMLGlobal (this=0x83a0f28)
    at /build/buildd/kde4libs-4.1.0/khtml/khtml_global.cpp:99
#6  0xb424e0af in KHTMLGlobal::deref ()
    at /build/buildd/kde4libs-4.1.0/khtml/khtml_global.cpp:133
#7  0xb424e1f5 in KHTMLGlobal::deregisterPart (part=0x80ddeb8)
    at /build/buildd/kde4libs-4.1.0/khtml/khtml_global.cpp:160
#8  0xb423c287 in ~KHTMLPart (this=0x80ddeb8)
    at /build/buildd/kde4libs-4.1.0/khtml/khtml_part.cpp:548
#9  0xb7e631da in KonqView::~KonqView ()
   from /usr/lib/kde4/lib/libkdeinit4_konqueror.so
#10 0xb7e6b6cf in KonqViewManager::clear ()
   from /usr/lib/kde4/lib/libkdeinit4_konqueror.so
#11 0xb7e6ebe9 in KonqViewManager::~KonqViewManager ()
   from /usr/lib/kde4/lib/libkdeinit4_konqueror.so
#12 0xb7eb0ae6 in KonqMainWindow::~KonqMainWindow ()
   from /usr/lib/kde4/lib/libkdeinit4_konqueror.so
#13 0xb743bf8c in qDeleteInEventHandler (o=0x6) at kernel/qobject.cpp:3595
#14 0xb743defc in QObject::event (this=0x8238048, e=0x8803958)
    at kernel/qobject.cpp:1124
#15 0xb6970c4f in QWidget::event (this=0x8238048, event=0x8803958)
    at kernel/qwidget.cpp:7310
#16 0xb6cc37a5 in QMainWindow::event (this=0x8238048, event=0x8803958)
    at widgets/qmainwindow.cpp:1252
#17 0xb7962de3 in KMainWindow::event (this=0x8238048, ev=0x8803958)
    at /build/buildd/kde4libs-4.1.0/kdeui/widgets/kmainwindow.cpp:1018
#18 0xb799e63c in KXmlGuiWindow::event (this=0x8238048, ev=0x8803958)
    at /build/buildd/kde4libs-4.1.0/kdeui/xmlgui/kxmlguiwindow.cpp:122
#19 0xb7e940a1 in KonqMainWindow::event ()
   from /usr/lib/kde4/lib/libkdeinit4_konqueror.so
#20 0xb6919c0c in QApplicationPrivate::notify_helper (this=0x805cbc0, 
    receiver=0x8238048, e=0x8803958) at kernel/qapplication.cpp:3772
#21 0xb691e888 in QApplication::notify (this=0xbfbda35c, receiver=0x8238048, 
    e=0x8803958) at kernel/qapplication.cpp:3739
#22 0xb78aaf53 in KApplication::notify (this=0xbfbda35c, receiver=0x8238048, 
    event=0x8803958)
    at /build/buildd/kde4libs-4.1.0/kdeui/kernel/kapplication.cpp:311
#23 0xb742d6a9 in QCoreApplication::notifyInternal (this=0xbfbda35c, 
    receiver=0x8238048, event=0x8803958) at kernel/qcoreapplication.cpp:587
#24 0xb742ea59 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, 
    event_type=52, data=0x804b6b0)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 0xb742ec7d in QCoreApplication::sendPostedEvents (receiver=0x0, 
    event_type=52) at kernel/qcoreapplication.cpp:1091
#26 0xb742ed72 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:850
#27 0xb6919567 in QApplication::exec () at kernel/qapplication.cpp:3304
#28 0xb7ede6fd in kdemain () from /usr/lib/kde4/lib/libkdeinit4_konqueror.so
#29 0x08048582 in _start ()
(gdb) 
Comment 5 Maksim Orlovich 2008-08-25 20:15:07 UTC

*** This bug has been marked as a duplicate of bug 151453 ***
Comment 6 Dario Andres 2009-08-02 20:27:09 UTC
*** Bug 166541 has been marked as a duplicate of this bug. ***