Bug 168550 - crash in konq (cause unknown)
Summary: crash in konq (cause unknown)
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-06 21:30 UTC by Neal Becker
Modified: 2008-08-13 21:04 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neal Becker 2008-08-06 21:30:03 UTC
Version:            (using KDE 4.1.0)
Installed from:    Fedora RPMs

konq crash repeatably when visiting this url:
http://www.bikecvcc.com/cvcc_century.html
Comment 1 Christophe Giboudeaux 2008-08-06 22:10:45 UTC
Just loading the page works perfectly here.


Please post a backtrace following the instructions on: 
http://techbase.kde.org/Contribute/Bugsquad/How_to_create_useful_crash_reports
Comment 2 Dario Andres 2008-08-06 22:52:27 UTC
Using KDE 4.1.1 (KDE 4.1.0 (4.1 >= 20080722)) (KDEmod) in ArchLinux:
Trying to reproduce this bug I experience a crash when closing the Konqueror window at the test URL (http://www.bikecvcc.com/cvcc_century.html) (That URL loaded without crashing Konq)

Here is the backtrace:

Aplicación: Konqueror (konqueror), señal SIGABRT
[Thread debugging using libthread_db enabled]
[New Thread 0xb6411700 (LWP 3957)]
[KCrash handler]
#6  0xb8056424 in __kernel_vsyscall ()
#7  0xb678d740 in raise () from /lib/libc.so.6
#8  0xb678f078 in abort () from /lib/libc.so.6
#9  0xb678668e in __assert_fail () from /lib/libc.so.6
#10 0xb44b4cef in KHTMLGlobal::finalCheck ()
    at /home/jan/Source/packages/kde41/work/kdelibs/src/kdelibs-4.1.0/khtml/khtml_global.cpp:247
#11 0xb4888443 in ~KHTMLFactory (this=0x916fca0)
    at /home/jan/Source/packages/kde41/work/kdelibs/src/kdelibs-4.1.0/khtml/khtml_factory.cpp:35
#12 0xb75672fb in QObjectCleanupHandler::clear () from /usr/lib/libQtCore.so.4
#13 0xb7567340 in QObjectCleanupHandler::~QObjectCleanupHandler ()
   from /usr/lib/libQtCore.so.4
#14 0xb781f1f6 in destroy ()
    at /home/jan/Source/packages/kde41/work/kdelibs/src/kdelibs-4.1.0/kdecore/util/kpluginfactory.cpp:29
#15 0xb76db86d in ~KCleanUpGlobalStatic (this=0xb785b6f4)
    at /home/jan/Source/packages/kde41/work/kdelibs/src/kdelibs-4.1.0/kdecore/kernel/kglobal.h:67
#16 0xb67906c9 in exit () from /lib/libc.so.6
#17 0xb67795cd in __libc_start_main () from /lib/libc.so.6
#18 0x080486e1 in _start ()
#0  0xb8056424 in __kernel_vsyscall ()
Comment 3 Frank Reininghaus 2008-08-13 19:36:43 UTC
concerning comment #2: The crash when closing Konqueror is most probably bug #156172 which was fixed a few days ago.

Neal, did your crash also happen when you closed Konqueror after visiting the site? If yes, this bug is probably a duplicate of bug #156172.
Comment 4 Maksim Orlovich 2008-08-13 21:04:28 UTC
From bt, he was indeed exiting.

*** This bug has been marked as a duplicate of 151453 ***