Bug 168501 - Confusing non-standard use of widgets in KColorEdit
Summary: Confusing non-standard use of widgets in KColorEdit
Status: RESOLVED FIXED
Alias: None
Product: kcoloredit
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Percy Camilo Triveño Aucahuasi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-06 12:32 UTC by Karl Ove Hufthammer
Modified: 2009-08-10 09:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Proposal of change. (76.84 KB, image/jpeg)
2008-08-15 00:09 UTC, Percy Camilo Triveño Aucahuasi
Details
fixed bugs second round (135.85 KB, image/png)
2008-08-17 00:39 UTC, Percy Camilo Triveño Aucahuasi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Ove Hufthammer 2008-08-06 12:34:09 UTC
Version:           1.90.00 (KColorEdit 1.9) (using 4.1.1 (KDE 4.1.0 (4.1 >= 20080722)), compiled sources)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25.11-60.fc8

KColorEdit uses the KDE widgets in a non-standard way, which I, and I guess many others, find *very* confusing.

Example 1: There is a drop-down button called 'RGB Model'. I click on it, expecting to change the colour model, but what do I get? A list of three numbers. Result: I go away very confused.

Example 2: There is a drop-down button called 'Complement'. I click on it, expecting to change the automatically generated colours, but what do I get? A 'Add colors' button. Result: I go away even more confused.

Example 3: There are some arrows below the coloured rectangle. I have no idea what they do, but perhaps they change the colour of the above gradient? Seems sensible. I click on one of them. What happens? The colour did not change, but the contents of the drop-down button (which is very far away from the arrows) change. Result: I am confused, but I begin to understand how things are supposed to work. But I'm puzzled why the author chose the give non-standard behaviours to the widgets in the dialogue.

Now, about a month (?) later I accidently opens KColorEdit again. What happens? The exact same examples as above. Conclusion: Non-standard behaviour is confusing, difficult to learn and very user-unfriendly. Please change it.
Comment 1 Christoph Feck 2008-08-06 13:40:40 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Percy Camilo Triveño Aucahuasi 2008-08-09 02:45:38 UTC
Hi Karl, I'm the current maintainer of KColorEdit and the developer of this version (1.9), thanks for check arround KColorEdit. Mainly I was trying to add some new features and my plan was finish until the version 2.0 but I didn't have enough time. 

I will take your feedback, please if you can tell me more features/behaviours that aren't intuitive then I will try to solved it ... for the moment I'm working now on your comments ; ).

Finally, note that now there are more features and improvements in this applicacion so I'm sure that are only a few remains about the user interface that I have to fix, please be patient ; )

Best regards,
Percy
Comment 3 Percy Camilo Triveño Aucahuasi 2008-08-15 00:09:44 UTC
Created attachment 26853 [details]
Proposal of change.

Image with the new proposal UI.
Comment 4 Percy Camilo Triveño Aucahuasi 2008-08-15 00:13:00 UTC
SVN commit 847188 by aucahuasi:

CCBUG: 168501

Ok I was working arround the UI and this are the first results (see the image link):
http://img143.imageshack.us/img143/5058/defaultviewie4.jpg

I think this UI is more intuitive and follows the KDE standar.
Also, I'm attaching the same image in the bug tracker (see bellow).



 M  +0 -1      CMakeLists.txt  
 M  +2 -0      app/main.cpp  
 M  +1 -1      widgets/colorinfo/colorinfo.cpp  
 M  +1 -1      widgets/colorinfo/colorinfo.h  
 M  +52 -39    widgets/colorinfo/colorinfotext.cpp  
 M  +18 -12    widgets/colorinfo/colorinfotext.h  
 M  +6 -18     widgets/colorinfo/colorinfovisual.cpp  
 M  +8 -8      widgets/colorselectors/blenderselector/blendercolorselector.cpp  
 M  +1 -1      widgets/colorselectors/colorselector.cpp  
 M  +1 -1      widgets/colorselectors/colorselector.h  
 M  +5 -5      widgets/colorselectors/gtkselector/gtkcolorselector.cpp  
 M  +20 -20    widgets/colorselectors/kdeselector/kdecolorselector.cpp  
 M  +2 -1      widgets/kcoloreditpage.cpp  
 M  +3 -1      widgets/kcoloreditpage.h  
 M  +22 -21    widgets/kcoloreditwidget.cpp  
 M  +105 -91   widgets/multipagewidget.cpp  
 M  +76 -56    widgets/multipagewidget.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=847188
Comment 5 Karl Ove Hufthammer 2008-08-15 16:21:58 UTC
Great! That’s much better. Some more comments:

I find the buttons ‘Add color’ and ‘Insert color’ confusing. Initially, I would think they would do the same thing. After some trial and error, I finally discovered what the difference was, but the names are still confusing. I propose removing the 'Insert' button, and instead make it possible to select an area between colours, which 'Add' will then insert new colours into. See for example how the interface in the KDE app Basket works. There you can easily insert notes between other notes.

Also, I found no way to add the automatically generated colours (e.g., the three tetradic colours) to the palette.

Finally, the palette (on the right-hand side of the window) doesn’t work the way I would expect it to. When clicking a colour in the RHS palette, I would expect this to change the main colour (the colour in the gradient), and update the automatically generated colours, but it doesn’t. Instead it justs selects the colour rectangle, and there appears a button on the colour, but pressing this brings up a new colour chooser, much more limited than the one in KColorEdit itself, strangely enough. My suggestion: Make clicking the colour change to this colour, and remove the button.
Comment 6 Percy Camilo Triveño Aucahuasi 2008-08-17 00:38:37 UTC
SVN commit 848092 by aucahuasi:

CCBUG: 168501

Hi there ; ), thanks for your feedback Karl ; )

1) About the use of "Add" and "Insert" buttons:
They have diferent functions. The first, add the main color to end of the palette and the other, insert the main color in the position of the current selected item of the palette. 

So, I changed the icons of Add and Insert, I renamed the button Add to  "Append" and moreover I will put a tooltip in the Append and Insert buttons ... 

However, I don't think that remove the Insert button is a good idea, many users would want put a color in a specific position inside the palette, unfortunately I don't have here the Basket app, but I think that with this changes the issue is solved.

2) About add colors from the tetradic scheme:
This funcion works ok, however I made some improvements, now each color of any scheme (complement or tetradic) has a button with the "plus symbol" to append the color to the palette.

3) About the brief view or palette issue:
I made all the changes that you requested, I think your point was right.

To see the changes of the points 1 and 2 please check this link (also attached to the bugtracker)

http://img48.imageshack.us/img48/1046/fixedbugsyy3.png

Regards
Percy


 M  +1 -0      CMakeLists.txt  
 M  +4 -3      app/kcoloredit.cpp  
 M  +0 -2      app/main.cpp  
 M  +7 -19     itemviews/palettebriefview.cpp  
 M  +4 -3      itemviews/palettebriefview.h  
 M  +7 -6      itemviews/palettedetailview.cpp  
 M  +2 -2      widgets/colorselectors/blenderselector/blendercolorselector.cpp  
 M  +0 -8      widgets/colorselectors/gtkselector/gtkcolorselector.cpp  
 M  +0 -4      widgets/colorselectors/gtkselector/gtkcolorselector.h  
 A             widgets/colortoolwidget.cpp   [License: UNKNOWN]
 A             widgets/colortoolwidget.h   [License: UNKNOWN]
 M  +8 -10     widgets/colorwidget.cpp  
 M  +4 -6      widgets/colorwidget.h  
 M  +13 -11    widgets/kcoloreditwidget.cpp  
 M  +4 -0      widgets/kcoloreditwidget.h  
 M  +1 -1      widgets/multipagewidget.cpp  
 M  +2 -2      widgets/multipagewidget.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=848092
Comment 7 Percy Camilo Triveño Aucahuasi 2008-08-17 00:39:54 UTC
Created attachment 26888 [details]
fixed bugs second round

more fixed bugs.
Comment 8 Percy Camilo Triveño Aucahuasi 2008-08-27 07:03:49 UTC
I think that this bug should be closed as resolved, becouse I was improved a lot of things and fixed all the issues/comments that Karl has sent me.

Regards,
Percy
Comment 9 Karl Ove Hufthammer 2008-08-27 09:57:51 UTC
I’ll try to compile the latest version, and take a look. Please keep the bug open till then.
Comment 10 Percy Camilo Triveño Aucahuasi 2008-08-29 01:46:37 UTC
Ok I'll waiting for your comments ; )

Comment 11 Percy Camilo Triveño Aucahuasi 2008-09-13 12:08:51 UTC
http://extragear.kde.org/apps/kcoloredit/
Comment 12 Karl Ove Hufthammer 2009-06-04 12:57:59 UTC
Sorry for the very late reply. I’ve now taken a look at the KDE 4.2.3 version of KColorEdit, and I’m happy to say that it’s a vast improvement over the old version.

I still find the names and function of ‘Insert Color‘ and ‘Append Colour’, though.

One more thing: ‘CMYK Model‘ really should be called ‘CMY Model‘, as there’s no blacK component. Also, the label ‘Color information’ is a bit strange. Shouldn’t it be ‘Color Model’ (with the actual choices shortened, e.g. from ‘RGB Model’ to just ‘RGB’).

One last thing: Click on the text field part of a colour and typing doesn’t work. You have to click twice.
Comment 13 Percy Camilo Triveño Aucahuasi 2009-06-12 09:42:26 UTC
Hi Karl, glad to get news about you ;). 

>I’m happy to say that it’s a vast improvement 
>over the old version.

I'm happy to read this :)

>I still find the names and function of ‘Insert Color‘ 
>and ‘Append Colour’, though.

Yes, in fact I already thought the same about this issue. 

Thanks for your feedback, I will change the app acording your comments. 

The issue with ‘Insert Color‘/‘Append Colour’ and the rest ones will be solved in KColorEdit 2.1. I already have more ideas about this version, but currently I haven't enought time. Fortunately, I will get vacations in ~1 month ... so please be patient. 

Finally, I'm going to send to this thread news when I start to develop the version 2.1

Cheers, 
Percy ;)
Comment 14 Percy Camilo Triveño Aucahuasi 2009-08-10 09:12:12 UTC
SVN commit 1009477 by aucahuasi:

GUI: Many i18n issues solved
CCBUG: 197704
CCBUG: 168501
CCBUG: 176744

ned: Now the height of the window can be reduce until -arround- 550 pixels ... so, this solved the bug ;)

Karl: 
* The function ‘Append Colour’ is now moved to the color box (under a button with plus sign) ... now only exist ‘Insert Color‘ ... so no more ‘Append Colour’ and ‘Insert Color‘ functions (at least not explicity) ... I guess this solve the issue ;)

* ‘CMYK Model‘ is now ‘CMY Model‘

* The label ‘Color information’ is now ‘Color Model’ (with the actual choices shortened, e.g. from
‘RGB Model’ to just ‘RGB’) ... ;)

* Click once on the text field is giving the focus to edit the colour name ... without click twice ... solved too


This version is a RC of 2.1. I improved some GUI aspects (extras - selector for instance) ... I will continue working KColorEdit ... taking advantage my vacations :)

Cheers,
Percy


 M  +0 -15     desktop/kcoloreditui.rc  
 M  +11 -99    src/app/kcoloredit.cpp  
 M  +0 -12     src/app/kcoloredit.h  
 M  +2 -2      src/app/main.cpp  
 M  +4 -4      src/core/palette.cpp  
 M  +3 -3      src/itemviews/palettebriefview.cpp  
 M  +123 -5    src/itemviews/palettedetailview.cpp  
 M  +29 -0     src/itemviews/palettedetailview.h  
 M  +3 -3      src/widgets/colorinfo/colorinfotext.cpp  
 M  +30 -0     src/widgets/colorinfo/colorinfovisual.cpp  
 M  +17 -0     src/widgets/colorinfo/colorinfovisual.h  
 M  +4 -4      src/widgets/colorselectors/blenderselector/blendercolorselector.cpp  
 M  +2 -2      src/widgets/colorselectors/gtkselector/trianglecolorwidget.cpp  
 M  +2 -2      src/widgets/colorselectors/kdeselector/rectanglecolorwidget.cpp  
 M  +91 -68    src/widgets/colortoolwidget.cpp  
 M  +11 -6     src/widgets/colortoolwidget.h  
 M  +7 -4      src/widgets/colorwidget.cpp  
 M  +33 -27    src/widgets/kcoloreditwidget.cpp  
 M  +6 -4      src/widgets/kcoloreditwidget.h  
 M  +2 -0      src/widgets/palettedelegateeditors.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1009477