Bug 168481 - Dolphin cannot open folders whose name includes an accent on Samba shares
Summary: Dolphin cannot open folders whose name includes an accent on Samba shares
Status: RESOLVED DUPLICATE of bug 158639
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: smb (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 173358 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-06 09:36 UTC by François Tissandier
Modified: 2008-12-20 12:06 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
Screen capture of failing share access (117.44 KB, image/jpeg)
2008-11-28 09:28 UTC, alexis.deruelle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description François Tissandier 2008-08-06 09:36:47 UTC
Version:            (using KDE 4.1.0)
Installed from:    Ubuntu Packages
OS:                Linux

Ubuntu Hardy, KDE 4.1 RC1, Dolphin 1.00.99.

SMB folders containing a character with an accent (like the french é or à or è) can't be opened using Dolphin. They don't even appear as folder, but as unknown files.

Local folders with an accent are working fine (even on NTFS partitions). So apparently, it's specific to SMB shares.
Comment 1 Guillermo Antonio Amaral Bastidas 2008-08-09 09:32:45 UTC
Confirmed on Gentoo KDE 4.x trunk. Fixed.
Comment 2 Jan Schumacher 2008-08-20 00:01:08 UTC
I can confirm this on Hardy with KDE 4.1 (final) in Dolphin and Konqueror. German "umlaute" aren't displayed correctly - Message "File does not exist" appears when browsing the directory. These folders and files are displayed as files with zero size and can't be deleted. No problems using KDE 3.5.9 on the same machine.
Comment 3 alexis.deruelle 2008-09-12 09:07:14 UTC
The same here accessing shares with french accented chars like é è à etc.
kdebase-runtime-4.1.0-3.fc9.i386
Comment 4 François Dulaurier 2008-10-01 08:57:41 UTC
Confirmed for me too.

KDE 3.5 or 4.1.1 & SMB 3 on Kubuntu Hardy or XUbuntu Hardy

Same problem whatever the file explorer (nautilus, konqueror, dolphin), the shared filesytem (NTFS or ext3), the access method (smbmount or smb:/).

Access to KDE3 from KDE4 : problem! (NTFS or ext3 shares)
Access to KDE4 from KDE3 : problem!
Access to WinXP from KDE3 & 4 : problem!
Access to KDE3 & 4 from WinXP : NO problem!

It IS specific to Samba.
Comment 5 Diego Collaziol 2008-10-02 22:16:00 UTC
I can confirm this bug using Kubuntu Intrepid, with kde 4.1.2 and Dolphin 1.1. The kde 3.5.9 works without problems, and the problem is specific to samba. My server is samba 3.0 (Debian)
Comment 6 Valery Bulash 2008-11-25 16:54:19 UTC
Confirm for Mandriva 2009.0 Free (KDE 4.1.3).
- Configure Samba.
- Check access to Windows machine shared folder by smb:/server/resources.
- Gnome Nautilus accesses this folder in both cases - whether it contains UTF-8 characters or not.
- KDE Dolphin / Konqueror accesses this folder only in case when no UTF-8 characters inside. Otherwise reported something like "protocol smb:/server/resources suddenly closed" in status bar.

Can't use KDE to access corporate resources - forced to use Gnome just for this purpose
Comment 7 alexis.deruelle 2008-11-28 09:28:45 UTC
Created attachment 28872 [details]
Screen capture of failing share access
Comment 8 Alejandro Lorenzo 2008-12-03 12:12:08 UTC
Still present in Kde SVN from 2008/12/03
Comment 9 Alejandro Lorenzo 2008-12-06 19:04:18 UTC
Correction. It works with KDE SVN:  KDE 4.1.82 (KDE 4.2 >= 20081204)

It looks like i mis-executed the 4.1 version i have installed by the SVN version.

So, it works for me now...
Comment 10 FiNeX 2008-12-20 03:44:41 UTC
*** Bug 173358 has been marked as a duplicate of this bug. ***
Comment 11 FiNeX 2008-12-20 12:06:25 UTC

*** This bug has been marked as a duplicate of bug 158639 ***