Bug 168400 - Problem with setting current local timezone (Bratislav to Prague)
Summary: Problem with setting current local timezone (Bratislav to Prague)
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-05 11:07 UTC by Ladislav Nesnera
Modified: 2018-02-23 21:20 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
mysql.err (1.55 KB, application/octet-stream)
2009-05-13 22:10 UTC, Ladislav Nesnera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ladislav Nesnera 2008-08-05 11:07:37 UTC
Version:            (using Devel)
Installed from:    Compiled sources

I tried to change timezone from Bratislava to Prague but this setting is turned back to Bratislava always. This issue has impact to Kontact becouse setting through Kontact's configuration doesn't work too. I this case all calendar events have wrong area by default.
Comment 1 Ladislav Nesnera 2008-09-30 16:35:00 UTC
This problem persists still :-(
Qt: 4.4.3
KDE: 4.1.2 (KDE 4.1.1 (KDE 4.1 >= 20080828)) "release 52.3"
Kontact: 1.3
Comment 2 Dotan Cohen 2009-04-24 19:43:36 UTC
I cannot reproduce in KDE 4.2.2. Please provide explicit reproduction instructions. Is your system clock set to UTC?
Comment 3 Ladislav Nesnera 2009-04-27 12:45:38 UTC
OK. I tried to change time zone by two ways.
I. by Kontact settings:
1) Settings > Configrue Calendar > Time and Date > Regional (http://www.abclinuxu.cz/images/screenshots/5/3/102535-store-for-snapshots-18419.png)
2) It seems be well but only if you don't close Kontact. After that setting is turned back.
II. by KDE's Personal Settings
1) Personal Settings (Configure Desktop) > General > Computer Administration > Date & Time
2) Confirm this dialog (http://www.abclinuxu.cz/images/screenshots/5/3/102535-store-for-snapshots-18422.png)
3) If I close Personal Settings local time zone is changed back :?(

I'm using NTP server clock-1.cs.cmu.edu on boot.

Current environment:
Qt: 4.5.1
KDE: 4.2.70 (KDE 4.2.70 (KDE 4.3 >= 20090415)) "release 1.4"
Kontact: 4.3.0 pre
LSB Version:    core-2.0-noarch:core-3.2-noarch:core-2.0-x86_64:core-3.2-x86_64:desktop-3.2-amd64:desktop-3.2-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.2-amd64:graphics-3.2-noarch
Distributor ID: SUSE LINUX
Description:    openSUSE 11.1  (x86_64)
Release:        11.1
Codename:       n/a
Comment 4 Ladislav Nesnera 2009-05-13 22:10:26 UTC
Created attachment 33643 [details]
mysql.err
Comment 5 Ladislav Nesnera 2009-05-13 22:12:50 UTC
It could be tied with attached Akonadi's log above
Comment 6 Ladislav Nesnera 2009-07-08 12:35:16 UTC
I found solution in this mail thread http://osdir.com/ml/kde-bugs-dist/2009-06/msg15481.html. Date & Time (under Personal Settings) doesn't change LocalZone parameter in $KDEHOME/share/config/ktimezonerc file.
=> this bug is maybe duplicate to Bug 196316
Comment 7 Ben Creasy 2018-02-23 21:20:33 UTC
If this is happening with KDE 5, please leave a comment.