Bug 168278 - Plasma crashes when configuring File Watcher plasmoid
Summary: Plasma crashes when configuring File Watcher plasmoid
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 170511 178140 178626 183896 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-03 23:51 UTC by Alexey Chernov
Modified: 2009-02-10 11:46 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash report for the bug (6.96 KB, text/plain)
2008-08-03 23:51 UTC, Alexey Chernov
Details
plasma-filewatcher.kcrash (3.96 KB, application/octet-stream)
2008-09-21 14:49 UTC, Jonathan Thomas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Chernov 2008-08-03 23:51:21 UTC
Version:            (using KDE 4.1.0)
Installed from:    Compiled From Sources
Compiler:          GCC 4.1.2 Target: x86_64-unknown-linux-gnu Configured with: ../gcc-4.1.2/configure --prefix=/usr --libexecdir=/usr/lib --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-languages=c,c++ --disable-multilib Thread model: posix
OS:                Linux

Plasma crashes after confirming File Watcher plasmoid configuration. It however shows content of the file for a while and then plasma crashes. Backtrace will follow.
Comment 1 Alexey Chernov 2008-08-03 23:51:47 UTC
Created attachment 26611 [details]
Crash report for the bug
Comment 2 Aaron J. Seigo 2008-08-04 00:30:18 UTC
(pasting backtrace directly into bug report for easier searching)

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0x7f4838a86750 (LWP 3964)]
[New Thread 0x409bc950 (LWP 4059)]
[New Thread 0x4257d950 (LWP 3966)]
[New Thread 0x41d7c950 (LWP 3965)]
[KCrash handler]
#5  QGraphicsItem::clearFocus (this=0xc84720)
    at graphicsview/qgraphicsitem.cpp:1953
#6  0x00007f483473e636 in QGraphicsWidgetPrivate::fixFocusChainBeforeReparenting (this=0x5aa430, newParent=0x0) at graphicsview/qgraphicswidget_p.cpp:592
#7  0x00007f483473db05 in QGraphicsWidget::itemChange (this=0x5a97c0, 
    change=QGraphicsItem::ItemParentChange, value=@0x7fff40abfb10)
    at graphicsview/qgraphicswidget.cpp:931
#8  0x00007f483863383a in Plasma::Applet::itemChange (this=0x5a97c0, 
    change=QGraphicsItem::ItemParentChange, value=@0x7fff40abfb10)
    at /usr/src/packages/kde4/4.1.0/kdebase-workspace-4.1.0/libs/plasma/applet.cpp:1436
#9  0x00007f4834704323 in QGraphicsItem::setParentItem (this=0x5a97d0, 
    parent=0x1332de0) at graphicsview/qgraphicsitem.cpp:972
#10 0x00007f4838651a77 in AppletHandle (this=0x1332dd0, parent=0x65ee00, 
    applet=0x5a97c0, hoverPos=@0x7fff40abfe80)
    at /usr/src/packages/kde4/4.1.0/kdebase-workspace-4.1.0/libs/plasma/applethandle.cpp:85
#11 0x00007f483865ce16 in Plasma::Containment::sceneEventFilter (
    this=0x65ee00, watched=0x5a97d0, event=0x7fff40abfff0)
    at /usr/src/packages/kde4/4.1.0/kdebase-workspace-4.1.0/libs/plasma/containment.cpp:848
#12 0x00007f48347162ac in QGraphicsScenePrivate::filterEvent (
    this=<value optimized out>, item=0x5a97d0, event=0x7fff40abfff0)
    at graphicsview/qgraphicsscene.cpp:1033
#13 0x00007f4834716309 in QGraphicsScenePrivate::sendEvent (this=0xc84720, 
    item=0x0, event=0x5a97c0) at graphicsview/qgraphicsscene.cpp:1051
#14 0x00007f483471656d in QGraphicsScenePrivate::sendHoverEvent (
    this=0x621db0, type=<value optimized out>, item=0x5a97d0, 
    hoverEvent=0x7fff40ac0180) at graphicsview/qgraphicsscene.cpp:1100
#15 0x00007f4834721278 in QGraphicsScenePrivate::dispatchHoverEvent (
    this=0x621db0, hoverEvent=0x7fff40ac0180)
    at graphicsview/qgraphicsscene.cpp:3443
#16 0x00007f4834721599 in QGraphicsScene::mouseMoveEvent (
    this=<value optimized out>, mouseEvent=0x7fff40ac0740)
    at graphicsview/qgraphicsscene.cpp:3589
#17 0x00007f4834722765 in QGraphicsScene::event (this=0x621b10, 
    event=0x7fff40ac0740) at graphicsview/qgraphicsscene.cpp:2983
#18 0x00007f48341f818e in QApplicationPrivate::notify_helper (this=0x570aa0, 
    receiver=0x621b10, e=0x7fff40ac0740) at kernel/qapplication.cpp:3800
#19 0x00007f48341fccae in QApplication::notify (this=0x567960, 
    receiver=0x621b10, e=0x7fff40ac0740) at kernel/qapplication.cpp:3765
#20 0x00007f4837c2eb52 in KApplication::notify (this=0x567960, 
    receiver=0x621b10, event=0x7fff40ac0740)
    at /usr/src/packages/kde4/4.1.0/kdelibs-4.1.0/kdeui/kernel/kapplication.cpp:311
#21 0x00007f4836114748 in QCoreApplication::notifyInternal (this=0x567960, 
    receiver=0x621b10, event=0x7fff40ac0740) at kernel/qcoreapplication.cpp:591
#22 0x00007f483473064f in QGraphicsViewPrivate::mouseMoveEventHandler (
    this=0x7f48240015d0, event=0x7fff40ac1260)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 0x00007f48347336fd in QGraphicsView::mouseMoveEvent (this=0x7f4824001530, 
    event=0x7fff40ac1260) at graphicsview/qgraphicsview.cpp:2743
#24 0x00007f483424456f in QWidget::event (this=0x7f4824001530, 
    event=0x7fff40ac1260) at kernel/qwidget.cpp:7006
#25 0x00007f4834542346 in QFrame::event (this=0x7f4824001530, e=0x7fff40ac1260)
    at widgets/qframe.cpp:657
#26 0x00007f48345c6d2a in QAbstractScrollArea::viewportEvent (this=0xc84720, 
    e=0x0) at widgets/qabstractscrollarea.cpp:947
#27 0x00007f48347300db in QGraphicsView::viewportEvent (this=0x7f4824001530, 
    event=0x7fff40ac1260) at graphicsview/qgraphicsview.cpp:2334
#28 0x00007f48345c7ed8 in QAbstractScrollAreaFilter::eventFilter (
    this=<value optimized out>, o=<value optimized out>, e=0x5a97c0)
    at widgets/qabstractscrollarea_p.h:102
#29 0x00007f4836114a0d in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x7f4824002760, event=0x7fff40ac1260)
    at kernel/qcoreapplication.cpp:698
#30 0x00007f48341f815f in QApplicationPrivate::notify_helper (this=0x570aa0, 
    receiver=0x7f4824002760, e=0x7fff40ac1260) at kernel/qapplication.cpp:3796
#31 0x00007f48341fd19f in QApplication::notify (this=<value optimized out>, 
    receiver=0x7f4824002760, e=0x7fff40ac1260) at kernel/qapplication.cpp:3527
#32 0x00007f4837c2eb52 in KApplication::notify (this=0x567960, 
    receiver=0x7f4824002760, event=0x7fff40ac1260)
    at /usr/src/packages/kde4/4.1.0/kdelibs-4.1.0/kdeui/kernel/kapplication.cpp:311
#33 0x00007f4836114748 in QCoreApplication::notifyInternal (this=0x567960, 
    receiver=0x7f4824002760, event=0x7fff40ac1260)
    at kernel/qcoreapplication.cpp:591
#34 0x00007f48341fad31 in QApplicationPrivate::sendMouseEvent (
    receiver=0x7f4824002760, event=0x7fff40ac1260, alienWidget=0x7f4824002760, 
    nativeWidget=0x7f4824001530, buttonDown=<value optimized out>, 
    lastMouseReceiver=@0x7f4834a65360)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 0x00007f483425ab2d in QETWidget::translateMouseEvent (this=0x7f4824001530, 
    event=<value optimized out>) at kernel/qapplication_x11.cpp:4048
#36 0x00007f4834259bcf in QApplication::x11ProcessEvent (this=0x567960, 
    event=0x7fff40ac1920) at kernel/qapplication_x11.cpp:3166
#37 0x00007f483427e433 in x11EventSourceDispatch (s=0x573ef0, callback=0, 
    user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#38 0x00007f48326facc7 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#39 0x00007f48326fb4f2 in g_main_context_iterate ()
   from /usr/lib/libglib-2.0.so.0
#40 0x00007f48326fb9a8 in g_main_context_iteration ()
   from /usr/lib/libglib-2.0.so.0
#41 0x00007f483613d4ee in QEventDispatcherGlib::processEvents (this=0x56f0c0, 
    flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:325
#42 0x00007f483427e24f in QGuiEventDispatcherGlib::processEvents (
    this=0xc84720, flags=<value optimized out>)
    at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f4836113b65 in QEventLoop::processEvents (
    this=<value optimized out>, flags=@0x7fff40ac1c90)
    at kernel/qeventloop.cpp:149
#44 0x00007f4836113cc8 in QEventLoop::exec (this=0x7fff40ac1cd0, 
    flags=@0x7fff40ac1ce0) at kernel/qeventloop.cpp:200
#45 0x00007f4836115cce in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:849
#46 0x00007f4838886f4b in kdemain (argc=1, argv=0x7fff40ac2058)
    at /usr/src/packages/kde4/4.1.0/kdebase-workspace-4.1.0/plasma/plasma/main.cpp:54
#47 0x00000000004008d3 in main (argc=1, argv=0x7fff40ac2058)
    at /usr/src/packages/kde4/4.1.0/kdebase-workspace-4.1.0/build/plasma/plasma/plasma-qgv_dummy.cpp:3
#0  0x00007f48334a09e1 in nanosleep () from /lib/libc.so.6
Comment 3 Bram Schoenmakers 2008-09-07 01:54:16 UTC
*** Bug 170511 has been marked as a duplicate of this bug. ***
Comment 4 Andre Viegas 2008-09-19 17:25:14 UTC
(pasting backtrace directly into bug report for easier searching)

Application: Plasma Workspace (plasma), signal SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb8092770 (LWP 30606)]
[New Thread 0xb35fbb90 (LWP 32120)]
[New Thread 0xb3ffcb90 (LWP 30731)]
[New Thread 0xb49fdb90 (LWP 30613)]
[New Thread 0xb5ad5b90 (LWP 30612)]
[New Thread 0xb68bfb90 (LWP 30611)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x0638e02d in QGraphicsItem::clearFocus () from /usr/lib/libQtGui.so.4
#7  0x063d7244 in ?? () from /usr/lib/libQtGui.so.4
#8  0x063d5fc6 in QGraphicsWidget::itemChange () from /usr/lib/libQtGui.so.4
#9  0x0207b09d in Plasma::Applet::itemChange () from /usr/lib/libplasma.so.2
#10 0x063983b5 in QGraphicsItem::setParentItem () from /usr/lib/libQtGui.so.4
#11 0x02095bbc in ?? () from /usr/lib/libplasma.so.2
#12 0x020a5e23 in Plasma::Containment::sceneEventFilter ()
   from /usr/lib/libplasma.so.2
#13 0x063af45f in ?? () from /usr/lib/libQtGui.so.4
#14 0x063af523 in ?? () from /usr/lib/libQtGui.so.4
#15 0x063b0a7a in ?? () from /usr/lib/libQtGui.so.4
#16 0x063b82f3 in ?? () from /usr/lib/libQtGui.so.4
#17 0x063b86bf in QGraphicsScene::mouseMoveEvent ()
   from /usr/lib/libQtGui.so.4
#18 0x063b88d7 in QGraphicsScene::event () from /usr/lib/libQtGui.so.4
#19 0x05e1630c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#20 0x05e1e16e in QApplication::notify () from /usr/lib/libQtGui.so.4
#21 0x0679bddd in KApplication::notify () from /usr/lib/libkdeui.so.5
#22 0x0063a731 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#23 0x063c5e98 in ?? () from /usr/lib/libQtGui.so.4
#24 0x063ce3c6 in QGraphicsView::mouseMoveEvent () from /usr/lib/libQtGui.so.4
#25 0x05e6df2b in QWidget::event () from /usr/lib/libQtGui.so.4
#26 0x061a4033 in QFrame::event () from /usr/lib/libQtGui.so.4
#27 0x0623a60f in QAbstractScrollArea::viewportEvent ()
   from /usr/lib/libQtGui.so.4
#28 0x063c7daf in QGraphicsView::viewportEvent () from /usr/lib/libQtGui.so.4
#29 0x0623cbb5 in ?? () from /usr/lib/libQtGui.so.4
#30 0x0063991a in QCoreApplicationPrivate::sendThroughObjectEventFilters ()
   from /usr/lib/libQtCore.so.4
#31 0x05e162ea in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#32 0x05e1eb21 in QApplication::notify () from /usr/lib/libQtGui.so.4
#33 0x0679bddd in KApplication::notify () from /usr/lib/libkdeui.so.5
#34 0x0063a731 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#35 0x05e1ddae in QApplicationPrivate::sendMouseEvent ()
   from /usr/lib/libQtGui.so.4
#36 0x05e87e16 in ?? () from /usr/lib/libQtGui.so.4
#37 0x05e87185 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#38 0x05eaf6cc in ?? () from /usr/lib/libQtGui.so.4
#39 0x032830d8 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#40 0x03286783 in ?? () from /lib/libglib-2.0.so.0
#41 0x03286941 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#42 0x00664ea8 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#43 0x05eaed95 in ?? () from /usr/lib/libQtGui.so.4
#44 0x00638e1a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#45 0x00638fda in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#46 0x0063b685 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#47 0x05e16187 in QApplication::exec () from /usr/lib/libQtGui.so.4
#48 0x001ab7a1 in kdemain () from /usr/lib/libkdeinit4_plasma.so
#49 0x080487d2 in _start ()

Comment 5 Jonathan Thomas 2008-09-21 14:49:46 UTC
Created attachment 27500 [details]
plasma-filewatcher.kcrash

In 4.1.1 I find this happens only if I configure the plasmoid by clicking the big "configure" button in the middle of the plasmoid. The file gets displayed, but mousing back over the file watcher causes the crash.
Comment 6 Philipp Wagner 2008-10-20 00:39:42 UTC
I can confirm this with my own plasmoid (means, it's not specific to the filewatcher applet). Is this possibly a Qt bug? It usually works if I log off and on again (thus restarting plasma) before configuring the applet.
Comment 7 JP Rosevear 2008-10-22 20:33:48 UTC
See also https://bugzilla.novell.com/show_bug.cgi?id=436361, using 4.1 as well.
Comment 8 Philipp Wagner 2008-10-22 21:06:53 UTC
According to Aaron Seigo, this is a Qt bug which is already fixed in qt-copy and in the coming Qt 4.4.4.
Comment 9 Sergio Martins 2008-10-29 03:01:37 UTC
I also had a crash with the file watcher plasmoid but the backtrace is a little diferent. It happened while moving the plasmoid:

Application: Plasma Workspace (plasma), signal SIGSEGV
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb577a6e0 (LWP 27259)]
[New Thread 0xb16a7b90 (LWP 1116)]
[New Thread 0xb1fddb90 (LWP 29835)]
[New Thread 0xb27deb90 (LWP 29752)]
[New Thread 0xb2fdfb90 (LWP 27261)]
[New Thread 0xb4005b90 (LWP 27260)]
[KCrash handler]
#6  QGraphicsScene::focusItem (this=0x8384c28)
    at graphicsview/qgraphicsscene.cpp:2576
#7  0xb71d8c6c in QGraphicsItem::clearFocus (this=0x8384c28)
    at graphicsview/qgraphicsitem.cpp:1960
#8  0xb722099b in QGraphicsWidgetPrivate::fixFocusChainBeforeReparenting (
    this=0x8d3d3d0, newParent=0x0) at graphicsview/qgraphicswidget_p.cpp:592
#9  0xb721fc70 in QGraphicsWidget::itemChange (this=0x8384d10, 
    change=QGraphicsItem::ItemParentChange, value=@0xbfcf6240)
    at graphicsview/qgraphicswidget.cpp:941
#10 0xb7d6c21a in Plasma::Applet::itemChange (this=0x8384d10, 
    change=QGraphicsItem::ItemParentChange, value=@0xbfcf6240)
    at /var/tmp/portage/kde-base/libplasma-4.1.2/work/libplasma-4.1.2/libs/plasma/applet.cpp:1436
#11 0xb71e45aa in QGraphicsItem::setParentItem (this=0x8384d18, 
    parent=0x8d0e410) at graphicsview/qgraphicsitem.cpp:979
#12 0xb7d83505 in AppletHandle (this=0x8d0e408, parent=0x80e7950, 
    applet=0x8384d10, hoverPos=@0xbfcf64c0)
    at /var/tmp/portage/kde-base/libplasma-4.1.2/work/libplasma-4.1.2/libs/plasma/applethandle.cpp:85
#13 0xb7d8de8f in Plasma::Containment::sceneEventFilter (this=0x80e7950, 
    watched=0x8384d18, event=0xbfcf65b0)
    at /var/tmp/portage/kde-base/libplasma-4.1.2/work/libplasma-4.1.2/libs/plasma/containment.cpp:847
#14 0xb71f5f94 in QGraphicsScenePrivate::filterEvent (this=0x80c4c08, 
    item=0x8384d18, event=0xbfcf65b0) at graphicsview/qgraphicsscene.cpp:1016
#15 0xb71f6003 in QGraphicsScenePrivate::sendEvent (this=0x80c4c08, 
    item=0x8384d18, event=0xbfcf65b0) at graphicsview/qgraphicsscene.cpp:1034
#16 0xb71f629d in QGraphicsScenePrivate::sendHoverEvent (this=0x80c4c08, 
    type=QEvent::GraphicsSceneHoverEnter, item=0x8384d18, 
    hoverEvent=0xbfcf66fc) at graphicsview/qgraphicsscene.cpp:1083
#17 0xb71fed63 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x80c4c08, 
    hoverEvent=0xbfcf66fc) at graphicsview/qgraphicsscene.cpp:3426
#18 0xb71ff0fe in QGraphicsScene::mouseMoveEvent (this=0x80c45b0, 
    mouseEvent=0xbfcf6b90) at graphicsview/qgraphicsscene.cpp:3572
#19 0xb7204a47 in QGraphicsScene::event (this=0x80c45b0, event=0xbfcf6b90)
    at graphicsview/qgraphicsscene.cpp:2966
#20 0xb6c6bf7f in QApplicationPrivate::notify_helper (this=0x8064510, 
    receiver=0x80c45b0, e=0xbfcf6b90) at kernel/qapplication.cpp:3809
#21 0xb6c70a79 in QApplication::notify (this=0x805acb0, receiver=0x80c45b0, 
    e=0xbfcf6b90) at kernel/qapplication.cpp:3399
#22 0xb7728dca in KApplication::notify (this=0x805acb0, receiver=0x80c45b0, 
    event=0xbfcf6b90)
    at /var/tmp/portage/kde-base/kdelibs-4.1.2-r1/work/kdelibs-4.1.2/kdeui/kernel/kapplication.cpp:311
#23 0xb7c07397 in QCoreApplication::notifyInternal (this=0x805acb0, 
    receiver=0x80c45b0, event=0xbfcf6b90) at kernel/qcoreapplication.cpp:593
#24 0xb7212f4a in QGraphicsViewPrivate::mouseMoveEventHandler (
    this=0x8191578, event=0xbfcf7350)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 0xb7214544 in QGraphicsView::mouseMoveEvent (this=0x8191350, 
    event=0xbfcf7350) at graphicsview/qgraphicsview.cpp:2754
#26 0xb6cc45f2 in QWidget::event (this=0x8191350, event=0xbfcf7350)
    at kernel/qwidget.cpp:7154
#27 0xb6ff7393 in QFrame::event (this=0x8191350, e=0xbfcf7350)
    at widgets/qframe.cpp:657
#28 0xb708bb2c in QAbstractScrollArea::viewportEvent (this=0x8d3d3d0, 
    e=0x273d6570) at widgets/qabstractscrollarea.cpp:949
#29 0xb7211ab2 in QGraphicsView::viewportEvent (this=0x8191350, 
    event=0xbfcf7350) at graphicsview/qgraphicsview.cpp:2343
#30 0xb708d9b5 in QAbstractScrollAreaFilter::eventFilter (this=0x81965c8, 
    o=0x80f65c8, e=0xbfcf7350) at widgets/qabstractscrollarea_p.h:102
#31 0xb7c07822 in QCoreApplicationPrivate::sendThroughObjectEventFilters (
    this=0x8064510, receiver=0x80f65c8, event=0xbfcf7350)
    at kernel/qcoreapplication.cpp:700
#32 0xb6c6bf56 in QApplicationPrivate::notify_helper (this=0x8064510, 
    receiver=0x80f65c8, e=0xbfcf7350) at kernel/qapplication.cpp:3805
#33 0xb6c70e5d in QApplication::notify (this=0x805acb0, receiver=0x80f65c8, 
    e=0xbfcf7350) at kernel/qapplication.cpp:3534
#34 0xb7728dca in KApplication::notify (this=0x805acb0, receiver=0x80f65c8, 
    event=0xbfcf7350)
    at /var/tmp/portage/kde-base/kdelibs-4.1.2-r1/work/kdelibs-4.1.2/kdeui/kernel/kapplication.cpp:311
#35 0xb7c07397 in QCoreApplication::notifyInternal (this=0x805acb0, 
    receiver=0x80f65c8, event=0xbfcf7350) at kernel/qcoreapplication.cpp:593
#36 0xb6c70619 in QApplicationPrivate::sendMouseEvent (receiver=0x80f65c8, 
    event=0xbfcf7350, alienWidget=0x80f65c8, nativeWidget=0x8191350, 
    buttonDown=0xb741dc30, lastMouseReceiver=@0xb741dc34)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 0xb6cd6d9c in QETWidget::translateMouseEvent (this=0x8191350, 
    event=0xbfcf7748) at kernel/qapplication_x11.cpp:4048
#38 0xb6cd585d in QApplication::x11ProcessEvent (this=0x805acb0, 
    event=0xbfcf7748) at kernel/qapplication_x11.cpp:3044
#39 0xb6cfb653 in QEventDispatcherX11::processEvents (this=0x8053cb8, 
    flags=@0xbfcf7838) at kernel/qeventdispatcher_x11.cpp:134
#40 0xb7c0656d in QEventLoop::processEvents (this=0xbfcf78b0, 
    flags=@0xbfcf7878) at kernel/qeventloop.cpp:149
#41 0xb7c0670d in QEventLoop::exec (this=0xbfcf78b0, flags=@0xbfcf78b8)
    at kernel/qeventloop.cpp:200
#42 0xb7c08886 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:851
#43 0xb6c6b7a7 in QApplication::exec () at kernel/qapplication.cpp:3337
#44 0xb7fc61c4 in kdemain (argc=1, argv=0xbfcf7a84)
    at /var/tmp/portage/kde-base/plasma-workspace-4.1.2/work/plasma-workspace-4.1.2/plasma/plasma/main.cpp:58
#45 0x08048662 in main (argc=-1220457816, argv=0x8f87c78)
    at /var/tmp/portage/kde-base/plasma-workspace-4.1.2/work/plasma-workspace_build/plasma/plasma/plasma_qgv_dummy.cpp:3
#46 0xb7e80fdc in __libc_start_main () from /lib/libc.so.6
#47 0x080485a1 in _start ()
#0  0xffffe424 in __kernel_vsyscall ()
Comment 10 Stefan Usenbinz 2008-11-09 16:42:25 UTC
Well, have encountered this crash more than once now with different SVN trunk revisions, but it comes and goes without any apparent relation to an user action or a specific applet.
Latest occurance was with 
 - qt-copy Revision: 879192 (with applied patches)
 - KDE Revision: 881945

Thread 1 (Thread 0x7f633d2dc730 (LWP 17573)):
[KCrash Handler]
#5  0x00007f63456cee4a in QGraphicsItem::clearFocus (this=0xbaef30) at graphicsview/qgraphicsitem.cpp:1954
#6  0x00007f634570af89 in QGraphicsWidgetPrivate::fixFocusChainBeforeReparenting (this=0xb9b1a0, newParent=0x82a610) at graphicsview/qgraphicswidget_p.cpp:586
#7  0x00007f634570868b in QGraphicsWidget::itemChange (this=0xb92c70, change=QGraphicsItem::ItemParentChange, value=@0x7fff509dd420) at graphicsview/qgraphicswidget.cpp:935
#8  0x00007f63481d78f0 in Plasma::Applet::itemChange (this=0xb92c70, change=QGraphicsItem::ItemParentChange, value=@0x7fff509dd420) at /home/kde-devel/kde/src/KDE/kdelibs/plasma/applet.cpp:1548
#9  0x00007f63456d2668 in QGraphicsItem::setParentItem (this=0xb92c80, parent=0x82a620) at graphicsview/qgraphicsitem.cpp:973
#10 0x00007f6348221d74 in Plasma::AppletHandle::detachApplet (this=0xb56f40) at /home/kde-devel/kde/src/KDE/kdelibs/plasma/private/applethandle.cpp:173
#11 0x00007f63481e83f7 in Plasma::ContainmentPrivate::handleDisappeared (this=0x88c490, handle=0xb56f40) at /home/kde-devel/kde/src/KDE/kdelibs/plasma/containment.cpp:1552
#12 0x00007f63481ef48e in Plasma::Containment::qt_metacall (this=0x82a610, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0x7fff509dd870)
    at /home/kde-devel/kde/build/KDE/kdelibs/plasma/containment.moc:134
#13 0x00007f6335c3ead1 in DefaultDesktop::qt_metacall (this=0x82a610, _c=QMetaObject::InvokeMetaMethod, _id=46, _a=0x7fff509dd870)
    at /home/kde-devel/kde/build/KDE/kdebase/workspace/plasma/containments/desktop/desktop.moc:74
#14 0x00007f63463c3d75 in QMetaObject::activate (sender=0xb56f40, from_signal_index=4, to_signal_index=4, argv=0x7fff509dd870) at kernel/qobject.cpp:3028
#15 0x00007f63463c41d9 in QMetaObject::activate (sender=0xb56f40, m=0x7f634852e4e0, local_signal_index=0, argv=0x7fff509dd870) at kernel/qobject.cpp:3101
#16 0x00007f634821c6d7 in Plasma::AppletHandle::disappearDone (this=0xb56f40, _t1=0xb56f40) at /home/kde-devel/kde/build/KDE/kdelibs/plasma/applethandle_p.moc:96
#17 0x00007f634821c6f3 in Plasma::AppletHandle::emitDisappear (this=0xb56f40) at /home/kde-devel/kde/src/KDE/kdelibs/plasma/private/applethandle.cpp:402
#18 0x00007f634821d72c in Plasma::AppletHandle::qt_metacall (this=0xb56f40, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x7fff509dd990)
    at /home/kde-devel/kde/build/KDE/kdelibs/plasma/applethandle_p.moc:85
#19 0x00007f63463c3d75 in QMetaObject::activate (sender=0xc029c0, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3028
#20 0x00007f63463c41d9 in QMetaObject::activate (sender=0xc029c0, m=0x7f63466c27c0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3101
#21 0x00007f63463cdcee in QSingleShotTimer::timeout (this=0xc029c0) at .moc/debug-shared/qtimer.moc:74
#22 0x00007f63463cdde7 in QSingleShotTimer::timerEvent (this=0xc029c0) at kernel/qtimer.cpp:294
#23 0x00007f63463c200e in QObject::event (this=0xc029c0, e=0x7fff509de1e0) at kernel/qobject.cpp:1120
#24 0x00007f6345156017 in QApplicationPrivate::notify_helper (this=0x643d00, receiver=0xc029c0, e=0x7fff509de1e0) at kernel/qapplication.cpp:3803
#25 0x00007f6345156326 in QApplication::notify (this=0x63a6b0, receiver=0xc029c0, e=0x7fff509de1e0) at kernel/qapplication.cpp:3393
#26 0x00007f6346ff1a0e in KApplication::notify (this=0x63a6b0, receiver=0xc029c0, event=0x7fff509de1e0) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:307
#27 0x00007f63463af26e in QCoreApplication::notifyInternal (this=0x63a6b0, receiver=0xc029c0, event=0x7fff509de1e0) at kernel/qcoreapplication.cpp:583
#28 0x00007f63463b2caf in QCoreApplication::sendEvent (receiver=0xc029c0, event=0x7fff509de1e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:209
#29 0x00007f63463e0b65 in QTimerInfoList::activateTimers (this=0x6472b0) at kernel/qeventdispatcher_unix.cpp:557
#30 0x00007f63463de289 in timerSourceDispatch (source=0x647250) at kernel/qeventdispatcher_glib.cpp:160
#31 0x00007f6340ebe364 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0x00007f6340ec1675 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0x00007f6340ec1b5b in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0x00007f63463dd4f0 in QEventDispatcherGlib::processEvents (this=0x641b60, flags=@0x7fff509de420) at kernel/qeventdispatcher_glib.cpp:319
#35 0x00007f63451f8983 in QGuiEventDispatcherGlib::processEvents (this=0x641b60, flags=@0x7fff509de480) at kernel/qguieventdispatcher_glib.cpp:198
#36 0x00007f63463ac3b4 in QEventLoop::processEvents (this=0x7fff509de550, flags=@0x7fff509de500) at kernel/qeventloop.cpp:143
#37 0x00007f63463ac5b0 in QEventLoop::exec (this=0x7fff509de550, flags=@0x7fff509de570) at kernel/qeventloop.cpp:190
#38 0x00007f634554adc6 in QMenu::exec (this=0x7fff509de5d0, p=@0x7fff509de860, action=0x0) at widgets/qmenu.cpp:1938
#39 0x00007f63481ec3a1 in Plasma::ContainmentPrivate::showContextMenu (this=0x88c490, point=@0x7fff509de850, screenPos=@0x7fff509de860, includeApplet=true)
    at /home/kde-devel/kde/src/KDE/kdelibs/plasma/containment.cpp:569
#40 0x00007f63481ec4ad in Plasma::Containment::contextMenuEvent (this=0x82a610, event=0x7fff509df130) at /home/kde-devel/kde/src/KDE/kdelibs/plasma/containment.cpp:452
#41 0x00007f63456d4f6c in QGraphicsItem::sceneEvent (this=0x82a620, event=0x7fff509df130) at graphicsview/qgraphicsitem.cpp:3971
#42 0x00007f63457066d6 in QGraphicsWidget::sceneEvent (this=0x82a610, event=0x7fff509df130) at graphicsview/qgraphicswidget.cpp:1011
#43 0x00007f63456df98d in QGraphicsScenePrivate::sendEvent (this=0x70c8f0, item=0x82a620, event=0x7fff509df130) at graphicsview/qgraphicsscene.cpp:1030
#44 0x00007f63456e87aa in QGraphicsScene::contextMenuEvent (this=0x70b640, contextMenuEvent=0x7fff509df130) at graphicsview/qgraphicsscene.cpp:3109
#45 0x00007f63456e92af in QGraphicsScene::event (this=0x70b640, event=0x7fff509df130) at graphicsview/qgraphicsscene.cpp:2951
#46 0x00007f6345156017 in QApplicationPrivate::notify_helper (this=0x643d00, receiver=0x70b640, e=0x7fff509df130) at kernel/qapplication.cpp:3803
#47 0x00007f6345156326 in QApplication::notify (this=0x63a6b0, receiver=0x70b640, e=0x7fff509df130) at kernel/qapplication.cpp:3393
#48 0x00007f6346ff1a0e in KApplication::notify (this=0x63a6b0, receiver=0x70b640, event=0x7fff509df130) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:307
#49 0x00007f63463af26e in QCoreApplication::notifyInternal (this=0x63a6b0, receiver=0x70b640, event=0x7fff509df130) at kernel/qcoreapplication.cpp:583
#50 0x00007f63463b2caf in QCoreApplication::sendEvent (receiver=0x70b640, event=0x7fff509df130) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:209
#51 0x00007f63456f7afb in QGraphicsView::contextMenuEvent (this=0x9c3340, event=0x7fff509dfb30) at graphicsview/qgraphicsview.cpp:2363
#52 0x00007f63451af9ae in QWidget::event (this=0x9c3340, event=0x7fff509dfb30) at kernel/qwidget.cpp:7320
#53 0x00007f634550020f in QFrame::event (this=0x9c3340, e=0x7fff509dfb30) at widgets/qframe.cpp:651
#54 0x00007f634558d490 in QAbstractScrollArea::viewportEvent (this=0x9c3340, e=0x7fff509dfb30) at widgets/qabstractscrollarea.cpp:943
#55 0x00007f63456f7e62 in QGraphicsView::viewportEvent (this=0x9c3340, event=0x7fff509dfb30) at graphicsview/qgraphicsview.cpp:2337
#56 0x00007f634558fd30 in QAbstractScrollAreaPrivate::viewportEvent (this=0x94b770, event=0x7fff509dfb30) at widgets/qabstractscrollarea_p.h:96
#57 0x00007f634558fd70 in QAbstractScrollAreaFilter::eventFilter (this=0x94df30, o=0x94c4c0, e=0x7fff509dfb30) at widgets/qabstractscrollarea_p.h:107
#58 0x00007f63463ad7ab in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x643d00, receiver=0x94c4c0, event=0x7fff509dfb30) at kernel/qcoreapplication.cpp:694
#59 0x00007f6345155ff2 in QApplicationPrivate::notify_helper (this=0x643d00, receiver=0x94c4c0, e=0x7fff509dfb30) at kernel/qapplication.cpp:3799
#60 0x00007f6345157309 in QApplication::notify (this=0x63a6b0, receiver=0x94c4c0, e=0x7fff509dfb30) at kernel/qapplication.cpp:3614
#61 0x00007f6346ff1a0e in KApplication::notify (this=0x63a6b0, receiver=0x94c4c0, event=0x7fff509dfb30) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:307
#62 0x00007f63463af26e in QCoreApplication::notifyInternal (this=0x63a6b0, receiver=0x94c4c0, event=0x7fff509dfb30) at kernel/qcoreapplication.cpp:583
#63 0x00007f6345161fb1 in QCoreApplication::sendSpontaneousEvent (receiver=0x94c4c0, event=0x7fff509dfb30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:212
#64 0x00007f63451cf522 in QETWidget::translateMouseEvent (this=0x9c3340, event=0x7fff509e0560) at kernel/qapplication_x11.cpp:4048
#65 0x00007f63451cccee in QApplication::x11ProcessEvent (this=0x63a6b0, event=0x7fff509e0560) at kernel/qapplication_x11.cpp:3038
#66 0x00007f63451f9171 in x11EventSourceDispatch (s=0x647320, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:142
#67 0x00007f6340ebe364 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#68 0x00007f6340ec1675 in ?? () from /usr/lib/libglib-2.0.so.0
#69 0x00007f6340ec1b5b in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#70 0x00007f63463dd4f0 in QEventDispatcherGlib::processEvents (this=0x641b60, flags=@0x7fff509e07e0) at kernel/qeventdispatcher_glib.cpp:319
#71 0x00007f63451f8983 in QGuiEventDispatcherGlib::processEvents (this=0x641b60, flags=@0x7fff509e0840) at kernel/qguieventdispatcher_glib.cpp:198
#72 0x00007f63463ac3b4 in QEventLoop::processEvents (this=0x7fff509e0900, flags=@0x7fff509e08c0) at kernel/qeventloop.cpp:143
#73 0x00007f63463ac5b0 in QEventLoop::exec (this=0x7fff509e0900, flags=@0x7fff509e0920) at kernel/qeventloop.cpp:190
#74 0x00007f63463afab8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#75 0x00007f6345155d78 in QApplication::exec () at kernel/qapplication.cpp:3331
#76 0x00007f6348578cb7 in kdemain (argc=1, argv=0x7fff509e0c78) at /home/kde-devel/kde/src/KDE/kdebase/workspace/plasma/shells/desktop/main.cpp:58
#77 0x0000000000400893 in main (argc=1, argv=0x7fff509e0c78) at /home/kde-devel/kde/build/KDE/kdebase/workspace/plasma/shells/desktop/plasma_qgv_dummy.cpp:3

Just upgraded to qt-copy revision 882016 to see if that makes any difference...
Comment 11 Stefan Usenbinz 2008-11-10 22:23:15 UTC
qt-copy revision 882016 and KDE revision 882432. Immediate crash when starting to move an applet with similar callchain again. So no, it doesn't seem to be fixed in qt-copy.
Comment 12 Stefan Usenbinz 2008-11-13 20:44:40 UTC
0260-fix-qgraphicswidget-deletionclearFocus.diff seems to have done the trick. Have not seen any reoccurance since that patch was applied to qt-copy. Guess this can be moved to fixed now.
Comment 13 Anne-Marie Mahfouf 2008-12-19 16:47:27 UTC
*** Bug 178140 has been marked as a duplicate of this bug. ***
Comment 14 Jonathan Thomas 2008-12-24 01:39:48 UTC
*** Bug 178626 has been marked as a duplicate of this bug. ***
Comment 15 Simon Gebauer 2009-02-10 11:46:56 UTC
*** Bug 183896 has been marked as a duplicate of this bug. ***