Bug 168007 - System tray empty on startup since the Qt 4.4.1 update
Summary: System tray empty on startup since the Qt 4.4.1 update
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-systemtray (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 168 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 168087 168325 168386 168503 169069 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-01 17:24 UTC by Jan Mette
Modified: 2008-08-15 05:12 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
sytray fix for Qt4.4.1 (497 bytes, patch)
2008-08-05 17:01 UTC, Fathi Boudra
Details
Screenshot of the artifact in systray (10.91 KB, image/png)
2008-08-09 15:01 UTC, Alexey Chernov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Mette 2008-08-01 17:24:29 UTC
Version:            (using KDE 4.1.0)
Installed from:    Compiled From Sources
Compiler:          GCC 4.3.1 
OS:                Linux

Hi there,

since i updated to Qt 4.4.1 the systray icons are not drawn on startup of KDE 4.1...

The icons take their space in the tray, they just dont show and the tray is empty...

To solve this i have to remove and then add the systray applet again...

Downgrading to Qt 4.4.0 solves this problem...


If you need any more info, i am glad to help


Greetings

Jan
Comment 1 Urs Wolfer 2008-08-01 18:09:27 UTC
Confirmed.
Comment 2 Wolfgang Seebacher 2008-08-01 23:54:32 UTC
Confirmed. It's annoying.
Comment 3 Modestas Vainius 2008-08-02 02:59:07 UTC
Confirmed. Readding System tray seems to make it reappear (when "panel settings" bar is closed). But on the next login, it is empty (or simply hidden somewhere) again.
Comment 4 Pino Toscano 2008-08-02 12:28:13 UTC
*** Bug 168087 has been marked as a duplicate of this bug. ***
Comment 5 Radosław Mejer 2008-08-02 14:42:42 UTC
The same thing on my computer. Confirmed
Comment 6 Pino Toscano 2008-08-03 00:59:49 UTC
The bug is already confirmed enough.
Please stop the "me too!", thanks.
Comment 7 Bryan jackson 2008-08-04 00:20:38 UTC
Confirmed
Comment 8 younker 2008-08-04 10:40:19 UTC
I can confirm with this with Qt 4.4.1 installed, sometimes I can make the icon show in systray by re-adding this widgets, but most time I can not see the icons.
Comment 9 Martin Wilke 2008-08-04 11:47:33 UTC
confirmed
Comment 10 Jason Stubbs 2008-08-04 13:03:11 UTC
Before adding another "confirmed", please read comment #6.
Comment 11 winfield 2008-08-04 19:06:07 UTC
Hi, Jason Stubbs

could you give a link to the "comfirmed bug"

regard
Comment 12 Urs Wolfer 2008-08-04 20:43:55 UTC
*** Bug 168325 has been marked as a duplicate of this bug. ***
Comment 13 Nick B 2008-08-04 22:50:15 UTC
No bug is confirmed enough until the status actually changes to 'confirmed'.  Confirmed on archlinux.
Comment 14 Médéric Boquien 2008-08-04 22:53:43 UTC
Nick, as you can see the status of the bug is NEW. Which means it has been confirmed. Otherwise it would be at UNCONFIRMED. Please read http://bugs.kde.org/bug_status.html .
Comment 15 Nick B 2008-08-05 02:05:01 UTC
Ah, of course.  Always pleased to make myself look like an idiot.
Comment 16 Aaron J. Seigo 2008-08-05 08:09:18 UTC
*** Bug 168386 has been marked as a duplicate of this bug. ***
Comment 17 S. Burmeister 2008-08-05 09:16:49 UTC
I can work around this bug by moving the panel to the right edgke of the desktop and back to the bottom. After I lock the widgets the icons appear in the systray. Might be a bit easier than re-adding the systray.
Comment 18 Vincent Panel 2008-08-05 09:47:18 UTC
Workaround works for me too.
Comment 19 Pierre Schmitz 2008-08-05 13:43:39 UTC
Even with this "workaround" the systray disappears when clinking the plasma icon on the panel; and reappears when cosing the config panel.
Comment 20 Jason Stubbs 2008-08-05 15:57:56 UTC
SVN commit 842541 by jstubbs:

Make sure that the widget is on top after being created. raise() isn't
working for some reason, so this is a hack on top of a hack. ;)
Note, the system tray still isn't visible during panel configuration.
Thanks to Matthias Kretz for digging through subversion changes.

CCBUG: 168007
CC: plasma-devel@kde.org

More details to come in a reply to this on panel-devel@


 M  +11 -0     systemtraywidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=842541
Comment 21 Hunch 2008-08-05 16:23:52 UTC
report:
this bug is resolved after i update my sytem. anyone else?


2008/8/5 Ivo Anjo <knuckles@gmail.com>

[bugs.kde.org quoted mail]



<div dir="ltr">report:<br>this bug is resolved after i update my sytem. anyone else?<br><br><br><div class="gmail_quote">2008/8/5 Ivo Anjo <span dir="ltr">&lt;<a href="mailto:knuckles@gmail.com">knuckles@gmail.com</a>&gt;</span><br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="Ih2E3d">------- You are receiving this mail because: -------<br>
You are on the CC list for the bug, or are watching someone who is.<br>
<br>
<a href="http://bugs.kde.org/show_bug.cgi?id=168007" target="_blank">http://bugs.kde.org/show_bug.cgi?id=168007</a><br>
</div>knuckles gmail com changed:<br>
<br>
 &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; What &nbsp; &nbsp;|Removed &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; |Added<br>
----------------------------------------------------------------------------<br>
 &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; CC| &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;|knuckles gmail com<br>
</blockquote></div><br><br clear="all"><br>-- <br>世界没有尽头 所以会茫然<br>
</div>
Comment 22 Jason Stubbs 2008-08-05 16:49:19 UTC
See my message in comment #20. If it works in panel configuration mode and/or you updated before comment #20 was posted, then please add more information - distro and whatnot. Otherwise, the only useful comments on this bug are those explaining the _why_.
Comment 23 Fathi Boudra 2008-08-05 17:01:50 UTC
Created attachment 26652 [details]
sytray fix for Qt4.4.1

please, find attached a fix for Qt4.4.1 from Matthias Kretz.
Comment 24 Jason Stubbs 2008-08-05 17:04:43 UTC
That would be a regression as far as Qt is concerned. My mail on plasma-devel@ has the details:

http://mail.kde.org/pipermail/plasma-devel/2008-August/000258.html
Comment 25 Jason Stubbs 2008-08-07 14:55:15 UTC
*** Bug 168503 has been marked as a duplicate of this bug. ***
Comment 26 Jason Stubbs 2008-08-07 15:03:36 UTC
SVN commit 843617 by jstubbs:

Removing the raise() hack as going with Qt::AA_DontCreateNativeWidgetSiblings
is the better option for the time being. I extended the raise() hack to
include watching parentWidget()'s events and calling raise() whenever on all
ChildAdded events (which works) but the huge white flashes with native
widgets aren't really acceptable.

CCBUG: 168007


 M  +0 -11     systemtraywidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=843617
Comment 27 Jason Stubbs 2008-08-07 15:05:20 UTC
SVN commit 843619 by jstubbs:

Revert to Qt-4.4.0 behaviour so that the SystemTrayWidget is always on top.
This needs to be backported to the 4.1 branch.

BUG: 168007
CCMAIL: plasma-devel@kde.org


 M  +14 -0     systemtray.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=843619
Comment 28 Ferdinand Gassauer 2008-08-08 08:58:11 UTC
I hope that this will be backported BEFORE the distributions pack the 4.1
it's extremely annoying to not being able to access kmail and klipper sitting in the systray
Comment 29 Vincent Panel 2008-08-08 10:27:01 UTC
Don't worry, I think distributions follow this bug report closely. Mandriva will include this patch in the future Mandriva 2009.0 (it's already in the development version, cooker, and works pretty well).
Comment 30 Jason Stubbs 2008-08-08 10:41:06 UTC
I'll get it into the 4.1 branch on the weekend if nobody else takes care of it first.
Comment 31 Fathi Boudra 2008-08-08 11:51:51 UTC
SVN commit 843908 by fabo:

backport Qt4.4.1/systemtray fix to 4.1 branch.

CCBUG: 168007
CCMAIL: jasonbstubbs@gmail.com


 M  +20 -0     systemtray.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=843908
Comment 32 Alexey Chernov 2008-08-09 14:56:50 UTC
I've recompiled kdebase-workspace with this patch for myself, systray was obviously fixed, but however there're some artifacts when icons are added to it on startup and on some icons the image is like the proper icon overlays the one to the left of its position (screenshot will follow).

But though, thank you for this fix, because without systray it's completely insane working.
Comment 33 Alexey Chernov 2008-08-09 15:01:47 UTC
Created attachment 26753 [details]
Screenshot of the artifact in systray
Comment 34 Jason Stubbs 2008-08-09 15:49:20 UTC
That looks to be bug #158094
Comment 35 Alexey Chernov 2008-08-09 19:53:19 UTC
Thanks for the link, it really must be those bug and I've read it has a long story.. Sorry for filing it here.
Comment 36 Jason Stubbs 2008-08-14 03:05:53 UTC
*** Bug 169069 has been marked as a duplicate of this bug. ***
Comment 37 Pablo Cholaky 2008-08-15 05:12:29 UTC
Reporting this bug too