Bug 167866 - when i launch marble i only have a grey filled window ... and very empty !
Summary: when i launch marble i only have a grey filled window ... and very empty !
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: Torsten Rahn
Depends on:
Reported: 2008-07-31 17:34 UTC by solsTiCe
Modified: 2008-08-07 10:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:

the console output of marble (7.86 KB, text/plain)
2008-08-01 12:20 UTC, solsTiCe
an strace ouput of marble (74.72 KB, application/x-gzip)
2008-08-01 18:22 UTC, solsTiCe

Note You need to log in before you can comment on or make changes to this bug.
Description solsTiCe 2008-07-31 17:34:11 UTC
Version:            (using KDE 4.1.0)
Installed from:    Unlisted Binary Package
OS:                Linux

when i lauch marble, it displays some stuff in the konsole.
the last message being:
Succesfully parsed file!
Found 3 GeoNode object LEAKS!
Entered selectTheme
Select Theme:  "earth/srtm/srtm.dgml"  Stored:  "earth/srtm/srtm.dgml"
and then it uses 100% cpu and stays there with a grey (color of oxygen theme) window with nothing inside it not even a menu !

i use nvidia 173.14.09 on a kernel. but i doubt it's the problem.
Comment 1 solsTiCe 2008-07-31 17:49:34 UTC
it's the same with vanilla 2.6.25 kernel from archlinux
Comment 2 Torsten Rahn 2008-08-01 09:44:40 UTC
Sounds like a packaging bug. I guess it can't find the tiles. Could you provide the whole console output?

Comment 3 solsTiCe 2008-08-01 12:20:24 UTC
Created attachment 26547 [details]
the console output of marble
Comment 4 Torsten Rahn 2008-08-01 16:03:43 UTC
Thanks for the console output. Unfortunately I can't see anything that would be wrong with it. 
Could you try to move ~/.marble to ~/.marble_bak and move ~/.kde4/share/config/marblerc to ~/marblerc.bak while Marble is not running? After that please restart marble and tell us whether there has been any improvement. If this should fix the issue please send us the tarred up backed up configuration data (if it's of reasonable size, i.e. < 5MB).
Comment 5 solsTiCe 2008-08-01 18:19:37 UTC
~/.marble is empty !
$ find .marble/

and i even do not have a marblerc.

i have tried with a different user and with nv driver instead of nvidia. still the same
what is strange to me in the ouput console is
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/solstice/.marble/data/maps

it seems it can't even create the maps directory ! if i create it manually. it's the same!
Comment 6 solsTiCe 2008-08-01 18:22:20 UTC
Created attachment 26551 [details]
an strace ouput of marble

it stays at the last writev and nothing is ouitputed by strace but it uses
nonetheless 100%cpu, well only on one cpu....
Comment 7 Torsten Rahn 2008-08-01 23:10:32 UTC
> QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: 
> No such file or directory and
> QFileSystemWatcher: failed to add paths: /home/solstice/.marble/data/maps

That's a normal error message. Marble only creates the .marble directory later on.

> but it uses nonetheless 100%cpu, 

How long did you try to leave it processing? Do you have a 64bit or a 32bit system? Given that Pierre wasn't able to reproduce the bug in the Archlinux Bugzilla I'm inclined to think that it's not a packaging bug.

Comment 8 Michał Małek 2008-08-03 11:11:40 UTC
I've got the same problem on Archlinux, kernel, nVidia driver 96.43.05
Comment 9 Torsten Rahn 2008-08-03 12:34:33 UTC
Hm, so this sounds like it's an issue that is specific to Archlinux (with possibly NVidia used in addition), as I haven't received any similar reports from other users yet (and I know some of them who have NVidia chipsets).
Comment 10 solsTiCe 2008-08-03 13:20:20 UTC
do not conclude too fast it's an archlinux only specific issue. 
it might be because we're one of the first distro to use kde 4.1

i am not denying it could be a archlinux only bug either ;-)

i am trying to gather more information from archers. but it's not that easy. i am ignored most of the time... or nobody cares about marble
Comment 11 solsTiCe 2008-08-05 15:45:25 UTC
still the same problem with the latest nvidia driver 173.14.12
Comment 12 solsTiCe 2008-08-06 15:16:00 UTC
i just upgraded qt to 4.4.1 and it works. so qt might the culprit. (or may be nvidia but i am almost sure it was after qt upgrade than nvidia driver upgrade, that it began to work);
Comment 13 Torsten Rahn 2008-08-06 17:49:36 UTC
Great to hear! It would be nice to get more feedback on the issue if other people can confirm whether it was the newer Qt version or the nvidia driver.
Comment 14 Michał Małek 2008-08-07 10:08:05 UTC
I have only upgraded qt to 4.4.1 and marble indeed works now. So it was a fault of previous qt.