Bug 167626 - VGM support in Amarok
Summary: VGM support in Amarok
Status: RESOLVED UPSTREAM
Alias: None
Product: Phonon
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist
Target Milestone: ---
Assignee: Matthias Kretz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-28 23:43 UTC by David Korth
Modified: 2010-12-21 18:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Korth 2008-07-28 23:43:29 UTC
Version:            (using KDE 4.0.98)
Installed from:    Gentoo Packages

It would be nice to have support for VGM files in Amarok. VGM files are small files that contain exact music reproductions from classic video game systems, such as the Sega Genesis / Mega Drive. Additionally, support for VGZ (GZipped VGM) would be useful, since VGM files can be compressed to very small sizes (<10k per file in some cases). Also, VGM has its own tagging format called "GD3", which is similar to ID3 tagging.

The file format specifications for VGM and GD3 are available at http://www.smspower.org/music/vgmspecs.shtml
Comment 1 Lydia Pintscher 2008-07-28 23:54:37 UTC
Amarok can play what Phonon can play.
Reassigning to Phonon.

Thank you for your report.
Comment 2 Harald Sitter 2010-12-21 18:23:23 UTC
Phonon itself does not play anything, it uses existing frameworks, so functionality would need to be implemented in those (e.g. gstreamer or vlc ...)