Bug 167515 - support for comic titles and title text
Summary: support for comic titles and title text
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-comic (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Tobias Koenig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-27 09:20 UTC by a thing
Modified: 2008-09-22 16:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
adds the title for xkcd (4.16 KB, patch)
2008-08-25 21:03 UTC, Matthias Fuchs
Details
adds support for strip titles in the comic app (2.04 KB, patch)
2008-08-25 21:05 UTC, Matthias Fuchs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a thing 2008-07-27 09:20:45 UTC
Version:            (using KDE 4.0.98)
Installed from:    Fedora RPMs

Currently the comic plasmoid only displays a picture. However, for xkcd (and maybe other comics), the title of the comic and the title text (the XHTML title attribute for the img tag that is displayed on a mouseover in graphical browsers) are often a big part of the comic and the plasmoid does not display these.
Comment 1 Dominik Tritscher 2008-07-28 17:41:35 UTC
Changed to a wishlist item, as it's not a bug.
Comment 2 Matthias Fuchs 2008-08-25 21:03:50 UTC
Created attachment 27041 [details]
adds the title for xkcd

Ok, I created a patch that adds a virtual QString stripTitle() method to comicprovider and cachedprovider, the title is also stored. I also modifed xkcdprovider to provide the title.

Here is the patch for the dataengine.
Comment 3 Matthias Fuchs 2008-08-25 21:05:19 UTC
Created attachment 27043 [details]
adds support for strip titles in the comic app

Additionally I modified the applet to show the title of the comic on top.

I'm not sure though if I should provide an option to deactivate that in the config, or if I should also show the comic title --> "xkcd - Voting Machines" or "xkcd" if there is no strip. Currently it is only the strip title.