Bug 167458 - Double converted file and folder names (Unicode) using fish
Summary: Double converted file and folder names (Unicode) using fish
Status: RESOLVED DUPLICATE of bug 186038
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-26 01:17 UTC by Damien Gombault
Modified: 2009-04-30 12:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damien Gombault 2008-07-26 01:17:21 UTC
Version:            (using KDE 4.0.98)
Installed from:    Ubuntu Packages

When I connect to my other computer using fish, folders and files names appear double converted.

Example : The real name on the server is « Téléchargement », in Dolphin I get : « Téléchargement ».

I use UTF-8 on the client and the server.

I had the same problem with Konqueror (KDE3) but I could change the charset with « Tools/Select remote charset » and select UTF-8. This feature seems to be missing in Dolphin.
Comment 1 Thomas Capricelli 2009-03-16 11:58:59 UTC
i dont know if it's related, but when i use fish, every filename with special characters can NOT be copied or moved to a local folder. They are diplayed well, but when copying/moving, dolphin says "Impossible to read the file fish://......."
Comment 2 David Faure 2009-03-19 19:49:03 UTC
Works for me both with kde-trunk+qt-4.5 and with kde-4.2-branch+qt-4.4.3.

There have been quite a few encoding fixes lately, can you retest with KDE-4.2.2 when it's out or with trunk/4.3?

(Thomas, please tell me if you're already using trunk, you didn't specify your qt and kde versions)
Comment 3 Thomas Capricelli 2009-03-19 21:02:52 UTC
@david. Sorry : i use qt-4.5 and kde-4.2.1, official releases as found in gentoo.

I'm trying to find a easy way to reproduce. Just moving a file "àèé.txt" seems to work indeed, it must be something more subtle. I'll report here once found.
Comment 4 David Faure 2009-03-20 00:58:50 UTC
kde-4.2.1+qt-4.5 is a bad combination because it has at least the command-line-arguments encoding breakage (bug 186038 comment 40), plus the overall issue with the qt-4.5 locale initialization not fully fixed yet (bug 186038 comment 34).
So that's two reasons for the kind of problems you're describing in 4.2.1.
Unless you can reproduce any of these bugs with a recent 4.2-branch I'll close this as a duplicate of 186038.
Comment 5 Thomas Capricelli 2009-03-20 01:10:08 UTC
Please do that. If i can 
* reproduce it with 4.2.2
AND
* provide useful information about the bug

they i'll re-open it or open another one. ;-)
Comment 6 Peter Penz 2009-04-30 12:59:01 UTC

*** This bug has been marked as a duplicate of bug 186038 ***