Bug 167135 - dropdown completion in location bar gets falsely updated
Summary: dropdown completion in location bar gets falsely updated
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 171895 179123 184107 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-21 13:36 UTC by Benno Dielmann
Modified: 2009-02-12 14:46 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benno Dielmann 2008-07-21 13:36:15 UTC
Version:            (using KDE 4.0.98)
Installed from:    Ubuntu Packages
OS:                Linux

The history dropdown box of Konqueror's location bar gets updated (filtered) when the user selects items by pressing Tab. 

Example: Let's assume the history contains the following items in the following order:

http://bugs.kde.org/wizard.cgi
http://bugs.kde.org
http://bugs.kde.org/wizard.cgi?version=%20%28KDE%20%29&step=report

if you type 

bugs.

in the location bar, the dropdown drops down containing these items. If you now press tab several times, the expected behavior would be that the first item gets highlighted, then the second, and so on. At the moment (4.1 RC1) I observe the following: After pressing Tab once, the location bar text gets replaced by the first item (http://bugs.kde.org/wizard.cgi) which seems to trigger another filtering of the history, because the "http://bugs.kde.org" item disappears so there's no chance to reach it by pressing Tab twice.
Comment 1 Benno Dielmann 2008-07-21 13:38:05 UTC
Sorry, I didn't expect the example items would become links... They are just meant to be example history items...
Comment 2 Dario Andres 2008-07-24 23:45:11 UTC
(KDE 4.0.99 (4.1RC1+) in ArchLinux)
I can reproduce this bug
Comment 3 Dario Andres 2008-08-01 00:06:52 UTC
Using KDE 4.1.00 (KDE 4.1.0) (KDEmod) in ArchLinux i686:
I can still reproduce this bug
Comment 4 Dario Andres 2009-01-08 23:17:30 UTC
Here using:

Qt: 4.4.3 + qt-copy-patches-889120
KDE: 4.2.60 (KDE 4.2.60 (KDE 4.3 >= 20090106))
kdelibs svn rev. 907834 / kdebase svn rev. 907837
on ArchLinux x86_64 - Kernel 2.6.27.10

I can still reproduce this
Comment 5 Ronny Multrus 2009-01-23 15:52:10 UTC
Yes, this behavior is very annoying and should be implemented like it was in KDE 3.5.x and is described by the bug reporter. I'm now using 4.1.4 and the location bar is in very bad shape, I can't use tab to go thru the drop down items, hitting tab closes the list! And since my upgrade from 4.1.3 to 4.1.4, the location bar doesn't even search my bookmarks...
Comment 6 Neil Skrypuch 2009-02-02 01:26:32 UTC
I'm confirming that hitting tab in the location bar removes the autocomplete dropdown with KDE 4.2. For me, this makes the autocomplete pretty useless.
Comment 7 Dario Andres 2009-02-02 11:06:05 UTC
From:
kdebase/apps/konqueror/konqcombo.cpp:144

// we use KUrlCompletion, so let KLineEdit handle Key_Tab so that subdir<tab>/subdir<tab> works (#65877).
// KCompletionBox's handling of Key_Tab is just the same as Up/Down keys, not very useful.
completionBox()->setTabHandling(false);

Commenting out the last line makes the Tab function work OK but I don't know if this affect anything else (bug 65877 ?)
Comment 8 Stephan Sokolow 2009-02-02 12:28:52 UTC
Judging by the way the comment is phrased, I suspect it was just an on-a-whim change by someone who didn't think about how some people prefer to not have to lift their right hand off the keyboard and move it just to select a completion.
Comment 9 Dario Andres 2009-02-02 12:36:16 UTC
I have sent an email to the maintainers/commiters about this. They will know what to do.
Comment 10 David Faure 2009-02-03 01:13:26 UTC
No, I didn't add that line "on a whim" nor "without thinking" -- but at the time it didn't break Tab-goes-next-in-completion, it only fixed the usage of Tab when completion local urls -- and this line was from KDE 3.x, so it's not the problem. I'll investigate.
Comment 11 David Faure 2009-02-03 02:01:48 UTC
OK, it wasn't in KDE-3.x, it was in May 2008 -- but something must have changed later on. I swear it worked back then :-)
Comment 12 Benno Dielmann 2009-02-03 11:14:28 UTC
Well... it actually didn't work ;-) That's what this bug report originally was about...

The tab-ceased-to-work bug was introduced with KDE 4.1.4 (at least on my Kubuntu Intrepid)

So in May 2008, the dropdown at least didn't disappear, but cycling through the dropdown entries didn't work...
Comment 13 David Faure 2009-02-03 19:13:50 UTC
SVN commit 920746 by dfaure:

Re-enable handling of Tab
BUG: 167135


 M  +2 -4      konqcombo.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=920746
Comment 14 David Faure 2009-02-03 21:39:03 UTC
*** Bug 179123 has been marked as a duplicate of this bug. ***
Comment 15 Benno Dielmann 2009-02-03 23:01:01 UTC
Merci, David, for working on this bug. 

But, are you sure the bug you marked as a duplicate really is one? This bug report here originally wasn't about the Tab key closing the drop down list but about the completion going wrong (see above). Comments on it got slightly off-topic...

Is the original bug as reported above fixed by your commit, too?
Comment 16 David Faure 2009-02-04 11:46:55 UTC
Yes it works fine now (no re-filtering on <tab> if there are multiple items in the dropdown), since I re-enabled the code that makes "Tab" go "Down".
Hmm I cc'ed this bug on another commit but it didn't come through:


SVN commit 920743 by dfaure:

Better fix for 65877, which doesn't require disabling "Tab means Down" in the completion box (#167135 says some people like that :-).
I think I found a solution that makes everyone happy: if there's only one entry then Tab autoselects the first entry
and completes again, allowing to use it like a shell for local files:  /hom<tab>dfau<tab>Docu<tab> for /home/dfaure/Documents.
If there's more than one entry, then Tab does "Down" as before.
Comment 17 Ronny Multrus 2009-02-04 13:31:32 UTC
David, that sounds great, thank you! Maybe it is already this way, but can you make Shift + Tab go up in the list? If I recall correctly, this was like so back then and it would be nice to have it again...
Comment 18 Benno Dielmann 2009-02-04 16:20:25 UTC
Thanks for the good work, David!
Comment 19 David Faure 2009-02-05 20:12:48 UTC
*** Bug 171895 has been marked as a duplicate of this bug. ***
Comment 20 Tommi Tervo 2009-02-12 14:46:06 UTC
*** Bug 184107 has been marked as a duplicate of this bug. ***