Bug 165399 - the SMB ioslave doesn't work if directory contains files with non-latin1 names
Summary: the SMB ioslave doesn't work if directory contains files with non-latin1 names
Status: RESOLVED DUPLICATE of bug 158639
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: smb (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-30 11:04 UTC by Tomas Mecir
Modified: 2008-06-30 14:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mecir 2008-06-30 11:04:43 UTC
Version:            (using KDE 4.0.4)
Installed from:    SuSE RPMs
OS:                Linux

When trying to access a directory that contains at least one entry (be it files or directories) with a non-latin1 name, I don't get the directory listing, but instead a message about the protocol handler ending unexpectedly.

Also, if I try to create a directory/file with a non-latin1 name, I also receive the same message about unexpected ending, and the file never gets created. Again, smbclient works properly.

Note that this may be related to 158639, but the actual symptoms are different.

Trying to open the same directory using smbclient works properly.

To reproduce:
- Create an entry with non-latin1 (UTF8) characters in a SMB directory and try to access it using smb:/
- If you remove that entry and try to load the directory again, it works properly.
Comment 1 Pino Toscano 2008-06-30 14:25:15 UTC

*** This bug has been marked as a duplicate of 158639 ***