Bug 165325 - Crash when trying to import pictures from a USB-Camera
Summary: Crash when trying to import pictures from a USB-Camera
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Gphoto2 (show other bugs)
Version: 0.10.0
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-29 14:42 UTC by Carsten Niehaus
Modified: 2018-09-02 15:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.10.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Niehaus 2008-06-29 14:42:46 UTC
Version:           0.10.0-svn (rev.: 825782) (using 4.00.84 (KDE 4.0.84 (KDE 4.1 >= 20080625) "release 1.1", KDE:KDE4:Factory:Desktop / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25.5-1.1-default

I tried import pictures from my Canon EOS 400D.

Menu Import -> Digital Cameras -> Crash




Application: digiKam (digikam), signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[New Thread 0xb4ee16d0 (LWP 21327)]
[New Thread 0xad770b90 (LWP 21341)]
[New Thread 0xadf88b90 (LWP 21335)]
[New Thread 0xae789b90 (LWP 21334)]
[New Thread 0xb2cffb90 (LWP 21333)]
[New Thread 0xb24feb90 (LWP 21332)]
[New Thread 0xb39b5b90 (LWP 21329)]
[KCrash handler]
#6  0xb67c3aa4 in QString::fromLatin1_helper () from /usr/lib/libQtCore.so.4
#7  0xb67c3b7c in QString::fromLatin1 () from /usr/lib/libQtCore.so.4
#8  0x08134bb6 in Digikam::GPCamera::findConnectedUsbCamera (vendorId=1193, 
    productId=12560, model=@0xbfeba3a8, port=@0xbfeba3a4)
    at /home/kde-devel/kde/src/graphics/digikam/utilities/cameragui/gpcamera.cpp:1466
#9  0x0826cedc in Digikam::CameraList::findConnectedCamera (vendorId=1193, 
    productId=12560, model=@0xbfeba3a8, port=@0xbfeba3a4)
    at /home/kde-devel/kde/src/graphics/digikam/digikam/cameralist.cpp:274
#10 0x0827a241 in Digikam::DigikamApp::slotOpenSolidCamera (this=0x8597400, 
    action=0xa57a7a0)
    at /home/kde-devel/kde/src/graphics/digikam/digikam/digikamapp.cpp:1477
#11 0x0828f231 in Digikam::DigikamApp::qt_metacall (this=0x8597400, 
    _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xbfeba50c)
    at /home/kde-devel/kde/build/graphics/digikam/digikam/digikamapp.moc:194
#12 0xb68723fa in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#13 0xb6872972 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#14 0xb5b9a7c3 in QActionGroup::triggered () from /usr/lib/libQtGui.so.4
#15 0xb5b9b048 in ?? () from /usr/lib/libQtGui.so.4
#16 0xb5b9b25e in QActionGroup::qt_metacall () from /usr/lib/libQtGui.so.4
#17 0xb68723fa in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#18 0xb68726f0 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#19 0xb5b96941 in QAction::triggered () from /usr/lib/libQtGui.so.4
#20 0xb5b972af in QAction::activate () from /usr/lib/libQtGui.so.4
#21 0xb5f19032 in ?? () from /usr/lib/libQtGui.so.4
#22 0xb5f19ca2 in QMenu::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
#23 0xb75f7de5 in KMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.5
#24 0xb5bee176 in QWidget::event () from /usr/lib/libQtGui.so.4
#25 0xb5f1a719 in QMenu::event () from /usr/lib/libQtGui.so.4
#26 0xb5b9becc in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#27 0xb5ba2ca7 in QApplication::notify () from /usr/lib/libQtGui.so.4
#28 0xb75322cd in KApplication::notify () from /usr/lib/libkdeui.so.5
#29 0xb6860b51 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#30 0xb5ba3fae in QApplicationPrivate::sendMouseEvent ()
   from /usr/lib/libQtGui.so.4
#31 0xb5c01474 in ?? () from /usr/lib/libQtGui.so.4
#32 0xb5c005a4 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#33 0xb5c263ae in ?? () from /usr/lib/libQtGui.so.4
#34 0xb685f2ca in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#35 0xb685f48a in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#36 0xb686166d in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#37 0xb5b9bd47 in QApplication::exec () from /usr/lib/libQtGui.so.4
#38 0x082c9b79 in main (argc=1, argv=0xbfebb994)
    at /home/kde-devel/kde/src/graphics/digikam/digikam/main.cpp:336
#0  0xffffe430 in __kernel_vsyscall ()
Comment 1 caulier.gilles 2008-06-29 15:15:42 UTC
It's work with KDE3 version ?

Gilles Caulier
Comment 2 Carsten Niehaus 2008-06-29 15:18:40 UTC
So far it always worked in KDE3 with the KDE3-Digikam-version, yes.
Comment 3 Andi Clemens 2008-08-16 11:34:10 UTC
Carsten,

can you still confirm this and if so, give us an updated backtrace?

Andi
Comment 4 Andi Clemens 2008-09-02 18:28:47 UTC
Any updates here?
Comment 5 Carsten Niehaus 2008-09-02 19:28:39 UTC
I will try later! On my main machine I deinstalled digikam for KDE4. I will try it on my laptop soon. If I didn't answer in the next day ping me again, I have more time on weekends.
Comment 6 Andi Clemens 2008-09-08 15:25:18 UTC
Oh I forgot: PING :-)
Comment 7 Christophe Giboudeaux 2008-10-19 13:55:18 UTC
*** Bug 173138 has been marked as a duplicate of this bug. ***
Comment 8 BernardM 2008-11-26 07:32:03 UTC
The same bug for me on Mandriva 2009 Powerpack and Kodak Z650

Application : DigiKam (digikam), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb4b406d0 (LWP 25890)]
[New Thread 0xadd7cb90 (LWP 26155)]
[New Thread 0xaecbcb90 (LWP 25912)]
[New Thread 0xaf51ab90 (LWP 25906)]
[New Thread 0xb02a0b90 (LWP 25900)]
[New Thread 0xb21c9b90 (LWP 25893)]
[New Thread 0xb29cab90 (LWP 25892)]
[New Thread 0xb352cb90 (LWP 25891)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb59b7d90 in raise () from /lib/i686/libc.so.6
#8  0xb59b97f8 in abort () from /lib/i686/libc.so.6
#9  0xb68b2445 in qt_message_output () from /usr/lib/libQtCore.so.4
#10 0xb68b2535 in qFatal () from /usr/lib/libQtCore.so.4
#11 0xb68b25e5 in qt_assert () from /usr/lib/libQtCore.so.4
#12 0x080bf264 in Digikam::CameraItemPropertiesTab::setCurrentItem ()
#13 0x080adc29 in Digikam::ImagePropertiesSideBarCamGui::slotChangedTab ()
#14 0x080ae252 in Digikam::ImagePropertiesSideBarCamGui::itemChanged ()
#15 0x0814e416 in ?? ()
#16 0x0815d487 in ?? ()
#17 0xb69c8c8d in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#18 0xb69c9a95 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#19 0x08137fd7 in ?? ()
#20 0x08138053 in ?? ()
#21 0x0813ca0d in ?? ()
#22 0xb69c8c8d in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#23 0xb69c9a95 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#24 0x08281ac7 in Digikam::IconView::signalSelectionChanged ()
#25 0x08281b3a in Digikam::IconView::selectItem ()
#26 0x082866a6 in Digikam::IconItem::setSelected ()
#27 0x082839b3 in Digikam::IconView::slotRearrange ()
#28 0x08283ad8 in Digikam::IconView::qt_metacall ()
#29 0x0813c927 in ?? ()
#30 0xb69c8c8d in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#31 0xb69c9a95 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#32 0xb6a04ef5 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#33 0xb69cf946 in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#34 0xb69c351b in QObject::event () from /usr/lib/libQtCore.so.4
#35 0xb6066fac in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#36 0xb606f205 in QApplication::notify () from /usr/lib/libQtGui.so.4
#37 0xb6f34771 in KApplication::notify () from /usr/lib/libkdeui.so.5
#38 0xb69b3853 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#39 0xb69e2a8d in ?? () from /usr/lib/libQtCore.so.4
#40 0xb69df3ee in ?? () from /usr/lib/libQtCore.so.4
#41 0xb53da7ca in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#42 0xb53ddee8 in ?? () from /usr/lib/libglib-2.0.so.0
#43 0xb53de0a8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#44 0xb69df34a in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#45 0xb610395a in ?? () from /usr/lib/libQtGui.so.4
#46 0xb69b1ec3 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#47 0xb69b2081 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#48 0xb69b47f2 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#49 0xb6066e14 in QApplication::exec () from /usr/lib/libQtGui.so.4
#50 0x0829c05e in ?? ()
#51 0xb59a45c5 in __libc_start_main () from /lib/i686/libc.so.6
#52 0x0809e5c1 in _start ()
Comment 9 Andi Clemens 2008-12-01 23:30:17 UTC
Marcel,

isn't this one of the issues you fixed in the last week?

Carsten, BernardM,

can you still confirm this with the latest version (beta6 or svn)?

Andi
Comment 10 Marcel Wiesweg 2008-12-02 17:15:25 UTC
The initial backtrace is fixed by bug 175597.
The backtrace in comment #8 is fixed by bug 169641.

*** This bug has been marked as a duplicate of bug 175597 ***