Bug 165321 - Maximized mode doesn't work, digikam is "under" the taskbar
Summary: Maximized mode doesn't work, digikam is "under" the taskbar
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-MainView (show other bugs)
Version: 0.10.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-29 14:35 UTC by Carsten Niehaus
Modified: 2017-07-05 04:37 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.10.0


Attachments
Look at the bottom of the file to see the issue (179.11 KB, image/png)
2008-06-29 14:36 UTC, Carsten Niehaus
Details
maximized window (29.07 KB, image/png)
2008-06-29 16:19 UTC, Christophe Giboudeaux
Details
Oxygen style with digiKam (359.42 KB, image/png)
2008-08-01 08:36 UTC, caulier.gilles
Details
Plastic style with digiKam (330.76 KB, image/png)
2008-08-01 08:37 UTC, caulier.gilles
Details
ToolButton vs. PushButton (22.72 KB, image/png)
2008-08-15 11:15 UTC, Andi Clemens
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Niehaus 2008-06-29 14:35:02 UTC
Version:           0.10.0-svn (rev.: 825782) (using 4.00.84 (KDE 4.0.84 (KDE 4.1 >= 20080625) "release 1.1", KDE:KDE4:Factory:Desktop / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25.5-1.1-default

See attached screenshot. The Taskbar is over digikam. I just maximized Digikam.

Perhaps this is a Plasma bug?
Comment 1 Carsten Niehaus 2008-06-29 14:36:09 UTC
Created attachment 25701 [details]
Look at the bottom of the file to see the issue
Comment 2 caulier.gilles 2008-06-29 14:37:42 UTC
Strange. here it's not reproductible. Of course, i work with KDE3 as desktop...

Gilles Caulier
Comment 3 Christophe Giboudeaux 2008-06-29 16:15:01 UTC
the window on your screenshot isn't maximized
Comment 4 Christophe Giboudeaux 2008-06-29 16:19:32 UTC
Created attachment 25708 [details]
maximized window

Screenshot showing the buttons when a window is maximized
Comment 5 Gandalf Lechner 2008-07-11 17:26:39 UTC
I can confirm this bug, same situation here.
Comment 6 caulier.gilles 2008-07-28 14:14:34 UTC
SVN commit 838650 by cgilles:

optimize space
CCBUGS: 165321


 M  +2 -2      fuzzysearchview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=838650
Comment 7 caulier.gilles 2008-08-01 08:36:52 UTC
Created attachment 26543 [details]
Oxygen style with digiKam

The space used to render widget contents is dependant of KDE4 style used.

The Oxygen style consume a lots of free space duing large margin everywhere.
It's not an optimized style. Look attached screenshots for details.

Personally i use Plastik style which is really better.

Gilles Caulier
Comment 8 caulier.gilles 2008-08-01 08:37:53 UTC
Created attachment 26544 [details]
Plastic style with digiKam
Comment 9 Camilla Boemann 2008-08-01 09:27:44 UTC
It's not an oxygen bug - how on earth did you come up with that conclusion??

I suggest someone talk to plasma and see if they'll take it - otherwise i'll close it
Comment 10 Camilla Boemann 2008-08-14 20:06:44 UTC
closing as there seem to be no interest - and it's not oxygen
Comment 11 caulier.gilles 2008-08-15 10:22:06 UTC
Casper,

Are you take a look in my screenshots ?

Look like the Oxygen style is not optimized (from a space using i want mean). Buttons use a very huge marging and all the digiKam GUI is broken. If i use Plastic style (or all other one available), all is fine.

Gilles Caulier
Comment 12 Andi Clemens 2008-08-15 10:34:08 UTC
I can confirm this, too. Some filter dialogs get so big with Oxygen style, that they don't even fit on my 1024x768 screen. All other styles have much smaller buttons and therefore can be scaled much smaller.
Comment 13 Camilla Boemann 2008-08-15 10:39:30 UTC
Hi Gilles

Yesterday I commited several spacesaving stuff to trunk - you might want to try it out with that.

But the place where you loose the most is because all you buttons on the left and right in that screenshot seems to be pushbuttons. Buttons like that ought to be toolbuttons. Pushbuttons are meant for buttons like "Cancel" and other text buttons. The Oxygen style emphasizes this semantic difference, but it naturally requires the apps to use the right semantic.

Oh and finally - the fact that the panel is over the window is obviously a plasma problem
Comment 14 Camilla Boemann 2008-08-15 10:45:53 UTC
Actually Oxygen takes up less space - try to see the width of the statusbar - it's less in the oxygen style
Comment 15 Andi Clemens 2008-08-15 11:15:08 UTC
Created attachment 26857 [details]
ToolButton vs. PushButton

Casper, you are right, a ToolButton does the trick.

Gilles,

I can change all those buttons to ToolButtons if you don't mind.

Andi
Comment 16 caulier.gilles 2008-08-15 11:53:37 UTC
Andi,

You don't need to ask me to commit a change like this (:=)))... Go ahead

Casper,

Fine to hear improvements from Oxygen. We will take a look.

Are you re-assign this file to plasma component ?

Best

Gilles Caulier 
Comment 17 FiNeX 2008-08-15 12:42:06 UTC
So, the panel which is in front of the window is a plasma issue? I don't think so: if a window is too big it is placed below the panel (it should be managed by kwin). So this is not an issue.

If a window application is too big for a minimal resolution, it is an application problem, not a plasma one. If oxygen style doesn't allow digikam to be small enough for 1024x768, maybe digikam should be more elastic. Anyway, if now oxygen style has been improved to save more space, I'll keep this bug here, or, at least, I'll move to digikam, but not to plasma.
Comment 18 FiNeX 2008-08-15 12:44:27 UTC
Moreover, if needed, it could be created a wish to plasma (?) for adding an option to keep the panel below or above other windows.
Comment 19 caulier.gilles 2008-08-15 12:45:13 UTC
I re-open this file until it will fixed. also, it need to be re-assigned to Plasma (look #13)

Andi, no problem if bug is assigned to a developper. Take a care to let's mailling list as copy.

Also, at Akademy Dirk Muller ask me about a new bugzila version in beta test for the moment. Perhaps we have new options to manage bug workflow.

Gilles
Comment 20 Andi Clemens 2008-08-15 12:51:28 UTC
Yes new bugzilla version would be really helpful, I would be able to finally 
connect the MyLyn plugin from Eclipse with B.K.O.

Andi
Comment 21 Camilla Boemann 2008-08-15 13:05:52 UTC
For what it is worth I don't see this overlapping problem in kde 4.1

Can someone confirm that it's still a problem?
Comment 22 Camilla Boemann 2008-08-15 13:09:16 UTC
sorry - i just saw that the screenshot isn't of a maximized window

then it's indeed NOT a plasma bug

I'll assign it back to digikam, but add myself to the cc of this bug
Comment 23 caulier.gilles 2008-12-05 13:04:50 UTC
This file is fixed since with digiKam 0.9.5-svn and 0.10.0-beta6 since QScrollView is used everywhere in sidebar to optimize window size with small screen.

I close this file now.

Gilles Caulier