Bug 165309 - Usability: Dolphin "new tab" keyboard shortcut suggestion
Summary: Usability: Dolphin "new tab" keyboard shortcut suggestion
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-29 13:31 UTC by Bassio
Modified: 2008-06-29 15:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bassio 2008-06-29 13:31:24 UTC
Version:           1.0.99 (using 4.00.83 (KDE 4.0.83 (KDE 4.1 Beta2), Kubuntu packages)
Compiler:          gcc
OS:                Linux (i686) release 2.6.24-19-generic

I see that the current shortcut for opening a new tab in Dolphin is 3-keyed: CTRL+Shift+N

May I suggest that in order to become more in flow with other browsers like konqueror and firefox .. is to switch it to the 'easier on the hand' and 'somehow more accessible' and more intuitive suggestion of 
Ctrl+T

like this it will be the same as konqueror and same in firefox, you know .. to be more 'universal' ;)

so we will have ctrl+n for new window
and ctrl+t for new tab

What do you think Peter?
Comment 1 Peter Penz 2008-06-29 13:37:20 UTC
Konqueror and Konsole in KDE use Ctrl+Shift+N, so if we change it in Dolphin we'd also have to change it for the other KDE applications... I just checked the KDE 3 version of Konqueror and also here Ctrl+Shift+N has been used.

I personally don't like Ctrl+Shift+N myself, but won't change it until the other application maintainers agree. Maybe you can post your concerns at kde-usability@kde.org? Thanks!
Comment 2 Bassio 2008-06-29 14:21:23 UTC
hmmm .. do you have konqueror kde 4? try Ctrl-T there .. it works!!

Strangely as you mention, also Ctrl+Shift+N works in konqueror kde 4, so konqueror kde 4 now has two keyboard shortcuts for new tabs!!

Can't Dolphin implement that so it becomes similar to konqueror kde 4?
Comment 3 Peter Penz 2008-06-29 14:23:54 UTC
Ah, I was not aware about this. Yes, assigning an alternate shortcut is no problem, I'll implement this :-)
Comment 4 Bassio 2008-06-29 14:32:40 UTC
I have seen the kde-usability.

Their website is pretty much outdated which makes me doubt if the project is still running.

Nice to have the alternate shortcut Thank you.. since Ctrl-t is much easier. And making Ctrl-T the default will be more intuitive for new users .. while still not breaking the old 3-key one for old users who got used to it.

Click File--> "New tab Ctrl-Shift-N" should perhaps read "New tab Ctrl-T"

while preserving Ctrl-Shift-N in the background.

Can I depend on you to contact konqueror and other maintainers to discuss the consistency of this issue? Or do you want me to contact them?

We need to have a pretty much standardized shortcut for new tab in all kde-apps, so if konqueror maintainer is thinking about shifting to Ctrl-T as the default in the future then why not shift and make it a universal standard?
Comment 5 Peter Penz 2008-06-29 14:53:37 UTC
> Can I depend on you to contact konqueror and other maintainers
> to discuss the consistency of this issue? Or do you want me to contact them? 

Sorry, I but I only have around 5 hours per week time for Dolphin and get around 10 bug reports/wish requests per day ;-) By using CTRL-T as alternative shortcut Dolphin is consistent with Konqueror and for me the issue is solved.

Discussions about changing default shortcuts for KDE are mostly endless, so I won't jump into such a discussion myself ;-)

> We need to have a pretty much standardized shortcut for new tab
> in all kde-apps, so if konqueror maintainer is thinking about
> shifting to Ctrl-T as the default in the future then why not
> shift and make it a universal standard? 

The Konqueror maintainer (= David Faure) and I are in close contact. David would not make a change without giving me a note. The same is valid for the other direction: If I change a shortcut in Dolphin I check this with David.

Anyhow we can not change a default shortcut in KDE without discussion in core-devel@kde.org...
Comment 6 Peter Penz 2008-06-29 15:37:32 UTC
SVN commit 825833 by ppenz:

provide Ctrl+T as alternative shortcut to Ctrl+Shift+N for "New Tab" like Konqueror

BUG: 165309

 M  +1 -1      dolphinmainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=825833