Bug 165307 - kitchensync connects to palm over usb, but core dumps (signal 11) after reading 5999 entries from palm and kontact.
Summary: kitchensync connects to palm over usb, but core dumps (signal 11) after readi...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kitchensync
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Quentin Denis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-29 13:24 UTC by Dr. Christoph Pospiech
Modified: 2012-01-19 13:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Christoph Pospiech 2008-06-29 13:24:23 UTC
Version:           0.1 (using 3.5.9-4.el5 Fedora, CentOS release 5 (Final))
Compiler:          Target: i386-redhat-linux
OS:                Linux (i686) release 2.6.21-3_HPM

Not available - Is there any log file I can look at ?
Comment 1 Dr. Christoph Pospiech 2008-06-29 13:46:18 UTC
I found at least the following back trace from the core dump.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208153616 (LWP 3751)]
[New Thread -1261872240 (LWP 4448)]
[New Thread -1219908720 (LWP 4447)]
[New Thread -1211516016 (LWP 4446)]
[New Thread -1236694128 (LWP 4445)]
[New Thread -1228301424 (LWP 4442)]
[New Thread -1245086832 (LWP 4440)]
[New Thread -1253479536 (LWP 4437)]
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0x4e753557 in pthread_join () from /lib/libpthread.so.0
#2  0x41168926 in QWidget::setUpdatesEnabled () from /lib/libgthread-2.0.so.0
#3  0x413b8c7f in g_thread_join () from /lib/libglib-2.0.so.0
#4  0x411a6a20 in osengine_finalize () from /usr/lib/libosengine.so.0
#5  0x411bedcf in QSync::Engine::finalize (this=0x819bb48) at engine.cpp:52
#6  0x4148f593 in ~SyncProcess (this=0x819be40) at syncprocess.cpp:45
#7  0x4149053b in ~SyncProcessManager (this=0x818dc90)
    at syncprocessmanager.cpp:60
#8  0x41490f55 in __tcf_0 () at /usr/include/kde/kstaticdeleter.h:126
#9  0x4e604c79 in __cxa_finalize () from /lib/libc.so.6
#10 0x41483084 in __do_global_dtors_aux () from /usr/lib/libkitchensync.so.0
#11 0x414c6f9c in _fini () from /usr/lib/libkitchensync.so.0
#12 0x4dc177de in _dl_fini () from /lib/ld-linux.so.2
#13 0x4e6049c9 in exit () from /lib/libc.so.6
#14 0x4ea60512 in qt_xget_readonly_gc ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x4e201a1d in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#16 0x4e201a69 in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#17 0x4dc65fed in _XIOError () from /usr/lib/libX11.so.6
#18 0x4dc684ac in _XEventsQueued () from /usr/lib/libX11.so.6
#19 0x4dc53f32 in XPending () from /usr/lib/libX11.so.6
#20 0x4ea8112a in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x4eaf24a0 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x4eaf2356 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x4ead8a8f in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x0804d265 in main (argc=) at main.cpp:57
#25 0x4e5eedec in __libc_start_main () from /lib/libc.so.6
#26 0x0804d091 in _start ()

Hope this helps.

Christoph Pospiech
Comment 2 Lubos Lunak 2008-07-21 16:23:17 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 3 Dr. Christoph Pospiech 2012-01-08 14:38:50 UTC
Where are we with respect to this bug report ? I (=original reporter) have moved on to Kubuntu Oneiric (linux kernel 3.0.0, KDE 4.7). Did kitchensync make it to KDE 4 ? If not, we might want to close this bug.
Comment 4 quentin.denis 2012-01-19 12:45:02 UTC
I am sorry to tell you that I had to give up developing kitchensync. I took it over from Tobias Koenig to make it work again with the new opensync API, but now that I have started my professionnal life I don't find any time to maintain kitchensync anymore. So let's close the bug.

Btw, kitchensync has been ported to KDE4 and basically works. The problem is more on the opensync side...
Comment 5 Dr. Christoph Pospiech 2012-01-19 13:40:05 UTC
OK, given the last comment (#4) I changed the status of the bug to "resolved" as "unmaintained". I hope that is OK.

Christoph Pospiech