Bug 164861 - Plasma crash on logout
Summary: Plasma crash on logout
Status: RESOLVED DUPLICATE of bug 163607
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-24 21:26 UTC by Arnout Boelens
Modified: 2008-07-05 23:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arnout Boelens 2008-06-24 21:26:16 UTC
Version:           unknown (using 4.00.82 (KDE 4.0.82 >= 20080610), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.25-2-686

On loging out plasma crashes, generating the following backtrace:

Application: Plasma Workspace (plasma), signal SIGSEGV
[Thread debugging using libthread_db enabled]         
[New Thread 0xb5572720 (LWP 5113)]                    
[New Thread 0xb1d75b90 (LWP 5119)]                    
[New Thread 0xb295fb90 (LWP 5118)]                    
[KCrash handler]                                      
#6  0x000008da in ?? ()                               
#7  0xb29c3f0e in ~FolderView (this=0x8ff7398)        
    at /tmp/buildd/kdebase-4.0.82+svn819867/apps/plasma/applets/folderview/folderview.cpp:123
#8  0xb7cfc8a6 in Plasma::Containment::~Containment ()                                       
   from /usr/lib/libplasma.so.2                                                              
#9  0xb3dc8ac3 in ?? () from /usr/lib/kde4/plasma_containment_desktop.so                     
#10 0x08f153f0 in ?? ()                                                                      
#11 0x09300888 in ?? ()
#12 0xb7753b6b in KConfigGroup::writeEntry (this=0x8f153f0,
    key=0xb7dbbf5f "immutability", value=@0xbfe9a6ac, flags={i = -1075206464})
    at /tmp/buildd/kde4libs-4.0.82+svn819867/kdecore/config/kconfiggroup.cpp:961
#13 0xb7d08bc6 in Plasma::Corona::~Corona () from /usr/lib/libplasma.so.2
#14 0xb7f4d71d in ?? () from /usr/lib/libkdeinit4_plasma.so
#15 0x08eb9ed0 in ?? ()
#16 0x09501690 in ?? ()
#17 0xbfe9a6f8 in ?? ()
#18 0xb7f54e1f in ?? () from /usr/lib/libkdeinit4_plasma.so
#19 0xb7f68088 in ?? () from /usr/lib/libkdeinit4_plasma.so
#20 0x0918e7c0 in ?? ()
#21 0xbfe9a7b8 in ?? ()
#22 0xb7f5213f in ?? () from /usr/lib/libkdeinit4_plasma.so
#23 0x08eb9ed0 in ?? ()
#24 0x0956b480 in ?? ()
#25 0xbfe9a750 in ?? ()
#26 0xbfe9a770 in ?? ()
#27 0xbfe9a79c in ?? ()
#28 0xbfe9a794 in ?? ()
#29 0xbfe9a78c in ?? ()
#30 0xbfe9a788 in ?? ()
#31 0xbfe9a768 in ?? ()
#32 0x00000001 in ?? ()
#33 0x00000001 in ?? ()
#34 0xbfe9a740 in ?? ()
#35 0x095016a0 in ?? ()
#36 0x0956b470 in ?? ()
#37 0x0956b480 in ?? ()
#38 0x00000997 in ?? ()
#39 0x0918e7a8 in ?? ()
#40 0x00000000 in ?? ()
#0  0xb7f80424 in __kernel_vsyscall ()
Comment 1 Aaron J. Seigo 2008-06-24 23:56:58 UTC
this backtrace isn't very useful. please provide a better backtrace using the information on this page:

http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports

thanks...
Comment 2 Sebastian Sauer 2008-06-25 00:32:41 UTC
looks like a duplicate of bug #164653 which was fixed with r823000 (>= Sunday 22 June).
Comment 3 FiNeX 2008-06-25 11:22:07 UTC
@Arnout: you should update your kde version to a more recent one and re-test it.
Comment 4 Arnout Boelens 2008-06-25 17:56:20 UTC
@Aaron: It turned out I missed one Debian dbg package.. I just read on your blog how you wished development packages where with debugging symbols by default. Now I know why :-). When the crash occures again (I does not happen on every logout) I will give the new backtrace.

@FiNeX: I will try when there are new Debian packages. This might take a while though, because the are focusing on getting KDE 3.5.9 in shape for the new release..
Comment 5 Arnout Boelens 2008-06-26 01:35:20 UTC
The complete backtrace:

Application: Plasma Workspace (plasma), signal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0xb5510720 (LWP 4998)]
[New Thread 0xb1d35b90 (LWP 5004)]
[New Thread 0xb291fb90 (LWP 5003)]
[KCrash handler]
#6  0x00000005 in ?? ()
#7  0xb723ea43 in QGraphicsWidget::event (this=0x92bf019, event=0xbff37b98)
    at graphicsview/qgraphicswidget.cpp:1153
#8  0xb6c8b66c in QApplicationPrivate::notify_helper (this=0x91939a0, 
    receiver=0x92bf018, e=0xbff37b98) at kernel/qapplication.cpp:3772
#9  0xb6c9343e in QApplication::notify (this=0x9195908, receiver=0x92bf018, 
    e=0xbff37b98) at kernel/qapplication.cpp:3366
#10 0xb7a62a3d in KApplication::notify (this=0x9195908, receiver=0x92bf018, 
    event=0xbff37b98)
    at /tmp/buildd/kde4libs-4.0.82+svn819867/kdeui/kernel/kapplication.cpp:311
#11 0xb7591541 in QCoreApplication::notifyInternal (this=0x9195908, 
    receiver=0x92bf018, event=0xbff37b98) at kernel/qcoreapplication.cpp:587
#12 0xb723edc4 in QGraphicsWidget::sceneEvent (this=0x92bf018, 
    event=0xbff37b98)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#13 0xb7219dec in QGraphicsScenePrivate::sendEvent (this=0x91f1748, 
    item=0x92bf020, event=0xbff37b98) at graphicsview/qgraphicsscene.cpp:1046
#14 0xb721a85a in QGraphicsScene::setFocusItem (this=0x91f0c90, item=0x0, 
    focusReason=Qt::OtherFocusReason) at graphicsview/qgraphicsscene.cpp:2634
#15 0xb71f831e in QGraphicsItem::clearFocus (this=0x92bf020)
    at graphicsview/qgraphicsitem.cpp:1871
#16 0xb723db1c in ~QGraphicsWidget (this=0x92bf018)
    at graphicsview/qgraphicswidget.cpp:218
#17 0xb7c7121e in ~Applet (this=0x92bf018)
    at /tmp/buildd/kdebase-workspace-4.0.82+svn819867/libs/plasma/applet.cpp:126
#18 0xb7c9a8f3 in ~Containment (this=0x92bf018)
    at /tmp/buildd/kdebase-workspace-4.0.82+svn819867/libs/plasma/containment.cpp:103
#19 0xb3cfd89b in ~Panel (this=0x92bf018)
    at /tmp/buildd/kdebase-workspace-4.0.82+svn819867/plasma/containments/panel/panel.cpp:74
#20 0xb7ca6bc6 in ~Corona (this=0x91f0c90)
    at /usr/include/qt4/QtCore/qalgorithms.h:352
#21 0xb7eeb71d in ~DesktopCorona (this=0x91f0c90)
    at /tmp/buildd/kdebase-workspace-4.0.82+svn819867/plasma/plasma/desktopcorona.h:31
#22 0xb7ef013f in PlasmaApp::cleanup (this=0x9195908)
    at /tmp/buildd/kdebase-workspace-4.0.82+svn819867/plasma/plasma/plasmaapp.cpp:261
#23 0xb7ef2673 in PlasmaApp::qt_metacall (this=0x9195908, 
    _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbff37e38)
    at /tmp/buildd/kdebase-workspace-4.0.82+svn819867/obj-i486-linux-gnu/plasma/plasma/plasmaapp.moc:78
#24 0xb75a6090 in QMetaObject::activate (sender=0x9195908, 
    from_signal_index=4, to_signal_index=4, argv=0x0)
    at kernel/qobject.cpp:3010
#25 0xb75a6e12 in QMetaObject::activate (sender=0x9195908, m=0xb76739c4, 
    local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3080
#26 0xb75e08f7 in QCoreApplication::aboutToQuit (this=0x9195908)
    at .moc/release-shared/moc_qcoreapplication.cpp:123
#27 0xb75924b7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:849
#28 0xb6c8b4e7 in QApplication::exec () at kernel/qapplication.cpp:3304
#29 0xb7eeed11 in kdemain (argc=1, argv=0xbff38084)
    at /tmp/buildd/kdebase-workspace-4.0.82+svn819867/plasma/plasma/main.cpp:54
#30 0x08048592 in main (argc=)
    at /tmp/buildd/kdebase-workspace-4.0.82+svn819867/obj-i486-linux-gnu/plasma/plasma/plasma-qgv_dummy.cpp:3
#0  0xb7f1e424 in __kernel_vsyscall ()
Comment 6 Sebastian Sauer 2008-06-26 23:28:00 UTC
I (and someone else) can reproduce the backtrace from comment #5 with Cooker on;

1) remove the dolphin-icon from the panel
2) kquitapp plasma
3) plasma
4) crash

Quit funny since plasma starts then up anyway and the dolphin-icon is still in the panel. So, seems the change wasn't saved on the one side but somehow is able to lead to a crash on startup on the other side what is more then illogical imho.
Comment 7 Thomas Georgiou 2008-07-05 23:38:23 UTC
*** Bug 165021 has been marked as a duplicate of this bug. ***
Comment 8 Sebastian Sauer 2008-07-05 23:57:11 UTC
interesting duplicate-roundtrip of this crasher and following it

Ok, once more; let's mark this bug as duplicate of bug #163607 (cause same backtrace and cause at the other report we already got closer to a solution ;)


*** This bug has been marked as a duplicate of 163607 ***