Bug 16480 - [PATCH] Insert signature at top or cursor
Summary: [PATCH] Insert signature at top or cursor
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.1.99
Platform: unspecified Linux
: NOR wishlist with 282 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 58917 89664 93953 103956 111764 151585 (view as bug list)
Depends on:
Blocks:
 
Reported: 2000-12-04 21:48 UTC by Dave M
Modified: 2008-03-16 05:29 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
old unfinished patch (4.22 KB, patch)
2005-07-06 23:37 UTC, Edwin Schepers
Details
kmail-tofu.patch (13.93 KB, patch)
2007-10-30 23:14 UTC, Scott
Details
enterprise-tofu.patch (10.18 KB, patch)
2007-10-31 07:14 UTC, Scott
Details
kmail-tofu.patch (17.48 KB, patch)
2007-11-01 06:14 UTC, Scott
Details
enterprise-tofu.patch (12.66 KB, patch)
2007-11-01 06:17 UTC, Scott
Details
kmail-tofu.patch (17.49 KB, patch)
2007-11-01 19:17 UTC, Scott
Details
enterprise-tofu.patch (12.67 KB, patch)
2007-11-01 19:18 UTC, Scott
Details
trunk-tofu.patch (16.44 KB, patch)
2007-11-07 23:42 UTC, Scott
Details
trunk-tofu.patch (18.76 KB, patch)
2007-11-13 18:09 UTC, Scott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2000-12-04 21:20:35 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: kmail
Version: 1.1.99 (KDE 2.0)
Severity: wishlist
Compiler: gcc version 2.96 20000731 (Red Hat Linux 7.0)
OS: Linux 2.2.16-22smp i686 (Red Hat Linux 6.9.2)

hanks for a well featured and soild e-mail client

My feature request relates to the placement of the signature file in reply & forwarded mails

I use kmail predominately for work & as such have a large number of reply & forwarded e-mail. All the poeple I deal with follow the same convention which is that their comments appear at the top of the mail with the signature. There are good reasons for this practice which I won't go into here suffice to say that the ability to get a signature file at the top of a mail with a row of of characters
separating the start of previous e-mails would be a big advantage.

Ideally the feature would be selectable per profile but even one that is globally set would be great

Many thanks for your consideration

David
Comment 1 automailer 2003-04-03 20:43:56 UTC
IMHO also solved. 
 
KMail 1.5 forwards messages as attachments thus your signature will appear on top 
of the forwarded messages. 
 
Cheers, 
Thorsten 
Comment 2 Ingo Klöcker 2003-04-04 10:32:21 UTC
It's not really solved for replies. So I will leave this wish open for now. 
Comment 3 Keith Rinaldo 2003-04-28 20:18:55 UTC
This is an old post but it's still outstanding... I'd really like to see this feature 
implemented. 
Comment 4 Ingo Klöcker 2003-05-25 23:31:05 UTC
*** Bug 58917 has been marked as a duplicate of this bug. ***
Comment 5 Dave M 2003-07-16 06:34:29 UTC
Only asking because this WISH has been open (or new?) for like 2.5 years... Any chance of signatures 
being at the top of replies and in-line forwards? 
 
Thanks, 
 
Dave 
Comment 6 Ingo Klöcker 2003-07-16 12:19:41 UTC
As this is mainly useful for the dreaded reply above full quote below this will probably never 
be implemented. Furthermore some email clients allow the user to strip off everything below 
the signature marker. So people using such a client will have to turn off this feature just to be 
able to read the quoted/forwarded message. 
 
You should forward messages as attachment if you don't want to have the footer below the 
forwarded messages. 
 
As for replies, I don't think we will ever implement this because quoting the full replied-to 
message below the reply is regarded as impolite by most non-Outlook users. 
Comment 7 David 2003-07-16 13:42:39 UTC
I would like to point out it is not just Outlook users that make use of such a feature.  
  
Many times in business you want the most recent comments at the top of the mail and  
everything else in reverse sequence below. This enables email to be read more quickly as you  
immediately get the most recent comments without having to scroll through an entire message  
to find them inline or goto the bottom. You also get all of the comments (if there aren't very  
many) on the same screen as all the email header information such as Date, TIme, Subject  
and CC's. I can't tell you the number of times I have been reading a mail and when I have  
come across a cerain point glanced up to see who was on in the CC list. If the guy who wrote  
it has CCed his boss or HORROR my boss, his comments have a different meaning to if he  
has just sent it to me alone.  
  
Indeed this is how outlook works and possibly as a result it is how most corporate email  
communication is structured. As the vast majority of my e-mail and I suspect many of kmail  
users is in this same format such a feature is not dreaded but actually useful.  
  
Got to admitt I was very suprissed to have someone say that reply above quote is rude.  
Maybe 10 years ago this might have had some traction but now it is a business reality in most  
sectors of buisness (IT being a possible exception). Times have changed and people use the  
different forms of email for different reasons and there is a lot to like about reply above quote  
(see above).   
  
I like kde because I can configure it to work the way I want without someone dictating to me  
what I should and shouldn't do. This request is simply an extension of that.   
  
I'm quite happy for someone to say they aren't interested in implementing this because they  
don't have a use for it so it isn't going to get done. Don't know if it is so good for someone to  
tell me that they way all of my business associates and I email is rude. Maybe the hoped for  
change in behaviour is a bit too late now and we should just accept that different people work  
in different ways. When you write a letter (snail mail) do you put the date and your address in  
the top right hand corner with the correct punctuation just like they tought you in school 25  
years ago (if you are that old). If you didn't write a letter in this way guess what..... it was rude.  
Nowadays it doesn't seem to matter. Maybe the same thing has happened to email.  
  
If people are worried about loosing the body of the email beacuse the reply and the signature  
are at the top of the email and someones bot will delete it then simply change the signature  
separator. I think this is currently configurable in kmail anyway.  
  
I would really like to be able to do reply above quote even if it was activated in a very obscure  
way and judging from the above comments I am not the only one who would like to be able to  
do this in kmail.   
  
Looking forward to your response.  
 
Also please not that I am the one that originally requested this feature (David Price) and am 
not the same David that made an entry a day or two ago 
Comment 8 Dave M 2003-07-16 14:10:56 UTC
Agreed.  This is not something that is commonly thought of as poor etiquette 
anymore.  Personally, my reasons for this are the same as the other David's, 
for the most part.  I work for a big company that sends a lot of email back and 
forth.  Now, if I start in-lining my responses Ingo feels is "proper" a lot of 
people are going to be so confused, they'd likely just spontaneously combust, 
heh.  This is not the age of the old BBS and 2400 baud connection, we're 
talking about 100Mbit LANs and broadband internet conenctions.  We don't need 
to worry over every character of text in a reply anymore.  I'm not asking for 
it be made this way only, or even by default, a checkbox or something (__Place 
signature at top of response) that I have to turn on would be great (and 
appreciated).  As with the other David, heh, I also understand if people just 
don't want to do it, but I don't think the fear of being rude should stop 
anyone.

Thanks,

Dave
Comment 9 Ingo Klöcker 2003-07-16 19:13:38 UTC
The signature separator is a quasi-standard which all email clients (maybe except Outlook) 
agree on. So changing it would destroy it's purpose (which is to separate the message body 
from the footer). 
 
IMO the proper way to do full quotes is to attach the replied-to message and not to quote it 
inline in the message below the reply. At least that's how it's done in snail mail. One 
advantage of this is that the recipient can look at the reply and the replied-to message at the 
same time (in two windows). 
Comment 10 Matej Cepl 2003-11-26 19:07:29 UTC
I know that top-replying is the most hated thing on the face of the Earth, when done in email lists, but it is really usefull (and common) in replies to a personal address. Therefore, I vote for it (of course, when it is optional and hopefully automatically switched off for Reply-to-List).

Matej
Comment 11 Jkb 2004-01-01 18:55:52 UTC
Is it possible to add a toggle option in the configuration that says "Put Signature at Top" or "Put Signature at Bottom"?  Then, if people (me included) want their signature placed along with their comments, they can do it, and users who think its rude can keep theirs at the bottom or use forwarded messages as attachments.  Keep the "polite" way as a default, but I would like to have the option to do it.  Even if you guys don't implement this feature, I still think you're doing a heck of a job, so keep up the good work!

Thanks!
Comment 12 Josh Mitts 2004-01-01 19:30:35 UTC
First of all, kudos to you guys for creating an awesome e-mail client that makes Evolution look like Outlook on Windows ;).

I wholeheartedly agree with this request. KMail must allow users to add the signature to the top of the mail. I am a former Outlook user switching to Linux, and find it strange that I can't reply at the top easily (without cutting and pasting my sig).

As previous comments have indicated, adding a configurable option solves the problem for both worlds. Users that have used Outlook or Outlook Express on Windows expect this functionality, and KMail should at least give the user the ability to make this choice.

Keep up the great work! :)
Comment 13 Casey Allen Shobe 2004-01-01 19:47:33 UTC
Subject: Re:  Signature file to be added at top of reply or forwarded mail

Thursday 01 January 2004 13:30
> First of all, kudos to you guys for creating an awesome e-mail client that
> makes Evolution look like Outlook on Windows ;).

Evolution was developed more recently than KMail, and is intended to look and 
feel like Outlook, as that is the audience they want to capture.

> I wholeheartedly agree with this request. KMail must allow users to add the
> signature to the top of the mail. I am a former Outlook user switching to
> Linux, and find it strange that I can't reply at the top easily (without
> cutting and pasting my sig).

Welcome to the world of Microsoft innovations.  Outlook breaks the precedent 
set my every mail client that came before (unless, maybe, Lotus Notes came 
first and had that functionality even back then), by breaking the default 
methods used upon Reply (non-inline quoting, signature at top, etc.).  The 
traditional method is much better, as it keeps E-mail legible and short.  
With the Outlook method, you end up with a few dozen entire messages quoted 
below your own, and it's impossible to tell what part of the previous E-mail 
you're repyling to without reading the entire quoted email first.

Maybe it would be good for KMail to have this option, but it would be very bad 
for anybody to actually use it.

> As previous comments have indicated, adding a configurable option solves
> the problem for both worlds. Users that have used Outlook or Outlook
> Express on Windows expect this functionality, and KMail should at least
> give the user the ability to make this choice.

Outlook users expect a lot of stupid functionality that no other mail client 
has ever implemented or is likely to *ever* implement, as well.

Whether KMail will implement this option or not, I cannot predict.  But I 
thought I'd voice my opinion, anyways.

Comment 14 Matej Cepl 2004-01-01 20:12:35 UTC
> Maybe it would be good for KMail to have this option, but it would be very
> bad for anybody to actually use it.

</flame>

Could you please cool down for a second and re-read comments #7, 8, and 10 (which is mine :-) and try to reply to _them_, please?

Thank you.

Matej
Comment 15 Jkb 2004-01-01 21:02:00 UTC
Maybe the toggle could be worded as "Polite Signature Mode" vs. "Impolite Signature Mode"? ;)  I don't mind this at all if the functionality is added, since I presently have to copy and paste my signature to where I want it, and after a while, it gets old.

Seriously though, I don't feel that I'm being impolite when I leave the original message there on a reply or forward.  It gives the recipient the context to which I'm replying.  I admit it can be a pain in the butt if you get 10 years worth of history, but that's when I go in and trim off all but the last few relevant messages before replying again.

I suppose you could make the case to keep an arguably useful feature out of KMail based on net-etiquitte, but if we've resorted to that, can we make KMail also expand all instances of "How R U?" and "C U L8R" to their intelligent equivalents?  IMO, I think the place for these net-etiquitte problems to be addressed should be in a politely worded message to Miss Manners.  She'll fix things! ;)

Have a good one!
Comment 16 Matej Cepl 2004-01-01 21:06:40 UTC
> Maybe the toggle could be worded as "Polite Signature Mode" vs. "Impolite
> Signature Mode"? ;)

Don't even think, that you would get ever agreement on which is which :-).

Matej
Comment 17 David P James 2004-02-05 20:42:19 UTC
Ingo's comment in #9 would appear to solve this "problem" [created by Outlook, but let's not go there...].

You'd have two options for replying - inline (as present with sig below) and attach original (with the sig above the attachment, naturally). For all intents and purposes it would *look* the same as Outlook and would probably appear that way to Outlook users but to every other sane client out there only your message would be immediately visible. Not only that, there's a good chance that as an attachment it wouldn't come back again and again ad nauseum. The only other thing that kmail would have to do is assign a name of "----- Original Message -----" to the attachment and all should be good.

Of course reply-list should go inline regardless of setting.
Comment 18 Stephan Kulow 2004-05-17 20:41:47 UTC
Replaced dpnsw@optushome.com.au with dave@landlordhat.com due to bounces by reporter
Comment 19 Dave M 2004-05-17 20:46:24 UTC
FYI - The David who reported this is not me (I am dave@landlordhat.com), but I don't mind being the reporter, haha.  :)

--Dave M
Comment 20 Tom Albers 2004-11-16 21:37:04 UTC
*** Bug 89664 has been marked as a duplicate of this bug. ***
Comment 21 Bill Lewis 2005-01-11 23:54:50 UTC
Let me start by saying kudos to the Kmail development team - please keep up the great work!

As for this issue/wishlist, I was greatly hoping this was added in the recent KDE 3.3.2 release.

I use KDE and KMail for my work (and personal) computing.  I am all for adhering to standards (incidentally is this one), however, I believe this has become more an issue of semantics/culture.

I am a consultant/developer for numerous small and medium businesses, many of which have taken the initiative to consider Linux as a viable option for workstations over the rising costs of Windows/MSOffice.  I have already converted many servers to Linux, the workstations seem to be the next obvious evolutional step for some.  I truly believe that the great advances made by software such as OpenOffice, Mozilla, KDE/KMail, et al. have made this become more of a reality today for the business community than past years.

The number one thing I recommend to my clients that are looking to move in this direction is to start by using OpenOffice and other Open Source software such as Firefox and Thunderbird on there Windows PC - to become comfortable with the different applications they will use daily.  The first question I always get when users switch to Thunderbird is - "How do I fix my reply text and signature so they are not at the bottom of the message?"  Every time, every client that switches.

The main reason is speed - plain and simple, it takes too long (and is annoying) to scoll to the bottom of the message to reply, or read a reply.  I often hear "Time is Money" and believe it or not, this simple feature is one that could be a "show stopper", because the business culture prefers (and now demands) the other.  Thankfully, Thunderbird has this feature built-in so that the reply and signature can be postioned to the top of the reply so this doesn't become an issue.

However, I believe (and prefer) that KMail together with Kontact is a more complete package.  Ironically, isn't the birth of Kontact nothing more than an answer to the "Outlook-Style" of combining things like email, tasks, schedules, et al., which I think is a welcome addition and makes some barriers-for-entry easier to overcome.

Unfortuantely, when I forget to move my signature, or reposition my cursor prior to replying, I am often faced with client's compaining about the messages I send them being difficult to read.

I, as well as what appears to be many others, feel that adding this simple feature would be a welcome addition to KMail.
Comment 22 Dave M 2005-03-01 05:02:42 UTC
Has anything changed on the official stance for this?  Any hope?  As previously mentioned, sometimes it comes down to culture and consistancy.  Do I adhear to "correctness" or write emails my boss (or family or whoever) can understand?  That's why I think it would be good as an option...

Thanks,

Dave M
Comment 23 Keith J Kruepke 2005-03-01 06:38:11 UTC
I would just like to add that I have the same concerns and generally follow the email conventions that our most of our company and customers use.  I know that there are people out there who need the signature at the very bottom of the message while others (like me) need it above the quoted text.  I would like to see this configurable along with the signature.  I would also like to see "Insert Signature" on the menu along with "Append Signature", so the signature could go where the cursor is currently locate.  (I would not expect the append option to put the signature above the quoted text after the fact, which would require Kmail to track the boundary of the quoted text.)
Comment 24 Carsten Burghardt 2005-04-16 15:31:08 UTC
*** Bug 103956 has been marked as a duplicate of this bug. ***
Comment 25 Christian Pageau 2005-07-06 18:04:11 UTC
I think it's a little bit ridiculus that 4 years later asking this option it's not yet available. It's not complicated to add choice tu put Signature at top of reply , most of e-mail software have this and everybody is free to choose how use e-mail. I really appriciate Kmail because have more functionality versus Mozilla Thunderbird but at least thunderbird allow to put signature at top. I have to do a cut and paste for each reply or forward, what a lot of waste of time!

Thanks you very much for your help, I think it will be very appriciated.
Comment 26 Jan de Visser 2005-07-06 19:16:15 UTC
> It's not complicated to add choice tu (sic) put Signature at top of reply

So where's your patch?

Point being: This is free software. It's written by people that "have an itch to scratch". The itch of the people maintaining kmail is not the ability to put the signature up top, therefore I can assure you that just whining about it is not going to bring you this option. Submitting a patch will.
Comment 27 Christian Pageau 2005-07-06 20:07:52 UTC
First, sorry of my english, I'm a french speaker. I know that whining is not the solution. Unfortunatly I can't submit patch because I'm not a programmer. I said that not complicated but I've to be more specific, that easy to do by someone that already know how source code is working. I'm just a little bit disapointed that nobody working on project want to work on that since 4 years and a half.
Comment 28 Edwin Schepers 2005-07-06 23:36:21 UTC
Don't think noone is trying to implement such features. I once made a patch, but didn't have the time to fully test it and finalize the patch. From what I remember, things got tricky when changing identity. In that case, the signature changes also.
For me, I have now more important things to program. Maybe some time in the future...
Comment 29 Edwin Schepers 2005-07-06 23:37:46 UTC
Created attachment 11699 [details]
old unfinished patch
Comment 30 Andreas Gungl 2005-08-30 14:23:16 UTC
*** Bug 111764 has been marked as a duplicate of this bug. ***
Comment 31 Heath Holcomb 2006-02-05 18:12:11 UTC
Funny, I thought this was KDE not Gnome.  
Users are not idiots, we just want this option (of were the signature is placed in a replay).
Comment 32 Juha Tuomala 2006-02-05 18:20:29 UTC
Top posting sucks. :)
http://www.google.com/search?hl=en&ie=ISO-8859-1&q=top+posting&btnG=Google+Search
Comment 33 Heath Holcomb 2006-04-14 22:50:08 UTC
Nice Juha.

Anyway, as of KDE 3.5.2 (Kmail 1.9.1) this feature has not been added.

I'll open a new freature/bug request, unless someone can tell me if this request is still alive.  If this tread is dead, than I'll assume that it is being ignored.
Comment 34 David P James 2006-04-14 23:47:57 UTC
This is not, despite the appearances, a thread. At any rate, if you open a new wishlist bug it'll simply end up being duped back against this one, just as bug 111764 was and the other similar bugs have been. Nor will opening a new bug make it any more "alive" than this one.

On a side note, I've seen a couple of comments in this bug and others requesting this in the case of forwards. Huh? If you forward a message properly, i.e. as an attachment, the signature gets placed ahead of the attachment (and therefore the forwarded message). I don't even know why KMail offers inline forwarding...
Comment 35 Matej Cepl 2006-04-15 03:43:15 UTC
to the comment #34:
because some unnamed MUAs (beginning with O :-)) have pretty nasty way how to view attached messages -- just bunch of icons and you have to click on each one of them. Is it still true for the last versions?
Comment 36 Keith J Kruepke 2006-04-15 04:01:40 UTC
Just what wee need...another person telling us that anyone who uses email a different way than him is doing it wrong...  Thanks, David, that is very helpful!
Comment 37 Magnus Holmgren 2006-04-18 11:22:32 UTC
Oh, it's a thread alright. The mails sent out by the bugtracker has In-Reply-To fields in them.

Anyway, while there may be legitimate uses for Outlook-style top-posting, I feel the greatest dangers are these:

1) Users tend to hit reply and just leave the fullquote out of sight below without thinking. This leads to a huge pile of text building up, very often for no reason, as all recipients already have the preceding conversation in their mailboxes. This wastes storage space and bandwidth, but more importantly (space and bandwidth are cheap), it takes bloody ages to space through my list mail!

2) When you need to reply inline to make your reasoning clear, it's near impossible if you need more than one level of quoted text. Further, if the next person fails to decide not to top-post, you get a real mess.

Therefore I believe that a) top-posting should definitely not be the default, and b) it should only be available as a special Reply or Reply to All command.

Besides, why is the signature that important? Does it contain an utterly meaningless disclaimer?

What about a "Forward Thread" feature, which creates a reply with all ancestors attached? That ought to be the best way to introduce a new person into a discussion.
Comment 38 trevor 2006-05-03 00:52:21 UTC
I hope to bring some conclusive light to this wish.

It's not about semantics. It's about user preference and frequency of annoyance. To whit:

1. The user preference argument: 

The conventions of Usenet and proper threading/quoting are GREAT for US but LOUSY for "real world". By far and away, the dominant convention of business and everyday interaction is to place replies and signatures ABOVE preceeding conversation, period. 

This exists as stated POLICY in many organizations and this is set by public relations or general counsel or some other heavy hitter that does not discuss, but dictates such things.

So no ammount of pontification will resolve this: we cannot expect the world to change for one email client (no matter how fantastic it obviously is :) 

2. The frequency argument:

This annoyance happens every single day with every single email reply. That's what turn a small thing into the big deal it's been for years.

Therefore, as Kmail moves more into the user realm (as opposed to the developer realm) this request will never, ever end. It will never go away. And as other clients provide for this annoyance, users will start to say "I like Kmail BUT".

Attaching quoted text is an even worse solution. It is the worst solution. With this, users are forced to track threads between documents. It's not practical at all.

Developers of Kmail! Please reconsider your position in this matter! 
Comment 39 thematrix9000 2006-05-15 20:23:21 UTC
I have used KMail for over 1 year, but I need to have a signature at the top for legal and support reasons for my company. Until this feature is implemented, I will need to use a different mail program.
Comment 40 Daniel H. Neilson 2006-10-13 15:32:43 UTC
There is a simple workaround for those who still want this feature. You can add your signature to the 'Reply to sender' phrase on the 'Phrases' tab of the 'Composer' section of the kmail config.

For example, you could set the phrase to 

--%LYour name%LYour title%Lyou@yourcompany.com%L%LOn %D, you wrote:%L

which approximates the desired behavior. To my knowledge, there is no placeholder for your e-mail address, thus this does have the limitation that you cannot automatically vary your signature with your personality.
Comment 41 Aaron Kunkle 2006-10-16 19:28:04 UTC
These days I think you'll find that the majority of the world people reply to an email by top posting so that the most recent context of the conversion is directly below their reply. Whether you're talking about the business world or a casual personal email, most people don't care (or even know) about the "netiquette" rules of yesteryear.  We're not talking about usenet here... it's email.  Saying that the most common way of using email is "rude" only serves to make you sound dated and arrogant.

So, yes, we need this feature. A simple checkbox somewhere (next the signature setup for your identity?) to choose between signature-at-top or signature-at-bottom will solve this problem and we can move on to more important things... like answering emails.
Comment 42 Pradeepto K. Bhattacharya 2006-11-02 11:52:46 UTC
This wish has been implemented in work/kdepim-3.5.5+ branch - which basically is KDE PIM 3.5.5 + loads of fixes and new features.

So please take time to test the following new features -
 * Append Signature ( Edit Menu item in Composer Window )
 * Prepend Signature ( Edit Menu item in Composer Window )
 * Insert Signature at cursor position ( Edit Menu item in Composer Window )

The more this is tested more are the chances of seeing this feature in the future releases ( read as 3.5.6/7/8 ).
Comment 43 Bram Schoenmakers 2007-03-09 19:03:37 UTC
272 votes and no one on the CC list cared to test it and give feedback? What a shame.
Comment 44 Maciej Pilichowski 2007-09-30 09:26:13 UTC
I don't think adding special features for this is a good solution, but rather adding option in Settings. For me current placement of sig in reply is ok, but in forwarding not -- the mail after sending looks like I wrote all the text, which is not true. And I don't want to change placement each time I forward mail -- I would like to change it once and for good.
Comment 45 Scott 2007-10-30 23:14:01 UTC
Created attachment 21955 [details]
kmail-tofu.patch

I'm still surprised that the only attempt to add this tiny option that would
improve kmail for a world of people was in the kdepim-3.5.5+ branch, which now
appears dead.  However with the work that they did I was able to construct a
patch that adds the desired feature and more.  Now, you can prepend or append
(append by default) your signature to all emails, switching signatures doesn't
affect placement _even after text is written_, the -- prepend is optional,
everything is clean and consistent in the UI and there are only an additional
two options.  I hope a developer will read this bug over (though I'm also
creating a new one) as there are many well thought out reasons as to why this
won't signal the downfall of the internet.  I also wrote more in a gentoo forum
post and a gentoo bug that was promptly wontfixed:

http://forums.gentoo.org/viewtopic-p-4438034.html

http://bugs.gentoo.org/show_bug.cgi?id=197535
Comment 46 Keith J Kruepke 2007-10-30 23:29:39 UTC
This feature exists in KMail as distributed with Kubuntu 7.10 (Gutsy Gibbon). I am not sure if that change was specifically folded into the Kubuntu package for KMail, or if it is part of the general release of KMail.

Version details, as reported by KMail:

- KMail 1.9.6 (enterprise 0.20070907.709405)
- KDE 3.5.8

Does anyone else have this option now on their systems?
Comment 47 Thomas McGuire 2007-10-30 23:40:44 UTC
Right, the feature is in the enterprise branch already, though not yet in trunk. So the feature only needs porting to trunk.


The enterprise branch will probably be merged back to the 3.5 branch eventually.
Comment 48 Thomas McGuire 2007-10-30 23:43:23 UTC
Oh, and maybe the new patch has improvements over what is in the enterprise branch, so those would need to be merged into trunk and enterprise branch as well.

A patch for trunk doing all the merging would be very welcome (It could only be applied after the KDE 4.0 feature freeze is over, but at least it will not get lost like patches for the 3.5 branch do)
Comment 49 Thomas McGuire 2007-10-30 23:46:33 UTC
*** Bug 151585 has been marked as a duplicate of this bug. ***
Comment 50 Kiran Reddy 2007-10-31 04:44:04 UTC
I could acheive this by using templates that are available in kmail.

Just need to put %CURSOR on first like under the reply and reply-all and forward templates.

Comment 51 Scott 2007-10-31 07:14:21 UTC
Created attachment 21958 [details]
enterprise-tofu.patch

molded kmail tofu patch to patch against the enterprise branch (rev 729661) and
fit in with small changes, updated the clear spaces function to hopefully
(untested) work around a signature that's placed anywhere in the email, and
discovered a bug in the prepend -- to sig option that I haven't corrected yet.

As for the branch...we're talking about
http://websvn.kde.org/branches/kdepim/enterprise/kdepim/ right?  Sorry, you're
going to have to bear with me as I'm very new to coding/svn/etc.  Furthermore,
should I roll a patch for KDE 4.0?  And if so, what svn branch should I take
that from?  Thank you for your time and quick response, Thomas.
Comment 52 Scott 2007-11-01 06:14:40 UTC
Created attachment 21966 [details]
kmail-tofu.patch

corrects the prepend -- option bug in the last patch; the fix required more
changes than I wanted to make (libkpimidentities/identity.{h,cpp}, mainly
changed to signatureText and withSeparator), but it looks pretty clean and
doesn't appear to interrupt anything.  Tested without crashes and with desired
results thus far.  

Note on signatureText() -> called without anything will return the exact same
data as before, but now can have true or false passed referring to the --
config option.

To re-clarify, this patches against kdepim 3.5.8, enterprise trunk patch up
next.
Comment 53 Scott 2007-11-01 06:17:16 UTC
Created attachment 21967 [details]
enterprise-tofu.patch

see last post.	Patches against same SVN revision as the obsolete version.
Comment 54 Scott 2007-11-01 19:17:53 UTC
Created attachment 21974 [details]
kmail-tofu.patch

oops, small logic and reference errors.  I must have been half asleep.
Comment 55 Scott 2007-11-01 19:18:28 UTC
Created attachment 21975 [details]
enterprise-tofu.patch

see above
Comment 56 Scott 2007-11-07 23:42:20 UTC
Created attachment 22013 [details]
trunk-tofu.patch

Ok, I finally modified my patch to patch against trunk.  Let me know if there
are any problems and I'll get them fixed up.
Comment 57 Scott 2007-11-13 18:09:24 UTC
Created attachment 22048 [details]
trunk-tofu.patch

Finally a new patch update!  Tested against svn revision 736182.  I fixed a few
extra bugs on the way:
1) clean spaces didn't delete original text, just inserted new text
2) clean spaces required two undos to get to previous text (now only one)
3) clean spaces didn't respect sig text for the profile initially used in a
compose window

At this point my biggest concern is implementation; with prepending rather than
appending we don't know where the signature is anymore, so we have to guess; if
the user edits the signature in the email or writes a new one above it (what if
they have a really simple signature, like their name, and don't add the -- ?),
we'll guess wrong (mainly when switching identities) and it will be perceived
as an interface problem.

I think this is a generally good implementation and the wrong guess cases
should be very rare, but I'm going to continue to think about it and do some
experimentation.

The best option may be to add %SIGNATURE as a template option and that I'm
going to look into, but not in this patch.
Comment 58 Thomas McGuire 2008-01-02 19:21:45 UTC
*** Bug 93953 has been marked as a duplicate of this bug. ***
Comment 59 Thomas McGuire 2008-03-02 22:54:07 UTC
SVN commit 781456 by tmcguire:

Finally port the following:

- Make it possible to manually insert the signature at the start
  or at the cursor position
- Make it possible to automatically prepend instead of appending
  the signature
- Make it possible to disable the signature separator

Based on patch by Scott <firebrnr at gmail dot com>, many thanks!

FEATURE: 16480



 M  +25 -0     configuredialog.cpp  
 M  +2 -0      configuredialog_p.h  
 M  +9 -1      kmail.kcfg  
 M  +4 -1      kmcomposerui.rc  
 M  +21 -7     kmcomposewin.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=781456
Comment 60 Jkb 2008-03-16 05:29:20 UTC
It works beautifully!  Thanks for adding this feature!