Bug 164772 - Kwrite crashed when pasting text while opening file
Summary: Kwrite crashed when pasting text while opening file
Status: RESOLVED DUPLICATE of bug 200858
Alias: None
Product: kate
Classification: Unclassified
Component: kwrite (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-23 19:27 UTC by Oliver Putz
Modified: 2010-01-20 17:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Putz 2008-06-23 19:27:51 UTC
Version:           4.00.82 (KDE 4.0.82 >= 20080610) "release 3.5" (using 4.00.82 (KDE 4.0.82 >= 20080610) "release 3.5", compiled sources)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25.5-1.1-default

I tried to reproduce bug #157737. Therefore I opened a textfile on sftp://localhost via konqueror in kwrite. While the file was still loading, I typed some text into the file (and tried to save it). The result was the following crash:

Application: KWrite (kwrite), signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[New Thread 0xb65cf6d0 (LWP 3165)]
[KCrash handler]
#6  QString::operator= (this=0x82e0924, other=@0x4) at tools/qstring.cpp:1101
#7  0xb6de64a2 in QTextLayout::setText (this=0x81f20d0, string=@0x4)
    at text/qtextlayout.cpp:425
#8  0xb4d50217 in KateRenderer::layoutLine (this=0x814cc70, lineLayout=
      {d = 0xbf89dfc8}, maxwidth=671, cacheLayout=true)
    at /usr/src/debug/kdelibs-4.0.82/kate/render/katerenderer.cpp:746
#9  0xb4d55a4c in KateLayoutCache::line (this=0x80a7990, realLine=2, 
    virtualLine=2)
    at /usr/src/debug/kdelibs-4.0.82/kate/render/katelayoutcache.cpp:167
#10 0xb4d567b0 in KateLayoutCache::updateViewCache (this=0x80a7990, 
    startPos=@0x8150964, newViewLineCount=26, viewLinesScrolled=0)
    at /usr/src/debug/kdelibs-4.0.82/kate/render/katelayoutcache.cpp:151
#11 0xb4da3376 in KateViewInternal::doUpdateView (this=0x8150878, 
    changed=true, viewLinesScrolled=0)
    at /usr/src/debug/kdelibs-4.0.82/kate/view/kateviewinternal.cpp:563
#12 0xb4da3c25 in KateViewInternal::updateView (this=0x8150878, 
    changed=<value optimized out>, viewLinesScrolled=0)
    at /usr/src/debug/kdelibs-4.0.82/kate/view/kateviewinternal.cpp:542
#13 0xb4d8ab08 in KateView::updateView (this=0x814dbb8, 
    changed=<value optimized out>)
    at /usr/src/debug/kdelibs-4.0.82/kate/view/kateview.cpp:1385
#14 0xb4d11dc4 in KateDocument::tagAll (this=0x80d23c8)
    at /usr/src/debug/kdelibs-4.0.82/kate/document/katedocument.cpp:4972
#15 0xb4d11eca in KateDocument::updateConfig (this=0x80d23c8)
    at /usr/src/debug/kdelibs-4.0.82/kate/document/katedocument.cpp:5402
#16 0xb4dca74c in KateDocumentConfig::updateConfig (this=0xb7742430)
    at /usr/src/debug/kdelibs-4.0.82/kate/utils/kateconfig.cpp:221
#17 0xb4dc8a6c in KateConfig::configEnd (this=0xb7742430)
    at /usr/src/debug/kdelibs-4.0.82/kate/utils/kateconfig.cpp:77
#18 0xb4d2d966 in KateDocument::readVariables (this=0x80d23c8, 
    onlyViewAndRenderer=false)
    at /usr/src/debug/kdelibs-4.0.82/kate/document/katedocument.cpp:5454
#19 0xb4d30611 in KateDocument::openFile (this=0x80d23c8)
    at /usr/src/debug/kdelibs-4.0.82/kate/document/katedocument.cpp:3400
#20 0xb8033a4e in KParts::ReadOnlyPartPrivate::_k_slotJobFinished (
    this=0x80d24f8, job=0x828ab20)
    at /usr/src/debug/kdelibs-4.0.82/kparts/part.cpp:636
#21 0xb8033caa in KParts::ReadOnlyPart::qt_metacall (this=0x80d23c8, 
    _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbf89e77c)
    at /usr/src/debug/kdelibs-4.0.82/build/kparts/part.moc:162
#22 0xb8033d9a in KParts::ReadWritePart::qt_metacall (this=0x80d23c8, 
    _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbf89e77c)
    at /usr/src/debug/kdelibs-4.0.82/build/kparts/part.moc:268
#23 0xb800645a in KTextEditor::Document::qt_metacall (this=0x80d23c8, 
    _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbf89e77c)
    at /usr/src/debug/kdelibs-4.0.82/build/interfaces/ktexteditor/document.moc:86
#24 0xb4d1e42a in KateDocument::qt_metacall (this=0x80d23c8, 
    _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbf89e77c)
    at /usr/src/debug/kdelibs-4.0.82/build/kate/katedocument.moc:231
#25 0xb76b73fa in QMetaObject::activate (sender=0x828ab20, 
    from_signal_index=7, to_signal_index=7, argv=0xbf89e77c)
    at kernel/qobject.cpp:3007
#26 0xb76b7972 in QMetaObject::activate (sender=0x828ab20, m=0xb799e528, 
    local_signal_index=3, argv=0xbf89e77c) at kernel/qobject.cpp:3080
#27 0xb787e533 in KJob::result (this=0x828ab20, _t1=0x828ab20)
    at /usr/src/debug/kdelibs-4.0.82/build/kdecore/kjob.moc:186
#28 0xb787e9d2 in KJob::emitResult (this=0x828ab20)
    at /usr/src/debug/kdelibs-4.0.82/kdecore/jobs/kjob.cpp:290
#29 0xb7e83280 in KIO::FileCopyJob::slotResult (this=0x828ab20, job=0x814c648)
    at /usr/src/debug/kdelibs-4.0.82/kio/kio/job.cpp:2184
#30 0xb7e839ff in KIO::FileCopyJob::qt_metacall (this=0x828ab20, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf89e8cc)
    at /usr/src/debug/kdelibs-4.0.82/build/kio/jobclasses.moc:658
#31 0xb76b73fa in QMetaObject::activate (sender=0x814c648, 
    from_signal_index=7, to_signal_index=7, argv=0xbf89e8cc)
    at kernel/qobject.cpp:3007
#32 0xb76b7972 in QMetaObject::activate (sender=0x814c648, m=0xb799e528, 
    local_signal_index=3, argv=0xbf89e8cc) at kernel/qobject.cpp:3080
#33 0xb787e533 in KJob::result (this=0x814c648, _t1=0x814c648)
    at /usr/src/debug/kdelibs-4.0.82/build/kdecore/kjob.moc:186
#34 0xb787e9d2 in KJob::emitResult (this=0x814c648)
    at /usr/src/debug/kdelibs-4.0.82/kdecore/jobs/kjob.cpp:290
#35 0xb7e7a44f in KIO::SimpleJob::slotFinished (this=0x814c648)
    at /usr/src/debug/kdelibs-4.0.82/kio/kio/job.cpp:491
#36 0xb7e780a3 in KIO::SimpleJob::qt_metacall (this=0x814c648, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf89ea48)
    at /usr/src/debug/kdelibs-4.0.82/build/kio/jobclasses.moc:156
#37 0xb7e7810a in KIO::DirectCopyJob::qt_metacall (this=0x814c648, 
    _c=QMetaObject::InvokeMetaMethod, _id=32, _a=0xbf89ea48)
    at /usr/src/debug/kdelibs-4.0.82/build/kio/job_p.moc:142
#38 0xb76b73fa in QMetaObject::activate (sender=0x82906d0, 
    from_signal_index=8, to_signal_index=8, argv=0x0)
    at kernel/qobject.cpp:3007
#39 0xb76b7972 in QMetaObject::activate (sender=0x82906d0, m=0xb7fe7644, 
    local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3080
#40 0xb7f24987 in KIO::SlaveInterface::finished (this=0x82906d0)
    at /usr/src/debug/kdelibs-4.0.82/build/kio/slaveinterface.moc:161
#41 0xb7f2749f in KIO::SlaveInterface::dispatch (this=0x82906d0, _cmd=104, 
    rawdata=@0xbf89ebe4)
    at /usr/src/debug/kdelibs-4.0.82/kio/kio/slaveinterface.cpp:175
#42 0xb7f25227 in KIO::SlaveInterface::dispatch (this=0x82906d0)
    at /usr/src/debug/kdelibs-4.0.82/kio/kio/slaveinterface.cpp:90
#43 0xb7f17e50 in KIO::Slave::gotInput (this=0x82906d0)
    at /usr/src/debug/kdelibs-4.0.82/kio/kio/slave.cpp:319
#44 0xb7f181c3 in KIO::Slave::qt_metacall (this=0x82906d0, 
    _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbf89ecd8)
    at /usr/src/debug/kdelibs-4.0.82/build/kio/slave.moc:75
#45 0xb76b73fa in QMetaObject::activate (sender=0x81cf990, 
    from_signal_index=4, to_signal_index=4, argv=0x0)
    at kernel/qobject.cpp:3007
#46 0xb76b7972 in QMetaObject::activate (sender=0x81cf990, m=0xb7fe4300, 
    local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3080
#47 0xb7e4a0f7 in KIO::Connection::readyRead (this=0x81cf990)
    at /usr/src/debug/kdelibs-4.0.82/build/kio/connection.moc:84
#48 0xb7e4bb32 in KIO::ConnectionPrivate::dequeue (this=0x82c2810)
    at /usr/src/debug/kdelibs-4.0.82/kio/kio/connection.cpp:82
#49 0xb7e4c186 in KIO::Connection::qt_metacall (this=0x81cf990, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x819c310)
    at /usr/src/debug/kdelibs-4.0.82/build/kio/connection.moc:72
#50 0xb76b233b in QMetaCallEvent::placeMetaCall (this=0x82f6448, 
    object=0x81cf990) at kernel/qobject.cpp:535
#51 0xb76b3ed1 in QObject::event (this=0x81cf990, e=0x82f6448)
    at kernel/qobject.cpp:1137
#52 0xb6c07ecc in QApplicationPrivate::notify_helper (this=0x805a730, 
    receiver=0x81cf990, e=0x82f6448) at kernel/qapplication.cpp:3772
#53 0xb6c0e31e in QApplication::notify (this=0xbf89f648, receiver=0x81cf990, 
    e=0x82f6448) at kernel/qapplication.cpp:3366
#54 0xb7c4e09d in KApplication::notify (this=0xbf89f648, receiver=0x81cf990, 
    event=0x82f6448)
    at /usr/src/debug/kdelibs-4.0.82/kdeui/kernel/kapplication.cpp:311
#55 0xb76a5b51 in QCoreApplication::notifyInternal (this=0xbf89f648, 
    receiver=0x81cf990, event=0x82f6448) at kernel/qcoreapplication.cpp:583
#56 0xb76a6411 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, 
    event_type=0, data=0x804b870) at kernel/qcoreapplication.h:215
#57 0xb76a65ad in QCoreApplication::sendPostedEvents (receiver=0x0, 
    event_type=0) at kernel/qcoreapplication.cpp:1091
#58 0xb6c9200f in QEventDispatcherX11::processEvents (this=0x805a678, flags=
      {i = -1081478040})
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#59 0xb76a42ca in QEventLoop::processEvents (this=0xbf89f4d0, flags=
      {i = -1081477976}) at kernel/qeventloop.cpp:149
#60 0xb76a448a in QEventLoop::exec (this=0xbf89f4d0, flags={i = -1081477928})
    at kernel/qeventloop.cpp:196
#61 0xb76a666d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#62 0xb6c07d47 in QApplication::exec () at kernel/qapplication.cpp:3304
#63 0xb8061b1b in kdemain (argc=2, argv=0xbf89fa14)
    at /usr/src/debug/kdebase-4.0.82/apps/kwrite/kwritemain.cpp:781
#64 0x080487a2 in main (argc=)
    at /usr/src/debug/kdebase-4.0.82/build/apps/kwrite/kwrite_dummy.cpp:3
#0  0xffffe422 in __kernel_vsyscall ()
Comment 1 auxsvr 2008-11-21 22:48:44 UTC
This just occurred here, in KDE 4.1.3.
Comment 2 Dominik Haumann 2009-06-04 18:15:36 UTC
Can you please test again with KDE4.2 or even better upcoming KDE 4.3 / trunk?
There were quite some fixes with regard to the layout cache. So maybe it's fixed...
Comment 3 Milian Wolff 2010-01-20 17:17:34 UTC
marking as duplicate, please reopen if you can reproduce with KDE 4.4

*** This bug has been marked as a duplicate of bug 200858 ***