Bug 164656 - Desktop settings completely messed up when restarting session
Summary: Desktop settings completely messed up when restarting session
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Sauer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-22 12:06 UTC by Frederik Himpe
Modified: 2008-07-21 16:10 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Himpe 2008-06-22 12:06:14 UTC
Version:           4.0.83 (using Devel)
Installed from:    Compiled sources
OS:                Linux

It seems almost every time I log in, lots of desktop settings are lost: The application launcher and show desktop plasmoid in my panel are gone, the panel shows black text on black background (which can be fixed by reconfiguing the plasma theme), often there are two panels of different sizes behind each other, there are weird empty spaces in the system tray notification area (very probably some notification icons being invisible),...

A screenshot of the black text on black panel and spaces in the system tray can be seen here:
http://artipc10.vub.ac.be/serendipity/uploads/screenshots/kde4.1/kde4-desktop.jpg
Comment 1 FiNeX 2008-06-22 15:44:16 UTC
when you do the logout, does plasma crash?
Comment 2 Adam Pigg 2008-06-23 13:16:03 UTC
I noticed that plasma would crash on logout if i removed the dolphin and systemsettings buttons, changing other settings like the size and start menu type, and leaving the buttons meant it didnt crash and the settings were saved.
Comment 3 Frederik Himpe 2008-06-23 14:54:30 UTC
Plasma is crashing for me because of bug #164653 which has been fixed in svn now. Even then, what if I press Ctrl-Alt-Backspace, will I then also loose all changes I have made during that session? I would expect settings to be saved as soon as I make them and not only at a proper logout.
Comment 4 Sebastian Sauer 2008-06-23 15:34:07 UTC
Frederik:
iirc if there was a change done that needs to be saved, plasma will do so some minutes later (to prevent writes e.g. each 10 seconds if someone does e.g. rearrange it's plasmoids). So, if you do Ctrl-Alt-Backspace you may lose changes (as in e.g. changed settings for plasmoids) done in the last few minutes only.
re systemtray; probably also already fixed but I am not sure there since it seems the systemtray has more bugs and problems then lines-of-code :-/
re 2 panels && black text on black background; seems I am not able to reproduce this :-/

Adam:
yo, hi! :-) and hmmm... what does "dolphin and systemsettings buttons" mean in that context? icons on the desktop? icons on the panel? icons in the folderview? icons in the favorite-tab in kickoff? probably a separate bugreport or how is this related?!
Comment 5 Frederik Himpe 2008-06-24 11:39:03 UTC
I do not think this can all be explained by a lack of saved settings because of a plasma crash: I certainly do not have the habit of changing Plasma settings, and then logging out/crashing Plasma only a few minutes later. Also, I don't think this can explain the black-text-on-black-panel problem, as there is no such theme AFAIK. However, reconfiguring the theme in the Desktop Settings configuration panel, fixes the problem. A lot of people are complaining about this particular problem on Mandriva's Cooker mailing list and IRC channel. Maybe we should concentrate on that particular problem here in this bug report.
Comment 6 Sebastian Sauer 2008-06-24 18:58:02 UTC
Frederik: thanks for the additional info re Mandriva cause Adam is using Mandriva too and now I do understand the context there.
Well, it sounds for me like a distributor aka upstream bug/problem rather then a KDE-one cause it seems only Cooker-users have it... Anyway, this sounds like a good excuse to give Mandriva 2008.1 a try. So, I am downloading it right now :) btw, any special actions I need todo after installation to update to 4.0.83?! and also it seems I still don't got what the diff between "Cooker" and 2008.1 is.
Comment 7 Sebastian Sauer 2008-06-24 19:09:20 UTC
reassign from plasma-devel to me since imho upstream-bugs are not something the other devels could deal with anyway.
Comment 8 Frederik Himpe 2008-06-24 19:15:54 UTC
2008.1 is the previous stable version, cooker is the current development tree (compare with Fedora Rawhide or OpenSuse Factory).

to upgrade from 2008.1 to Cooker with kde 4:

# urpmi.removemedia -a
# urpmi.addmedia --distrib --mirrorlist 'http://api.mandriva.com/mirrors/basic.cooker.$ARCH.list'
# urpmi task-kde4
Comment 9 Frederik Himpe 2008-06-24 19:16:42 UTC
I forgot one command, before running urpmi task-kde4, run
# urpmi --auto-select
to bring everything up to date.
Comment 10 Sebastian Sauer 2008-06-24 20:18:51 UTC
*** Bug 164786 has been marked as a duplicate of this bug. ***
Comment 11 Aaron J. Seigo 2008-06-24 23:27:30 UTC
Frederik: did you perhaps run Amarok2? if so, that bug was fixed just a few days ago in trunk.
Comment 12 Frederik Himpe 2008-06-24 23:44:17 UTC
Oh yes, Amarok was active in the system tray.
Comment 13 Sebastian Sauer 2008-06-24 23:57:29 UTC
uh, *huge* thanks to Aaron for that hint! Yay, now the remaining question is, if the systray-issue named here too ( and at bug #164786 ) is independend of this?

p.s. I am still on "urpmi task-kde4" and so far the Mandriva KDE3-default feels really great. Will be interesting to see what KDE4+powerpack does provide :)
Comment 14 Sebastian Sauer 2008-07-21 16:10:26 UTC
oh, seems the report was still open. So, let's mark it as fixed then :) Thanks frederik, aaron, finex and rex :)