Bug 164498 - cannot open shared folders with non-english characters via smb:/
Summary: cannot open shared folders with non-english characters via smb:/
Status: RESOLVED DUPLICATE of bug 158639
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: smb (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-20 09:29 UTC by Viesturs Zarins
Modified: 2008-06-25 10:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Viesturs Zarins 2008-06-20 09:29:57 UTC
Version:            (using Devel)
Installed from:    Compiled sources
OS:                Linux

Tested from Ubuntu 4.0.80, and kde4daily.

SMB slave has some bugs with non english characters.

Steps to reproduce:
Open a smb share via Dolphin, say smb:/host/
In this share, i have a folder, called "Adīvie" (Latvian locale).
Upon opening, i get an error popup from dolphin, saying "File noes not exist smb:/host/Ad%C4%ABvie".
But in the file list, the folder is shown with the correct name, but has some sort of 'access denied' icon.

Clicking on it I get another error "File or folder smb:/host/Adīvie does not exsist". (note it has the coding now).

Manually entering "smb:/host/Adīvie" in the url bar, it automatically is converted to "smb:/host/Ad%C4%ABvie" and I get "Unknown error in stat: Unknown error 8127".
Then I switched back to the breadcrumbs mode, and the url was displayed as "smb:/host/Adīvie".


At the same time i can freely browse this folder using Dolphon from KDE3. And it always shows the correctly encoded folder name in the URL bar (both in breadcrumbs and URL mode).
Comment 1 Pino Toscano 2008-06-25 10:12:36 UTC

*** This bug has been marked as a duplicate of 158639 ***