Bug 164387 - plasma crashes on startup
Summary: plasma crashes on startup
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 164445 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-18 16:31 UTC by Maciej Pilichowski
Modified: 2008-06-21 21:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Pilichowski 2008-06-18 16:31:06 UTC
Version:            (using KDE 4.0.82)
Installed from:    Ubuntu Packages

plasma crashes on startup 

From yestarday to today there was no update for KDE4Daily so there is nothing new. AFAIR I only started Kate so at startup Kate is restored, as well as Konqueror. There should be a dolphin as well, but the third app is KDE crash handler.

Application: Plasma Workspace (plasma), signal SIGFPE
[Thread debugging using libthread_db enabled]
[New Thread 0xb5724940 (LWP 4665)]
[New Thread 0xb331cb90 (LWP 4667)]
[New Thread 0xb3f58b90 (LWP 4666)]
[KCrash handler]
#6  0xb401f346 in BinaryClock::paintInterface (this=0x8138510, p=0xbfe8b0f8, 
    option=0xbfe8abd8, contentsRect=@0xbfe8a9d8)
    at /home/kde4daily/src/kdeplasmoids/applets/binary-clock/binaryclock.cpp:194
#7  0xb7eb785e in Plasma::Applet::paint (this=0x8138510, painter=0xbfe8b0f8, 
    option=0xbfe8abd8, widget=0x0)
    at /home/kde4daily/src/kdebase/workspace/libs/plasma/applet.cpp:901
#8  0xb648b74c in _q_paintItem ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#9  0xb648c7c4 in QGraphicsScenePrivate::drawItemHelper ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#10 0xb649076d in QGraphicsScene::drawItems ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#11 0xb64a2b2c in QGraphicsView::drawItems ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#12 0xb64a7287 in QGraphicsView::paintEvent ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#13 0xb5f276fe in QWidget::event ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#14 0xb6295048 in QFrame::event ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#15 0xb632c48d in QAbstractScrollArea::viewportEvent ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#16 0xb64a542c in QGraphicsView::viewportEvent ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#17 0xb632ef7a in QAbstractScrollAreaPrivate::viewportEvent ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#18 0xb632efac in QAbstractScrollAreaFilter::eventFilter ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#19 0xb67d3a18 in QCoreApplicationPrivate::sendThroughObjectEventFilters ()
   from /home/kde4daily/install/qt-copy/lib/libQtCore.so.4
#20 0xb5ec97f7 in QApplicationPrivate::notify_helper ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#21 0xb5ecb406 in QApplication::notify ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#22 0xb7093e37 in KApplication::notify (this=0x805a3a0, receiver=0x826f2f0, 
    event=0xbfe8c1fc)
    at /home/kde4daily/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#23 0xb67d568a in QCoreApplication::notifyInternal ()
   from /home/kde4daily/install/qt-copy/lib/libQtCore.so.4
#24 0xb5ed5669 in QCoreApplication::sendSpontaneousEvent ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#25 0xb5f3443a in qt_sendSpontaneousEvent ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#26 0xb5f2e125 in QWidgetPrivate::drawWidget ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#27 0xb5f2e7c4 in QWidgetPrivate::paintSiblingsRecursive ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#28 0xb5f2e453 in QWidgetPrivate::drawWidget ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#29 0xb609ca63 in QWidgetBackingStore::cleanRegion ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#30 0xb609d36f in qt_syncBackingStore ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#31 0xb5f44604 in QETWidget::translateConfigEvent ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#32 0xb5f459a6 in QApplication::x11ProcessEvent ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#33 0xb5f71efd in x11EventSourceDispatch ()
   from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#34 0xb5994bf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#35 0xb5997e5e in ?? () from /usr/lib/libglib-2.0.so.0
#36 0x08062498 in ?? ()
#37 0x00000000 in ?? ()
#0  0xb7fd0402 in __kernel_vsyscall ()
Comment 1 Sebastian Sauer 2008-06-21 04:50:31 UTC
Hi Maciej,

is this reproducable for you or did it happen only once? I did just review the binary clock and fixed a possible crasher with r822676 but the provided backtrace indicates that it crashes on the line
int yPos = ((appletHeight % rectSize) / 2) + contentsRect.topLeft().y();
which is not only unrelated to the possible crasher but I just fail to see why it should crash here (therefore also the question if it happened only once or more then one time and if the last case, I assume each time a similar backtrace?).
Comment 2 Sebastian Sauer 2008-06-21 05:15:21 UTC
eh, sometimes I am blind (well, mostly 5am in the morning ;) ... it's fixed now with r822678. Thansk for the feedback!
Comment 3 Sebastian Sauer 2008-06-21 21:07:13 UTC
*** Bug 164445 has been marked as a duplicate of this bug. ***