Bug 164386 - several regressions from KDE 3.5
Summary: several regressions from KDE 3.5
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-18 16:16 UTC by Adam Spiers
Modified: 2011-08-09 19:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New channel selector (smaller, more standard, more featureful) (47.69 KB, image/png)
2009-05-10 18:24 UTC, Christian Esken
Details
First version of control grouping (44.39 KB, image/png)
2009-05-10 18:27 UTC, Christian Esken
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Spiers 2008-06-18 16:16:27 UTC
Version:            (using KDE 4.0.5)
Installed from:    Fedora RPMs
OS:                Linux

Since I upgraded from KDE 3.5 to 4.0.5, the input/output/switches tabs in kmix have vanished, and consequently a whole load of channels and switches.  Even the master volume slider is missing by default!  (This is true even after stopping kmix, rm ~/.kde/share/config/kmix*, then restart kmix.)  It is interesting to note that despite the tabs missing, the kmix handbook still has screenshots with the input/output/switches tabs in.

I can recover the channels and switches via Settings > Configure Channels, but then they all appear in a single view for each soundcard, which is far too wide.  Additionally there is no way to reorder the channels, so "Master Mono" no longer appears at the far left like it used to in KDE 3.5.

Finally in KDE 3.5 the slider widths used to expand and contract to fit the window width.  Now they are fixed width, which seems to defeat the point of allowing the window width to be changed.

Overall, the combination of these seriously affects the usability of the application.  Are these all intentional changes or accidental regressions?  Thanks...
Comment 1 Christian Esken 2008-06-18 21:54:09 UTC
Comments:
- Master channel should not be missing. Is it probably called "Front" instead? If yes, then this is intentional, as the control that ALSA calls Master is actually NOT a master.
- Handbook was not yet updated. 
- Reordering channels was never possible in KDE3 => no regression
- Reordering channels is possible in KDE4. This is actually new, but undocumented, as it cannot be done via GUI yet. Please see the KDEDIR/share/apps/kmix/profiles/ for an example
- I don't understand the issue with the slider width. In KDE4 the window adjusts to the sliders exactly as in KDE3
Comment 2 Dominik Tritscher 2008-07-19 11:04:50 UTC
I have a similar problem: The master channel seems to be renamed to front to. But now I have to front channels. By comparing 3.5.x and 4.1 versions of kmix I found out that the first front channel is corresponding to the master and the second one was called front channel in 3.5.x too.
This is somewhat confusing too me. Additionally the kmix applet shows the pcm channel instead of the master/front. As the pcm channel does not affect the master volume (driver bug?), the panel applet is currently not usable.
Is there any possibility to get the master channel back and mapped to the kmix applet?
Comment 3 Christian Esken 2008-07-20 23:08:15 UTC
Dominik,

a)use the context menu on the try icon to select a different master.

b)If the PCM control doesn't operate, please test with a different mixer. If it doesn't work there also, file a bug at the soundcard driver (ALSA?) project. If it works, file another bug in bugs.kde.org.

In any case, please post the ouput of "amixer" (or "amixer -c 1" or any other number that corresponds to the affected soundcard) as attachment here.
Comment 4 Adam Spiers 2009-01-20 11:14:52 UTC
Hi Christian, thanks for your replies so far.

(In reply to comment #1)
> Comments:
> - Master channel should not be missing. Is it probably called "Front" instead?
> If yes, then this is intentional, as the control that ALSA calls Master is
> actually NOT a master.

OK thanks; is this explained in detail in some release notes anywhere as I found it quite confusing and would expect others to be confused by it too.

> - Handbook was not yet updated.

I understand that there is often not enough time to update the documentation too - in these cases I would recommend putting a prominent warning at the beginning of the handbook saying that it is out of date.  This would only take a few minutes to do and would eliminate a lot of confusion.
 
> - Reordering channels was never possible in KDE3 => no regression

I didn't actually claim it was possible :-)  Rather that it was not necessary because the channels arguably appeared in a more intuitive order than they do now.

> - Reordering channels is possible in KDE4. This is actually new, but
> undocumented, as it cannot be done via GUI yet. Please see the
> KDEDIR/share/apps/kmix/profiles/ for an example

That's cool; I look forward to seeing it in the GUI!

> - I don't understand the issue with the slider width. In KDE4 the window
> adjusts to the sliders exactly as in KDE3

I'm talking about the _slider_width_ adjusting to the window _width_.  So if you make the window wider, the sliders get fatter.  This allows the user to choose how much spacing there is between each slider.  This is especially important given the regression of the input/output/switches tabs being removed, since for example my NVidia CK804 has no less than 23 vertical "columns" (sliders or switches of various sorts) which even on a 1600x1200 display makes the mixer horribly crowded.  Is there any chance of bring those three tabs back?  It was much nicer this way with a separate dropdown to select which soundcard you are mixing.
Comment 5 Christian Esken 2009-05-10 18:24:05 UTC
Reordering channels will be possible via GUI (drag-n-drop interface), starting with KDE4.4. See screenshot.

About the "input/output/switches" I am undecided about how to do it yet. I am pretty sure it won't be "traditional tabs", but groups "inside" the existinng tab. There are various issues with it still, but the basic concept is done. I'll add a preliminary screenshot with very limited (bad) GUI design.
Comment 6 Christian Esken 2009-05-10 18:24:56 UTC
Created attachment 33522 [details]
New channel selector (smaller, more standard, more featureful)
Comment 7 Christian Esken 2009-05-10 18:27:23 UTC
Created attachment 33523 [details]
First version of control grouping

Very early screenshot. Will also allow to recreate a design, that resembles the traditional (KDE3) "input/output/switches" design.
Comment 8 Christian Esken 2011-08-09 19:35:14 UTC
- Master channel should not be missing. Is it probably called "Front" instead? If yes, then this is intentional, as the control that ALSA calls Master is actually NOT a master.

has been changed back, as it confused too many users.

- Handbook was not yet updated. 

Done

- Reordering channels was never possible in KDE3 => no regression
- Reordering channels is possible in KDE4. This is actually new, but undocumented, as it cannot be done via GUI yet. Please see the KDEDIR/share/apps/kmix/profiles/ for an example

Done

- I don't understand the issue with the slider width. In KDE4 the window adjusts to the sliders exactly as in KDE3

Window sizing has been changed. Hopefully everything is fine. If not,please open a new bug report.