Bug 164317 - Removing task manager from panel messes up layout of plasmoids in panel
Summary: Removing task manager from panel messes up layout of plasmoids in panel
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: panel (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: triaged
: 166737 166738 167278 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-17 18:39 UTC by Elias Probst
Modified: 2010-12-31 15:35 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
Screenshot showing the panel before and after removing the task manager (48.74 KB, image/png)
2008-06-17 18:40 UTC, Elias Probst
Details
panel without taskmanager and colorchooser added (37.47 KB, image/png)
2008-07-23 13:39 UTC, Ingo Malchow
Details
systray taking too much space (22.78 KB, image/jpeg)
2009-01-20 13:03 UTC, Georgi Ivanov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2008-06-17 18:39:29 UTC
Version:            (using Devel)
Installed from:    Compiled sources

When removing the task manager from the panel, the other plasmoids residing in the panel move towards the center of the panel, which makes it look cluttered.

The plasmoids should stay at their places.

Will provide a screenshot/attachment.
Comment 1 Elias Probst 2008-06-17 18:40:15 UTC
Created attachment 25418 [details]
Screenshot showing the panel before and after removing the task manager
Comment 2 Jan Mette 2008-07-10 17:09:37 UTC
I would also like to see this (small) problem solved...

When i first encountered this stuff by removing the taskmanager, i expected that the systray and clock will behave like the other applets, e.g. not stretch to full width on the panel but just take the space they need to display and that they just move to the left, like the other applets too and "reveal" some free space in the panel... And i could add a spacer then to solve that, but if i add a spacer now (instead of the taskmanager), it doesnt move the systray + clock to the far right, as i would expect it... In fact, you need a _lot_ of spacers to solve it :)

In the end, the behaviour of the clock and systray applet is irritating to me, as they dont behave like the other applets...
Comment 3 Aaron J. Seigo 2008-07-16 19:59:10 UTC
*** Bug 166738 has been marked as a duplicate of this bug. ***
Comment 4 Aaron J. Seigo 2008-07-16 20:00:27 UTC
*** Bug 166737 has been marked as a duplicate of this bug. ***
Comment 5 Elias Probst 2008-07-16 21:11:46 UTC
Quick note: I need 22 spacers on a default sized panel (1680 width) to get the other applets back in their initial position after removing the task manager → not really JohnDoe compatible solution.
Comment 6 Ingo Malchow 2008-07-23 13:39:38 UTC
Created attachment 26357 [details]
panel without taskmanager and colorchooser added

same here, even more confusing, if you add something like the colorchooser
Comment 7 Janet 2008-07-23 15:01:39 UTC
There are no spacers anymore in KDE 4.0.99? But positioning the widgets still isn't possible in a "reasonable" way. Bug 167278 seems to be a duplicate.
Comment 8 Ladislav Nesnera 2008-07-28 17:26:02 UTC
Re: #7 From Janet
What do you mean by: ..positioning the widgets still isn't possible in a "reasonable" way?
Comment 9 Jonatan Wentzel 2008-07-28 17:47:18 UTC
I'm not sure what Janet means, but I would say that it would be reasonable to be able to move the widgets after having put them on the Panel. I am not able to do this.

Another problem is when I put the Panel on the left side of the screen. Then most icons become way too large (four widget icons take up almost half of the panel...).
Comment 10 Maciej Pilichowski 2008-07-28 18:07:42 UTC
Jonatan, please do not add issues to this report. This report is about removing task manager from panel. This and nothing else.

(for second you can open report, the first one is fixed for some time).
Comment 11 Ladislav Nesnera 2008-07-28 18:21:54 UTC
Re: #10 From Maciej
Hi Maciej. Do you know about a bug which talks only about managing position of widgets on the Panel? Thanks
Comment 12 Jonatan Wentzel 2008-07-28 18:28:41 UTC
My humble apologies
Comment 13 Maciej Pilichowski 2008-07-28 18:31:04 UTC
Ladislav, this one
http://bugs.kde.org/show_bug.cgi?id=154119
?
Comment 14 Janet 2008-07-29 01:11:00 UTC
Re #8:The method for positioning the icons on the panel is very clumsy: a) why in this extra mode and not simply use the middle mouse button? But that's not the topic of this bug report - so it's b): It's not possible to position widgets on the panel where I want to, after removing the task manager some widgets have halos bigger than the widget so e.g. it is impossible to drag the clock to the very right of the panel, to position the pager in the middle of the panel, to position the tray between pager and clock without tossing the pager to the very left. There's space enough in the panel to get the layout I want, the widgets just don't use it - or too much of it. If there were spacers for which the user could define the width or a grid it would be easier to get a nice and useful layout in the panel with or without task manager.
Comment 15 Alberto Gonzalez 2008-08-06 20:28:59 UTC
I'd describe this problem in a different way:

The Task Manager, when present on the panel, expands to occupy all the available space. This is fine and expected.

The System Tray and the Digital Clock applets also expand to occupy all the free space available, while they should stick to just the necessary size to show their contents.

When the System Tray and the Clock are on the same panel as the Task Manager, the Task Manager pushes them (it's stronger ;-) ) so they only occupy the needed space, but when they are in a different panel they can expand freely, and they do!

So the solution would be to have these two widgets to just use the necessary space and not expand to all the available free space in the panel. This is the same behavior as all other widgets except the Task Manager, so it should be possible to do it.

Moving the widgets is not the issue, once each one behaves as expected.
Comment 16 Tanja Schulte 2008-08-07 14:42:41 UTC
*No* other widget than the taskmanager should auto-occupy all possible space. 
Comment 17 Alassane 2008-08-16 07:34:14 UTC
I can confirm this bug. I find the new layout fine, but it could be irritating
Comment 18 Valerio Pilo 2008-09-03 19:59:42 UTC
Confirmed here too, my opinion is as of comment #15: every applet should only use the size that it strictly needs, and nothing more; the only 'expanding' one should be the Task Manager.
Comment 19 Sebastian Kügler 2008-11-18 03:43:44 UTC
*** Bug 167278 has been marked as a duplicate of this bug. ***
Comment 20 Marco Martin 2008-11-19 13:39:50 UTC
It no more does that in trunk.
Comment 21 Alberto Gonzalez 2009-01-13 16:56:30 UTC
I just installed KDE-4.1.96 (4.2-RC1) and the bug not fixed. Some widgets (notably the digital clock) use all the free space in the panel, pushing other widgets and messing the layout. Only the presence of the taskbar on the main (default) panel hides this behavior, but as soon as you use a second panel without a taskbar but with the digital clock the bug is inevitably visible.
Comment 22 Georgi Ivanov 2009-01-20 13:01:50 UTC
Same problems in RC2. My goal is to have to panels. In the bottom i will have panel with taskbar. On the top i want panel with digital clock and systray applet.
Right now systray take way too much space. Example in attachment.
Comment 23 Georgi Ivanov 2009-01-20 13:03:37 UTC
Created attachment 30455 [details]
systray taking too much space

systray taking too much space. Digital clock takes much space too . It's just systray is more greedy :)
Comment 24 Gerhard Hoogterp 2009-02-01 23:47:10 UTC
How and where is this fixed and resolved? After installing kde 4.2 today I'm still blessed with the same behavior.. A systray taking half the panel, the clock taking half of the rest and no empty space to be seen or found. Neither a way to resize either widget... 
Inquiring minds want to know..  
Comment 25 Elias Probst 2009-02-04 13:57:52 UTC
Can confirm it still happens in 4.2.
Reopening.
Comment 26 Mario 2009-02-08 11:38:55 UTC
I confirm it. It's very irritating.
Comment 27 Gabriel Speckhahn 2009-04-22 02:25:52 UTC
I can still confirm this on 4.2.2, is this issue being worked on? It's a quite frustrating bug :\
Comment 28 Aaron J. Seigo 2009-04-22 02:44:36 UTC
"is this issue being worked on?"

yes:

http://reviewboard.kde.org/r/581/

should be ready for 4.3. you can send your payment in cookies and glass beads to the Plasma team at your convenience.
Comment 29 Alberto Gonzalez 2009-04-22 11:21:53 UTC
Thanks for the update, great to know it's being worked on.

However, adding a spacer to the panel seems like a workaround. AFAIK, this bug is just about 3 applets (that I know of) being buggy when compared to the rest: digital clock, system tray and color chooser. These are the 3 applets that expand to use as much space as possible in the panel. Couldn't just they be fixed so that they would retract to use as little space as possible? This should solve the problem where it is, without having to add workarounds like a spacer.
Comment 30 Alberto Gonzalez 2009-04-23 12:35:44 UTC
I have tried a panel spacer applet and it does solve the problem correctly (if it's the best fix, I don't know, but it works).

The spacer plasmoid can be found here:
http://kde-look.org/content/show.php/Panel+Spacer?content=89304
Comment 31 Jaime Torres 2009-04-25 11:34:32 UTC
In svn trunk r954171 (kde 4.2.70) the space applet is included in plasma.
Comment 32 FiNeX 2009-04-25 22:41:52 UTC
System tray has been fixed today by Aaron for doesn't expanding when the taskbar is not on the panel. The same fix could be done on other plasmoids.
Comment 33 Ruchir Brahmbhatt 2009-05-01 13:37:29 UTC
yeah systray doesn't expand now. Still digital clock does. I think the plasmoids shouldn't expand. And spacer can be used to position the plasmoids as per user's wish.
Comment 34 FiNeX 2009-05-01 13:55:11 UTC
Color chooser should have been fixed too.

@Everybody: could a list of plasmoid which expands be wrote? It could be useful for developers. Many thanks.
Comment 35 Ruchir Brahmbhatt 2009-05-01 14:05:31 UTC
Digital clock.
Comment 36 Marco Martin 2009-05-07 21:06:59 UTC
fixed in trunk
Comment 37 Janet 2009-05-08 04:10:16 UTC
Activity Bar
Comment 38 Alberto Gonzalez 2010-12-31 14:43:54 UTC
I just installed KDE 4.5.4 on a new computer and I see this problem again: The clock applet expands as much as it can, and there seems to be no spacer anymore to fix the problem.

Was the spacer removed? Is it hidden under a strange name or in a strange package?
Comment 39 Alberto Gonzalez 2010-12-31 15:35:51 UTC
Sorry for the noise, the spacer is in the settings and I was looking for it in the widgets. Excuse me.