Bug 164265 - akregator crash on start
Summary: akregator crash on start
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: HI crash
Target Milestone: ---
Assignee: kdepim bugs
: 164821 164906 166569 166920 167924 168778 173474 174403 174862 174888 175095 175702 177369 (view as bug list)
Depends on:
Reported: 2008-06-17 07:48 UTC by miki
Modified: 2012-07-01 23:24 UTC (History)
29 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description miki 2008-06-17 07:48:10 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Application: Akregator (akregator), signal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0xb4a6c720 (LWP 1622)]
[KCrash handler]
#6  0xb339527d in QHash<QString, QList<Akregator::Feed*> >::detach (this=0x1d)
    at /usr/include/qt4/QtCore/qhash.h:286
#7  0xb3395bf0 in QHash<QString, QList<Akregator::Feed*> >::operator[] (
    this=0x1d, akey=@0xbfad1384) at /usr/include/qt4/QtCore/qhash.h:722
#8  0xb3390850 in Akregator::FeedList::findByURL (this=0x8250268, 
    at /home/mi/kde/src/KDE/kdepim/akregator/src/feedlist.cpp:313
#9  0xb3391af0 in Akregator::FeedList::findArticle (this=0x8250268, 
    feedURL=@0xbfad1384, guid=@0xbfad1388)
    at /home/mi/kde/src/KDE/kdepim/akregator/src/feedlist.cpp:329
#10 0xb33756ac in Akregator::ArticleDeleteJob::doStart (this=0x8316820)
    at /home/mi/kde/src/KDE/kdepim/akregator/src/articlejobs.cpp:64
#11 0xb337594d in Akregator::ArticleDeleteJob::qt_metacall (this=0x8316820, 
    _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfad1438)
    at /home/mi/kde/build/KDE/kdepim/akregator/src/articlejobs.moc:65
#12 0xb7dfc4f9 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#13 0xb7dfcbc2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#14 0xb7e03037 in ?? () from /usr/lib/libQtCore.so.4
#15 0xb7e0315c in ?? () from /usr/lib/libQtCore.so.4
#16 0xb7df7c9a in QObject::event () from /usr/lib/libQtCore.so.4
#17 0xb5455c0c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#18 0xb545a7a9 in QApplication::notify () from /usr/lib/libQtGui.so.4
#19 0xb7922e07 in KApplication::notify (this=0xbfad1b6c, receiver=0x8318368, 
    at /home/mi/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#20 0xb7de76a9 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#21 0xb7e151a1 in ?? () from /usr/lib/libQtCore.so.4
#22 0xb7e12a40 in ?? () from /usr/lib/libQtCore.so.4
#23 0xb4f60bf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#24 0xb4f63e5e in ?? () from /usr/lib/libglib-2.0.so.0
#25 0xb4f643ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#26 0xb7e12f98 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#27 0xb54e91b5 in ?? () from /usr/lib/libQtGui.so.4
#28 0xb7de692d in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#29 0xb7de6abd in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#30 0xb7de8d3d in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#31 0xb5455567 in QApplication::exec () from /usr/lib/libQtGui.so.4
#32 0x08050159 in main (argc=5, argv=0xbfad1c44)
    at /home/mi/kde/src/KDE/kdepim/akregator/src/main.cpp:115
#0  0xb7efe410 in __kernel_vsyscall ()
Comment 1 Matej Repinc 2008-06-24 17:03:30 UTC
Confirming the bug, and also when akregator crashes it looks like the shortcuts like ALT+F2 don't seem to work. When trying to go to system settings and selecting keyboard shortcuts I get "Failed to contact the KDE global shortcuts daemon
Message: The name org.kde.kded was not provided by any .service files
Error: org.freedesktop.DBus.Error.ServiceUnknown".
Comment 2 Bram Schoenmakers 2008-06-25 11:03:21 UTC
*** Bug 164906 has been marked as a duplicate of this bug. ***
Comment 3 Frank Osterfeld 2008-06-26 20:16:25 UTC
SVN commit 824854 by osterfeld:

Sanitize findByURL. This stops leaking empty QLists using operator[] and and maybe also fixes the crash in 164265
Needs to be merged into trunk/

 M  +13 -14    feedlist.cpp  
 M  +11 -11    feedlist.h  

WebSVN link: http://websvn.kde.org/?view=rev&revision=824854
Comment 4 Rolf Eike Beer 2008-07-04 07:38:34 UTC
*** Bug 164821 has been marked as a duplicate of this bug. ***
Comment 5 auxsvr 2008-07-16 17:59:53 UTC
Using KDE 4.1 RC1 I get a similar crash when akregator starts:

Application: Akregator (akregator), signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[New Thread 0xb50c36d0 (LWP 17083)]
[KCrash handler]
#6  0xb363ee02 in QHash<QString, QList<Akregator::Feed*> >::findNode (
    this=0x1c, akey=@0xbfb3ffac, ahp=0x0) at /usr/include/QtCore/qhash.h:862
#7  0xb363d7aa in Akregator::FeedList::findByURL (this=0x83ba6b8, 
    feedURL=@0xbfb3ffac) at /usr/include/QtCore/qhash.h:852
#8  0xb363d97c in Akregator::FeedList::findArticle (this=0x83ba6b8, 
    feedURL=@0xbfb3ffac, guid=@0xbfb3ffb0)
    at /usr/src/debug/kdepim-4.0.98/akregator/src/feedlist.cpp:328
#9  0xb3625b75 in Akregator::ArticleDeleteJob::doStart (this=0x8559468)
    at /usr/src/debug/kdepim-4.0.98/akregator/src/articlejobs.cpp:64
#10 0xb3625e35 in Akregator::ArticleDeleteJob::qt_metacall (this=0x8559468, 
    _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb40068)
    at /usr/src/debug/kdepim-4.0.98/build/akregator/src/articlejobs.moc:65
#11 0xb65af3fa in QMetaObject::activate (sender=0x855dc68, 
    from_signal_index=4, to_signal_index=4, argv=0x0)
    at kernel/qobject.cpp:3007
#12 0xb65af972 in QMetaObject::activate (sender=0x855dc68, m=0xb6638a08, 
    local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3080
#13 0xb65b6547 in QSingleShotTimer::timeout (this=0x855dc68)
    at .moc/release-shared/qtimer.moc:74
#14 0xb65b666c in QSingleShotTimer::timerEvent (this=0x855dc68)
    at kernel/qtimer.cpp:300
#15 0xb65abd1f in QObject::event (this=0x855dc68, e=0xbfb4050c)
    at kernel/qobject.cpp:1105
#16 0xb5a8decc in QApplicationPrivate::notify_helper (this=0x8068490, 
    receiver=0x855dc68, e=0xbfb4050c) at kernel/qapplication.cpp:3772
#17 0xb5a9431e in QApplication::notify (this=0xbfb40884, receiver=0x855dc68, 
    e=0xbfb4050c) at kernel/qapplication.cpp:3366
#18 0xb6d2383d in KApplication::notify (this=0xbfb40884, receiver=0x855dc68, 
    at /usr/src/debug/kdelibs-4.0.98/kdeui/kernel/kapplication.cpp:311
#19 0xb659db51 in QCoreApplication::notifyInternal (this=0xbfb40884, 
    receiver=0x855dc68, event=0xbfb4050c) at kernel/qcoreapplication.cpp:583
#20 0xb65c6181 in QTimerInfoList::activateTimers (this=0x806b70c)
    at kernel/qcoreapplication.h:215
#21 0xb65c63fb in QEventDispatcherUNIX::processEvents (this=0x806ad80, flags=
      {i = -1078721016}) at kernel/qeventdispatcher_unix.cpp:899
#22 0xb5b180a2 in QEventDispatcherX11::processEvents (this=0x806ad80, flags=
      {i = -1078720568}) at kernel/qeventdispatcher_x11.cpp:154
#23 0xb659c2ca in QEventLoop::processEvents (this=0xbfb40830, flags=
      {i = -1078720504}) at kernel/qeventloop.cpp:149
#24 0xb659c48a in QEventLoop::exec (this=0xbfb40830, flags={i = -1078720456})
    at kernel/qeventloop.cpp:196
#25 0xb659e66d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#26 0xb5a8dd47 in QApplication::exec () at kernel/qapplication.cpp:3304
#27 0x0804eb97 in main (argc=)
    at /usr/src/debug/kdepim-4.0.98/akregator/src/main.cpp:115
#0  0xffffe430 in __kernel_vsyscall ()
Comment 6 Matej Repinc 2008-07-16 19:29:25 UTC
Well Akregator seems to work just fine in RC1, installed from Kubuntu binary packages. The problem remains in trunk.
Comment 7 auxsvr 2008-07-16 19:37:11 UTC
Thanks for the feedback, Matej. It seems that akregatorrc was the cause of the crash here. It works fine now.
Comment 8 Christophe Marin 2008-07-18 21:00:31 UTC
*** Bug 166569 has been marked as a duplicate of this bug. ***
Comment 9 Christophe Marin 2008-07-18 21:00:39 UTC
*** Bug 166920 has been marked as a duplicate of this bug. ***
Comment 10 G360 2008-07-29 19:56:18 UTC
Is bug http://bugs.kde.org/show_bug.cgi?id=116482 not related?
Comment 11 Christophe Marin 2008-07-29 20:25:38 UTC
> Is bug http://bugs.kde.org/show_bug.cgi?id=116482 not related?

No it's another issue.
Comment 12 S Clark 2008-07-30 02:18:01 UTC
I'm not sure if this is really the same as #166569...however, I can dump my feeds.opml and archive contents somewhere if it'll help.
Comment 13 miki 2008-07-30 07:50:41 UTC
after clean settings in ./kde folder everything is ok 
Comment 14 S Clark 2008-08-01 21:38:38 UTC
Update related to my report (#166569, which was apparently marked as a duplicate of this one) - I completely deleted the .kde/share/apps/akregator directory and the .kde/share/config/akregator* files.  I opened a akregator.  I deleted the "KDE" default feeds.  I added a single feed ( http://www.twis.org/audio/podcast.rss , though I suspect the feed's not at fault here ).  I configure the feed to check every 5 days, and limit to 20 articles.  I exit.  I attempt to restart akregator: segfault again.

I've tried it without deleting the KDE default feeds as well - same results.

AMD64, gcc 4.3.1, KDE 4.1.0 release source complied from Gentoo's KDE4 overlay.
Comment 15 S Clark 2008-08-02 00:37:11 UTC
(One additional followup - the same set of files opens fine, repeatedly, with my old parallel install of Akregator from KDE 3.5.9, so I'm guessing it's not a magically repeatedly-"corrupted" file problem.)
Comment 16 Florian Kriener 2008-08-02 12:02:21 UTC
I tried that, cleaning akregator related files from ~/.kde4 (commetn #13), but it does not work for me using KDE 4.1.0, Akregator 1.2.50. Could one set this bug back to new?
Comment 17 Christophe Marin 2008-08-03 02:14:17 UTC
Comment 18 Christophe Marin 2008-08-03 02:14:35 UTC
*** Bug 167924 has been marked as a duplicate of this bug. ***
Comment 19 Christophe Marin 2008-08-08 22:47:21 UTC
*** Bug 168778 has been marked as a duplicate of this bug. ***
Comment 20 S Clark 2008-09-04 21:12:02 UTC
And another followup, I can confirm this is still a problem in 4.1.1...
Anything I can supply from this end that might help solve this one?  Akregator and k3b are the only two KDE 3.5.x applications remaining that make me keep the 3.5.x install in parallel on my machine here.
Comment 21 Johannes Felko 2008-09-08 16:09:35 UTC
Used System is Kubuntu 8.04 with KDE 4.1.1
here is a paste of the Crashmanager 
Comment 22 Dirk Ruediger 2008-09-21 14:30:04 UTC
I also confirm the behavior. I use  Kubuntu 8.04 with KDE 4.1.1. You find the  paste of the Crashmanager at http://paste.ubuntu.com/48882/
Comment 23 Steffen Schloenvoigt 2008-09-26 08:38:44 UTC
Same here.
If I remove ~/.kde4/share/apps/akregator/Archive/* Akregator starts again. But if i pull the feeds, quit akregator and try to start it again, it crashes with the following dump http://paste.ubuntu.com/50747/

Hope that helps and I can soon start to use the KDE4 PIM-Suite.
Comment 24 Sergei Andreev 2008-09-26 08:55:43 UTC
The things are really even worse: akregator not only crashes itself but the whole kontact.
Comment 25 Steffen Schloenvoigt 2008-09-30 21:17:33 UTC
Ok, I removed and readded all of my feeds and found the one that seems to make problems: Its the RSS Feed of sueddeutsche.de found under
If this feed is removed from feeds.opml akregator starts without problems, if I add it again, close akregator und start it again, the problem returns.
Why is this feed causing so much trouble?
Comment 26 Georges 2008-10-12 18:56:25 UTC
I can confirm this bug.
It happens on my Debian machine (lenny) using kde 4.1.2 and on my gentoo machine using the same 4.1.2.
On the first start it works fine... after deleting the default feeds and adding my standard feeds, it crashes and won't start again.
The used feeds are the following:
- lwn.net
- phoronix.com
- heise.de
- planetkde.org

Architecture, both amd64.
Comment 27 Gudlaugur Johannesson 2008-10-15 08:15:29 UTC
I can confirm this bug on OpenSUSE 11.0, Version 1.3.1, Using KDE 4.1.2 (KDE 4.1.2) "release 44.5".  This bug occurs when you limit the number of article stored in the archive.  Changing the archiveMode in the feeds.opml file in .kde4/share/apps/akregator/data to globalDefault makes akregator start normally again.
Comment 28 Marc Bianciotto 2008-10-19 17:24:31 UTC
I am not able to confirm this workaround. It does not work for me on KDE 4.1.2 (Kubuntu 8.04 w/ ppa repos). removing ./.kde4/share/apps/akregator/Archive/* is still needed here to make akregator start again.
Comment 29 Frank Osterfeld 2008-10-19 20:10:20 UTC
SVN commit 873573 by osterfeld:

don't crash on startup when expiry is enabled

 M  +24 -7     articlejobs.cpp  
 M  +5 -4      articlejobs.h  
 M  +7 -6      expireitemscommand.cpp  
 M  +12 -11    kernel.cpp  
 M  +17 -8     mainwidget.cpp  
 M  +3 -1      mainwidget.h  

WebSVN link: http://websvn.kde.org/?view=rev&revision=873573
Comment 30 Frank Osterfeld 2008-10-19 20:11:02 UTC
SVN commit 873575 by osterfeld:

backport 873573: don't crash on startup when expiry is enabled

 M  +24 -7     articlejobs.cpp  
 M  +5 -4      articlejobs.h  
 M  +7 -6      expireitemscommand.cpp  
 M  +17 -8     mainwidget.cpp  
 M  +5 -2      mainwidget.h  

WebSVN link: http://websvn.kde.org/?view=rev&revision=873575
Comment 31 Dmitry Suzdalev 2008-10-24 11:02:15 UTC
Still crashes for me in trunk.
I removed [Archive] section from akregatorrc (and tried to remove that whole file too - didn't help). 
Also I removed all maxArticleCount entries from feeds.opml. Didn't help too.

Crashes are happening at startup and 100% reproducible.

Here's the backtrace:

Application: Akregator (akregator), signal SIGSEGV

Thread 1 (Thread 0xb4cb2b00 (LWP 3623)):
[KCrash Handler]
#6  0xb343458b in Akregator::FeedList::findByID (this=0x0, id=1174317961) at /home/ulet/kde-svn/kdepim/akregator/src/feedlist.cpp:390
#7  0xb3462035 in Akregator::ExpireItemsCommand::Private::createDeleteJobs (this=0x9d69c28) at /home/ulet/kde-svn/kdepim/akregator/src/expireitemscommand.cpp:89
#8  0xb3462127 in Akregator::ExpireItemsCommand::qt_metacall (this=0x9d6d068, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc82048)
    at /home/ulet/kde-svn/build/kdepim/akregator/src/expireitemscommand.moc:67
#9  0xb6de7d8a in QMetaObject::activate (sender=0x9d69cc0, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3025
#10 0xb6de8302 in QMetaObject::activate (sender=0x9d69cc0, m=0xb6e71dc4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3098
#11 0xb6deee57 in QSingleShotTimer::timeout (this=0x9d69cc0) at .moc/release-shared/qtimer.moc:74
#12 0xb6deef7c in QSingleShotTimer::timerEvent (this=0x9d69cc0) at kernel/qtimer.cpp:300
#13 0xb6de466f in QObject::event (this=0x9d69cc0, e=0xbfc824fc) at kernel/qobject.cpp:1117
#14 0xb65061ec in QApplicationPrivate::notify_helper (this=0x9b1a4f0, receiver=0x9d69cc0, e=0xbfc824fc) at kernel/qapplication.cpp:3809
#15 0xb650c62e in QApplication::notify (this=0xbfc82774, receiver=0x9d69cc0, e=0xbfc824fc) at kernel/qapplication.cpp:3399
#16 0xb729c76b in KApplication::notify (this=0xbfc82774, receiver=0x9d69cc0, event=0xbfc824fc) at /home/ulet/kde-svn/kdelibs/kdeui/kernel/kapplication.cpp:307
#17 0xb6dd6541 in QCoreApplication::notifyInternal (this=0xbfc82774, receiver=0x9d69cc0, event=0xbfc824fc) at kernel/qcoreapplication.cpp:589
#18 0xb6e001a1 in QTimerInfoList::activateTimers (this=0x9b1fcf4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 0xb6dfcd20 in timerSourceDispatch (source=0x9b1fcc0) at kernel/qeventdispatcher_glib.cpp:166
#20 0xb56f61b8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#21 0xb56f9853 in ?? () from /usr/lib/libglib-2.0.so.0
#22 0x09b1f220 in ?? ()
#23 0x00000000 in ?? ()

Comment 32 Steffen Schloenvoigt 2008-10-24 21:03:01 UTC
r875380 seems to have fixed it for me. 
Thank you very much!
Comment 33 Frank Osterfeld 2008-10-27 20:55:17 UTC
Comment 34 Frank Osterfeld 2008-10-27 21:01:02 UTC
*** Bug 173474 has been marked as a duplicate of this bug. ***
Comment 35 Frank Osterfeld 2008-11-09 22:55:12 UTC
*** Bug 174403 has been marked as a duplicate of this bug. ***
Comment 36 Frank Osterfeld 2008-11-11 13:52:41 UTC
*** Bug 174862 has been marked as a duplicate of this bug. ***
Comment 37 Christophe Marin 2008-11-11 21:50:02 UTC
*** Bug 174888 has been marked as a duplicate of this bug. ***
Comment 38 Oliver Putz 2008-11-19 09:27:49 UTC
*** Bug 175095 has been marked as a duplicate of this bug. ***
Comment 39 Frank Osterfeld 2008-11-21 10:35:31 UTC
*** Bug 174821 has been marked as a duplicate of this bug. ***
Comment 40 Frank Osterfeld 2008-11-21 11:54:10 UTC
*** Bug 175702 has been marked as a duplicate of this bug. ***
Comment 41 Dario Andres 2008-12-10 11:47:58 UTC
*** Bug 177369 has been marked as a duplicate of this bug. ***