Bug 164139 - Background color for the date in Kclockapplet does not change
Summary: Background color for the date in Kclockapplet does not change
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kicker
Classification: Plasma
Component: kclockapplet (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Gebauer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-15 14:00 UTC by Victor Marin
Modified: 2009-09-08 00:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Marin 2008-06-15 14:00:16 UTC
Version:            (using KDE 3.5.9)
Installed from:    Ubuntu Packages
OS:                Linux

Hi,
Background color for the date in Kclockapplet does not change when it does the colour of the panel. It happens when changing desktop theme and the colour for the KDE panel it's set up to match the desktop colour. While it works Ok the change of the background colour for the time.

Regards,
Victor
Comment 1 Pino Toscano 2008-06-15 14:11:12 UTC

*** This bug has been marked as a duplicate of 98398 ***
Comment 2 Victor Marin 2008-06-15 20:27:57 UTC
Hi,
IMHO, this is not exactly the same bug as 98398, as the color currently changes right for the time, but not for the date. At lesat this was not specified in the previous bug.

So, it seems this bug was resolved for the time displayed (at least it works Ok on my computer), but the bug remains for the date. 

Rgds,
Victor
Comment 3 Victor Marin 2008-06-15 20:49:54 UTC
This bug relating the color of the background for the date, it happens with or also without enabling transparency. 

And when enabling transparency for the panel. . the kclockapplet does not follow it, either for the time nor for the date. 

It is a small bug, anyway. But, one has to see it all the time. After 3 years since it was similarly reported for the first time, and for an -otherwise- very good desktop environment like it is KDE, it just makes a feeling of being a not so well finished app. Just a feeling. .   

Comment 4 gambas 2008-08-18 22:04:05 UTC
Fixed in KDE 3.5.10.
Comment 5 Victor Marin 2008-08-20 13:45:08 UTC
Thanks for that.
Comment 6 FiNeX 2008-09-06 11:30:55 UTC
It has not been fixed in KDE 3.5.10, I've just tested it :-(
Comment 7 gambas 2008-09-06 12:08:06 UTC
Maybe I didn't understand the bug report which was not very well written. What are you talking about? Do you mean that the clock applet background does not follow the color theme when it changes? It works on my machine, provided that the background colors set in the clock dialog are equal to the window background specified in the color theme (this is by design).
Comment 8 FiNeX 2008-09-06 12:56:51 UTC
Actually, my current settings of clock applet use the same background color for both date and time which is the same of the background window color of KDE.

When I change the color scheme of KDE, the background color setting of the time is changed too, but not the background color setting of the date.
Comment 9 FiNeX 2009-09-08 00:02:38 UTC
Kicker is no more mantained and all bugs/wishes will not be fixed/implemented in KDE3. A list of the most interesting/unresolved issues which is still valid for KDE4 has been created. Before reopening old kicker bugs on KDE4 Plasma, please try the new KDE 4.3.1, check the current behaviour and, only if you find new bugs or if you need a particular feature, open a new bug report.

Remember that KDE 4 is a full rewrite of KDE 3 so some old features will not be re-implemented because the behaviour has be changed a lot on some sides.

Thanks for the comprehension and enjoy the new KDE 4!

-- 
FiNeX & D. Andres