Bug 163991 - import images from picasa webalbum
Summary: import images from picasa webalbum
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-WebService-Google (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 21 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-13 19:47 UTC by Bro
Modified: 2018-08-22 12:36 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bro 2008-06-13 19:47:33 UTC
Version:            (using KDE 3.5.9)
Installed from:    Mac OS X (Fink) Packages

Hi,

It is very nice to be able to export pictures to picasa webalbum (which I havn't done yet). Could it also be possible to do the other way round: importing pictures from a picasa web album into digikam (with keywords, geolocation,... if possible, but IMHO, images would be a great start, especially for mac users who cannot do it other wise -private album).


I love digikam, keep going the great job.

Thanks.


Bro.
Comment 1 caulier.gilles 2009-09-29 22:34:28 UTC
PicasaWeb export is already implemented...

Gilles Caulier
Comment 2 caulier.gilles 2009-09-29 22:35:33 UTC
oups, it's about import not export
Comment 3 Jens Mueller 2010-02-04 21:35:52 UTC
SVN commit 1085306 by jmueller:

Added basic import support. Need to find a better ui (anonymous support, other poeple support, custom uri support (private collections), selection of images to download (showing readed thumbUrls), ...)

CCBUGS: 163991

 M  +24 -0     picasawebitem.h  
 M  +132 -20   picasawebtalker.cpp  
 M  +11 -8     picasawebtalker.h  
 M  +3 -17     picasawebwidget.cpp  
 M  +0 -6      picasawebwidget.h  
 M  +117 -6    picasawebwindow.cpp  
 M  +4 -3      picasawebwindow.h  
 M  +46 -4     plugin_picasawebexport.cpp  
 M  +6 -3      plugin_picasawebexport.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1085306
Comment 4 Smit Mehta 2012-04-19 10:12:56 UTC
Hi Gilles

Histroy shows that you changed its status from being fixed -> unconfirmed. Is there any problem to be fixed yet?

Smit
Comment 5 caulier.gilles 2012-04-19 10:49:19 UTC
Don't remember especially. but as i can see Import is already implemented by commit 1085306 from Jens, since a long time.

The question is : this entry still valid ?

Gilles Caulier
Comment 6 Smit Mehta 2012-04-19 12:41:31 UTC
No, I dont think so its still valid. The import has been implemented and its working fine in 2.6.0beta3. I think we should change the status to resolved/fixed.
Comment 7 caulier.gilles 2012-04-19 12:43:23 UTC
ok fine. You can do it. Don't forget to patch kipi-plugins NEW file.

Gilles Caulier
Comment 8 Smit Mehta 2012-04-19 12:47:58 UTC
Git commit f02f0f98730428dd1954ae080fd9ae80d9fa26c8 by smit mehta.
Committed on 19/04/2012 at 14:46.
Pushed by smitmehta into branch 'master'.

closing the bug.

M  +2    -1    NEWS

http://commits.kde.org/kipi-plugins/f02f0f98730428dd1954ae080fd9ae80d9fa26c8