Bug 163634 - Usability: function of the (white, green and blue) panel-resizing arrows is not obvious
Summary: Usability: function of the (white, green and blue) panel-resizing arrows is n...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: containment-panel (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 164147 166395 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-09 17:39 UTC by monstermunch
Modified: 2008-09-05 19:17 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description monstermunch 2008-06-09 17:39:55 UTC
Version:            (using Devel)

For reference, this is what the 'control panel' for resize a panel looks like at the moment:
http://img164.imageshack.us/my.php?image=panelcontrollereq6.png

Just from looking at the screenshot, it's very obvious how to change the justification of the panel (i.e. the icons give a strong hint what they do from the way they look), add widgets and remove the panel. Resizing the panel horizontally  is less obvious as the arrows are a unfamiliar widget but the arrows do look draggable. 

However, how to resize the panel and move it is much less obvious. The way resizes/moving works copies how window titlebars do this (i.e. dragging and stretching titlebar moves/resizes the window). From looking at the configuration panel, it just was not obvious to me that this was possible (the config panel looks nothing like a title bar window and is not part of the panel so I didn't expect resize/moving this to change the panel). I found it through experimentation but I would hope there would be a way to make it more obvious how to alter the panel. Also, even when you find the drag to move location, you are only given feedback when the panel snaps to one of the edges.

Some ideas:

* add a "resize panel" and "move panel" button. Very obvious and would act like when you select move/resize from a right-click window title bar menu. I find going from a menu click to what feels like a dragging action (except you aren't dragging) a bit weird though.

* Add a (not sure what the word is) gripper icon to the corner of the configuration panel (like the ones in the corner of windows). Some kind of arrow, dotted etc. thing to make it look like you can grab it.

* Have a "move" hover icon appear when you are in the area that you can click/drag to move the window. At the moment, nothing appears.

* Have a "click and drag this area to move the panel" label. Maybe a little ugly.

* Just have 4 icons for each of the four edges of the screen the panel can attach to. This would be similar to the old KDE3 configuration screen and how the justification look i.e. have a top, left, right, bottom icon that instantly move the panel to that edge on click. Not great for multiple monitors though.

* Perhaps continue with the idea of the coloured arrows used for resizing horizontally to resizing vertically. This would be nice and consistent as you are reusing the same concept and you could just add have a "drag arrows to resize the panel" label to make it really clear.  In the above screenshot, you would, for instance, add a horizontal pointing blue arrow to the top left corner of the panel. Grabbing this would resize vertically.
Comment 1 Michael 2008-06-12 17:23:58 UTC
I miss the presets (normal, small, tiny) to quickly resize the panel! Free-form is nice but a preset option would make it more consistent on multiple machines. 
Comment 2 monstermunch 2008-06-12 17:37:11 UTC
This was a little unclear in my original post, but how to vertically resize a horizontal panel is what is not obvious (and vice versa for vertical panels) to me.
Comment 3 Aaron J. Seigo 2008-06-12 17:50:49 UTC
@Michael: "a preset option would make it more consistent on multiple machines."

at some point we'll be providing "sticky points" at particularly good sizes (e.g. for the icon sizes) which will give you this.
Comment 4 Aaron J. Seigo 2008-06-16 01:00:13 UTC
*** Bug 164147 has been marked as a duplicate of this bug. ***
Comment 5 Will Stephenson 2008-06-16 10:17:40 UTC
The resize handle is hard to spot; how about as well as the control panel edge being used to start resize, put a larger 'handle area' extending down into the control panel in the center of the edge that invites a drag?  "Oi mate, fancy a drag on this funny egyptian cigarette?"
Comment 6 Maciej Pilichowski 2008-06-16 13:11:01 UTC
My cents: adjust/move is easy comparing to drag&drop panel. Mostly because the metaphor of dragging is so sophisticated nobody saw it before -- it took me several days (and knowing in advance it is possible at all), that in order to drag a panel you cannot drag it :-) You have to drag the remote control pane!

This is plain wrong -- D&D UI is well established now, don't change it. If user wants to drag the panel (in unlocked) mode, let him/her do it.
Comment 7 Alex Merry 2008-08-06 21:42:11 UTC
There are tooltips on the arrows now that tell you what they do.  Eg: the white arrow says "Move this slider to set the panel position", the blue arrow "Move this slider to set the maximum panel size" and the green arrow "minimum" respectively.

There is also a "grip" at the top of the panel toolbox that has the three little dots that indicate a movable grip (like on splitters in windows that you can move), and the mouse changes cursor to a resize arrow and the grip lights up when you hover on it.

The widgets on the panel get "move" icons in the centre when they are hovered over, indicating they can be moved around.

The only thing left without a hint is moving the panel itself, but I'd have thought that deduction would lead users to conclude that, since the panel can't be moved from the panel itself (due to the widgets being in the way), the only place left to move it from is the blank area in the toolbox.

Does this satisfy the reporter?
Comment 8 Maciej Pilichowski 2008-08-07 11:55:59 UTC
Alex -- I am not reporter but for me UI is obscure (except for moving items on panels which is almost perfect). And it is not the matter of explaining, that user will read long "how to" -- GUI should be self-explanatory, after all those are the most basic tasks.

Just from the start -- white arrow, blue arrow, and green arrow. So they differ only in color -- wrong UI, those are fundamentals. 
Comment 9 Alex Merry 2008-08-12 17:57:48 UTC
*** Bug 166395 has been marked as a duplicate of this bug. ***
Comment 10 Alex Merry 2008-08-12 18:00:31 UTC
Maciej suggested distinct icons for "starting point", "minimum size" and "maximum size", possibly along the lines of

||
|->
->|

to replace the white, blue and green triangles in the duplicate bug report.
Comment 11 Alex Merry 2008-08-23 16:07:33 UTC
We now have a "move" button (with the same move icon as the widgets have when you hover over them) in the panel toolbox, so that should be pretty self-explanatory.

The resizing arrows need some thinking about, though.  One of the issues is that, however they look, they need to be able to reach the edge of the screen.
Comment 12 Alex Merry 2008-09-05 19:17:04 UTC
Martin's done considerable work on this.  See http://www.notmart.org/images/newpanelcontroller.png